1. sandraxoxo's Avatar
    I've actually had my Inspire for a while now, I would like to say around 6 months? Maybe a little less, but around there. Anyways, for the past month or so I've been having insane lag. The screen would lag, or the key board would lag. And it's quite severe lag, it could freeze up anywhere between 10seconds to 10 minutes. Rebooting doesn't seem to help and my mobile network is almost always off, so it's probably not my apps. Is this typical of the phone? Should I bring it in and see if there's something wrong? Or should I just deal it with for another year and a half.
    The lag is occasional and pretty random.
    09-15-2011 08:18 PM
  2. elslunko's Avatar
    I've had mine for a couple of weeks but managed to make it pretty laggy (even after rebooting) after installing a whole bunch of apps. It became noticeably laggy after installing various launchers, keyboards, and other visual mods then trying to return back to Sense. Even after uninstalling those modifying apps the lag persisted and Sense would randomly need to reload.

    Eventually I wiped the device and that fixed the issue.
    09-15-2011 10:25 PM
  3. RoboWarrior's Avatar
    I had similar problems and I returned it for warrrenty and absolutely no lag with the replacement.
    09-16-2011 12:03 AM
  4. shansmi's Avatar
    Try doing a factory reset then add the apps back a few at a time until you find the problematic apps. Try not to install duplicate type apps like weather Widgets etc that do the same function where they all run in the background. I noticed the HTC weather widget doing this on my inspire and whatever tmo is calling their latest 2.3.4 device. Beweather does not cause this on the inspire or infuse. You could see it "loading" when coming out of sleep mode.
    09-16-2011 06:55 AM
  5. Ashley Payne's Avatar
    I have had my phone for over a year now and I've had the freezing, lagging problems. Even when I write all of a sudden it'll start vibrating because of what I just wrote out. It's nuts. So rebooting, reseting, and turning it off and on doesn't help. This is my third phone with in a year due to this. So doe anyone have any idea what to do?
    12-13-2012 11:58 AM
LINK TO POST COPIED TO CLIPBOARD