Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  
    iReaperrr's Avatar

    Posts
    16 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Contact's number shows up in Messaging instead of name

    So my mom (previous owner) said she stopped using this phone because it started getting glitchy after the 2.3.3 update. So I said, "I don't care, I want to use it because it's a better phone" so ever since I started using it, I've noticed one thing, that in Messaging the contact's number shows up rather than their contact name. Example:

    Contact: John Doe
    Number: +18005555555

    *goes to messaging*

    Me: Hello.
    +18005555555: Hey!

    That's how almost all my texts have shown up. (if I have their number stored)

    Is anyone else having this problem?
  2. #2  
    The Architect's Avatar

    Posts
    89 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Carrier
    Stock

    Default Re: Contact's number shows up in Messaging instead of name

    It's a known issue. There are other threads discussing it in more detail. It seems the common answer is "use a third party SMS client"

    Personally, I just exit and restart the messages app/widget and it corrects it self. I've had the Inspire for over a year, and I don't even notice it anymore.
  3. #3  
    BusyManNVA's Avatar

    Posts
    16 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Carrier
    Stock

    Default Re: Contact's number shows up in Messaging instead of name

    I use GO SMS for messaging and have found that when this starts happening, it means I have too many messages saved. I go through and delete a bunch, restart the app, and it goes back to working fine. Don't know if this would fix the issue in the stock messaging app, if that's what you're using.
  4. #4  
    pazzo02's Avatar

    Posts
    1,130 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Carrier
    Sabsa Prime ICS

    Default Re: Contact's number shows up in Messaging instead of name

    Although I'm rooted now, I did experience this problem with the GB update (part of the reason I finally rooted). I started using Hnadcent and never experienced the problem again. There was never an official fix for this, so yes, using a 3rd party app is the standard solution.
  5. Thread Author  Thread Author    #5  
    iReaperrr's Avatar

    Posts
    16 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Contact's number shows up in Messaging instead of name

    Thanks, so I'll be downloading Handcent. (again, because on my Huawei Fusion, I used it as well.)
  6. #6  
    Gates Is Antichrist's Avatar

    Posts
    30 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Contact's number shows up in Messaging instead of name

    SIMPLE FIX. I see so many complicated explanations, and don't know why no one else says the following which is 100% effective for me.. Go Settings/General/Apps. Scroll to Messaging and click it. Click "force stop" (don't worry, it's not as radical as you might fear).

    Now back all the way out and click your message icon. At least for me, names now appear instead of numbers.

Posting Permissions

";