1. iReaperrr's Avatar
    So my mom (previous owner) said she stopped using this phone because it started getting glitchy after the 2.3.3 update. So I said, "I don't care, I want to use it because it's a better phone" so ever since I started using it, I've noticed one thing, that in Messaging the contact's number shows up rather than their contact name. Example:

    Contact: John Doe
    Number: +18005555555

    *goes to messaging*

    Me: Hello.
    +18005555555: Hey!

    That's how almost all my texts have shown up. (if I have their number stored)

    Is anyone else having this problem?
    05-02-2012 08:24 AM
  2. The Architect's Avatar
    It's a known issue. There are other threads discussing it in more detail. It seems the common answer is "use a third party SMS client"

    Personally, I just exit and restart the messages app/widget and it corrects it self. I've had the Inspire for over a year, and I don't even notice it anymore.
    05-02-2012 09:11 AM
  3. BusyManNVA's Avatar
    I use GO SMS for messaging and have found that when this starts happening, it means I have too many messages saved. I go through and delete a bunch, restart the app, and it goes back to working fine. Don't know if this would fix the issue in the stock messaging app, if that's what you're using.
    05-03-2012 10:02 AM
  4. pazzo02's Avatar
    Although I'm rooted now, I did experience this problem with the GB update (part of the reason I finally rooted). I started using Hnadcent and never experienced the problem again. There was never an official fix for this, so yes, using a 3rd party app is the standard solution.
    05-04-2012 08:27 AM
  5. iReaperrr's Avatar
    Thanks, so I'll be downloading Handcent. (again, because on my Huawei Fusion, I used it as well.)
    05-15-2012 10:27 PM
  6. Gates Is Antichrist's Avatar
    SIMPLE FIX. I see so many complicated explanations, and don't know why no one else says the following which is 100% effective for me.. Go Settings/General/Apps. Scroll to Messaging and click it. Click "force stop" (don't worry, it's not as radical as you might fear).

    Now back all the way out and click your message icon. At least for me, names now appear instead of numbers.
    12-01-2016 06:15 AM
LINK TO POST COPIED TO CLIPBOARD