Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Default Having problems I can't figure out

    For some reason when I get a call or make a call the phone goes directly to speakerphone. Anyone know how to fix this?

    Also another thing I am having problems with is with the weather. It did find my city at first but now it switched to a different city on its own and now it won't find mine. I live near St. Louis and it won't even find that city when I search for it.
  2. #2  
    zhelf's Avatar

    672 Posts
    Global Posts
    1,787 Global Posts


    it could be the sensor that switches to speaker when you flip the phone over that is messing it up try disabling that in settings>sound then uncheck flip for speaker

    htc does not have every city in its database which really sucks but you probably had your gps on so it found your city then disabled your gps so it goes to the nearest one in its database.
    Windows Phone:Lumia 920
    Android: Nexus 4
    iOS: iPhone 5
  3. Thread Author  Thread Author    #3  


    It's not the flip for speaker setting because I disabled that and it still does it.
  4. #4  


    This is sad... I have had my phone for almost a week now and just realized my phone is also defaulting to coming on with the speakerphone turned on when I answer calls. I have tried everything and can't figure out what is going on. Are we the only two with this problem? I have an otherwise completely un-buggy phone.

    update: I went on HTC's help page, they did not have an answer to this question but almost all of their answers were to soft reset the phone. I did it and it has cleared up the problem for me.

    To soft reset, turn off the phone and remove the battery for about 10 seconds. Piece of cake. (Anybody that can't get the battery door open needs to man up a bit here. It is not easy but it is not like it is fort knox or anything.)
    Last edited by bmolloy; 02-18-2011 at 03:17 PM.

Posting Permissions