Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default Contacts, sim card, SD card, and Google sync issues

    Hi, I'm hoping someone can help me solve one/all of these problems.

    I had all my contacts stored on my sim card. This is how they were on my last phone (Blackjack) and the guy at the AT&T store just copied them all from my old sim card onto my new sim card, and put the new sim card in my htc Inspire.

    I was told that Android will automatically back up all your contacts to your gmail account, and if you ever lose your phone or get a new phone or whatever, you can copy them back to your phone this way. However, I noticed that my phone was not doing that. Despite having 200 contacts on my phone (sim card), my gmail account had 0 Android contacts listed.

    I read the forums and found out that you need to copy contacts from your sim card to your gmail account, and I followed the instructions to do this, which were as follows:

    - go into settings and temporarily disable google sync
    - go into "people" and to menu --> Export to SD card
    - go into settings --> manage applications --> contacts and clear all data
    - go into settings --> manage applications --> people and clear all data
    - go back into "people" and do "import from SD card" and make sure you save them to google account rather than to your phone or to your sim card
    - go into settings and reenable google sync

    So those were the directions.

    After I deleted all my people and contacts, I was expecting the "people" app to be empty, but it still showed every one of my contacts (because they were all on my sim card). I even repeated the steps, clearing all the data again, but they were all still showing up.

    Eventually I figured out that within the People app I could do menu --> view and disable "sim card." That cleared it out.

    So then I imported all my contacts from the SD card where I had just saved them and choose google account as the destination.

    I went back into settings and enabled google sync. After 5 minutes or so, it was done, and when I went back to the People app, some of the contacts even had facebook pics next to them, which was awesome, and was what I wanted all along.

    Here is where the problems and questions start:

    Problem 1: Not all of my contacts are there. Despite all 200 contacts being saved on the sim card, there are only about 150 contacts currently appearing in my People app. Among the ones that are missing are my girlfriend. Ha. Since they are all still saved on my sim card, I can access them that way (menu --> view --> sim card), but is there a way to fix this problem besides manually going through them all and writing down the names and phone number and then manually reentering them and saving them as google contacts rather than as PHONE or SIM CARD contacts? Because that is going to be tedious. Does anyone know why only about 75% of my contacts actually copied to the SD card rather than all of the contacts?

    Question 2: After the sync, I periodically get a notice that says "Matched contact suggestions" and it gives me a big list of people and pictures. Within this list, what is the difference between "linked" and "google" and "facebook for HTC"? The format is like this:

    John Doe
    ---- John Doe (linked) [ ]
    ---- John Doe (Google) [ ]
    ---- John Doe (Google) [ ]
    ---- John Doe (Facebook for HTC) [ ]

    Jane Smith
    ---- Jane Smith (linked) [ ]
    ---- Jane Smith (google) [ ]

    etc.

    How do I know which link boxes to check? What is the difference between "linked" and "google" and "facebook" entries?

    Also, why is it asking me to link people who are facebook friends but who are not on my contacts list?

    Problem 3: After the sync, my text message format is now all goofed up. Before, it would look like this:

    John Doe: Hey how are you?
    Me: I'm good, you?

    But now, it's like this:

    John Doe: (M 555-123-4567): Hey how are you?
    Me: I'm good, you?

    Why is it showing an M (mobile?) and then their phone number? It's ugly and annoying. I know who the text is from; I don't need their phone number appearing, too. Did I accidentally change a setting somewhere, and if so, how do I disable this?

    These issues have been driving me crazy for the last few hours. I appreciate any help you anyone can give.

    Thanks!
  2. Thread Author  Thread Author    #2  

    Default

    update: I went through all these steps again except this time imported the contacts from the sim card rather than the SD card, and it correctly pulled all my contacts in. But as soon as I synced with Google, I had 770 contacts in my phone, including every person I've ever emailed from that gmail account.

    I only want the SIM card contacts, but I want them saved to Google so they get backed up in my gmail, and I want the pics to be pulled from Facebook. I don't want the other hundreds of people that I've emailed at one point or another in the past showing up in the list.

    How do I do that?


    edit: Wait, I set it to "only display contacts with phone numbers" and now those hundreds of email addresses aren't showing up anymore.

    I don't know if this was a fix or a bandaid. Ideas?
    Last edited by metalhead0; 04-14-2011 at 08:47 PM.

Posting Permissions

B