1. leprechaun106317's Avatar
    I was wondering if anyone else has had this issue.. my phone connects to my home Wi-Fi connection just fine and stays connected just fine until I turn my phone off then there is an 85% likeliness that when I turn it back on the connection is lost and it refuses to reconnect until I unplug my router.. is there anyway to fix this? It's kind of annoying having to unplug my router every other day. Oh and no other devices that use the Wi-Fi have this problem they constantly stay connected.
    04-14-2012 02:23 PM
  2. PersonaNonGrata's Avatar
    When you say turn your phone off, you mean complete power down? Do you turn it off & leave it off for a while, or does the problem happen with a simple reboot? Does it happen every time you turn it off/reboot?
    Does the problem happen in other wifi networks (i.e., work, public places)? Maybe you only have wifi at home, though.
    Does your router have ip address reservation? Maybe you could set the router to always assign your phone the same ip address.
    04-14-2012 02:32 PM
  3. leprechaun106317's Avatar
    Yeah I mean power down when I go to bed. It happens i'd say almost every other time I turn it off.. I can get lucky sometimes and it won't happen but it seems to be getting more frequent. It's not just my phone either it happens to my mom's phone too (same phone as mine) I can connect fine to other connections. i'm not sure if it has ip address reservation.. how would I set that? Ok looking at the router settings and not seeing anything for that.
    04-14-2012 02:52 PM
  4. PersonaNonGrata's Avatar
    Try this on your phone:
    • Go to Settings -> Wireless & networks -> Wi-Fi settings
    • Press menu key -> Advanced -> check "Use static IP"
    • Choose an IP address which you know won't (or is unlikely to) be assigned by your router to another device.
    • Copy the Gateway, Netmask, and DNS addresses from a computer which is connected to your router.

    I don't know if this setting will affect your ability to connect to other wifi networks, or if it will only affect the one you are currently connected to.
    04-14-2012 03:51 PM
  5. leprechaun106317's Avatar
    I tried that and it wouldn't connect at all.
    04-15-2012 12:00 AM
  6. PersonaNonGrata's Avatar
    You sure you picked a good IP address?

    What ROM and android version are you using?
    04-15-2012 12:42 AM
  7. donavan's Avatar
    I got something like this when I was on a custom ROM... I found no way to get around it. It only seemed to happen using certian acess points.
    04-15-2012 11:44 AM
  8. leprechaun106317's Avatar
    i'm using gingerbread but it happened before I upgraded to that too.
    04-15-2012 07:49 PM
  9. PersonaNonGrata's Avatar
    Try the PowerSave Mode in the hidden menu.
    In the dialer, dial 3846#*505# or 3846#*506# depending on your device (p505 vs. p506). Go to Connectivity Test -> PowerSave Mode

    I'm shooting in the dark here, as I don't know the source of your problem.
    04-16-2012 04:40 PM
  10. davesatan25's Avatar
    I have fix the wifi whit this custom stock p505 kernel !
    mixmax1982 and chiphead like this.
    04-19-2012 02:23 AM
  11. mixmax1982's Avatar
    Where did you get this kernel? Fix is in zImage or just wireless.ko module? Maybe we can implemented this in joban .35 kernel? Can somebody try and report?
    04-20-2012 10:40 AM
  12. XRAY72's Avatar
    I thought I was having an issue too. Unplugged the router to my PC, waited a minute, plugged it back in. Ta da! Problem solved, wasn't my phone afterall. I'm Sharing this because I want everyone to remember sometimes its the simple things.!
    04-20-2012 08:09 PM
  13. donavan's Avatar
    Where did you get this kernel? Fix is in zImage or just wireless.ko module? Maybe we can implemented this in joban .35 kernel? Can somebody try and report?
    Nope you can't do it with out the source code, I have already checked and recheck. This is why joban got the boot because he refused to release his source code even thought what your suggesting (and I suggested a while back) would probably fix the issue. Fear not though I have a damn good developer helping me out on my kernel build and though I have run into some technical issues here and there all the peices are starting to fall into place, and with any luck I should have a working Cyanogenmod based kernel very soon.
    04-20-2012 10:42 PM
  14. mixmax1982's Avatar
    I'm using custom ROM based on Russian V20e LG P500 firmware and having problems with WIFI. Module won't even start. With davesatan25 fix kernel my WIFI started, but don't get IP adress automatically. Only manual settings worked BUT IT WORKED!!! I was comparing this WI-FI fix kernel with stock kernel - and there's differences in zImage (in size).
    So I think davesatan25 modified the stock kernel from source and he might help us with .35 kernel!!
    04-21-2012 05:33 AM
  15. donavan's Avatar
    I'm using custom ROM based on Russian V20e LG P500 firmware and having problems with WIFI. Module won't even start. With davesatan25 fix kernel my WIFI started, but don't get IP adress automatically. Only manual settings worked BUT IT WORKED!!! I was comparing this WI-FI fix kernel with stock kernel - and there's differences in zImage (in size).
    So I think davesatan25 modified the stock kernel from source and he might help us with .35 kernel!!
    sounds like he did and maybe he can... I will be trying another build today using a different cross compiler in hopes that it works with the newer version. God willing I will have a ported Cyanogen based kernel by the end of the day, barring any crazy errors. I will be building the Wifi module also so that we don't run into the no wifi issue that we have currently. But hey if someone comes out with a 100% working kernel with source I will gladly step aside and let them run with it
    04-21-2012 08:33 AM
  16. leprechaun106317's Avatar
    wow sorry I haven't said anything for a while I kinda forgot I made this post lol Anyway, it's now happening even if the phone is on as I had my phone on as usual and in the evening the wi-fi dropped and wouldn't come back until I unplugged my router as usual. i'll try the powersaver thing you suggested.

    ok neither of those codes worked it just said connection problem or invalid code.
    04-22-2012 01:17 AM
LINK TO POST COPIED TO CLIPBOARD