06-27-2013 04:56 PM
42 12
tools
  1. bill.weckel's Avatar
    Ok. Here's the modified updater-script for Piccolo.

    Bear in mind that this is only a work-around, not a permanent fix, for those using a LG-P500 CWM instead of the correct CWM for your device.

    What you will need to do:

    1) Download the modified updater-script
    2) Download the Old baseband fix. Search for it. It's here. I've uploaded it and given references to other threads as to where it can be found.
    3) Unzip the Piccolo ROM into it's own folder
    4) Goto "Path to unzipped Piccolo\META-INF\com\google\android" and replace the "updater-script" with the one in the zip downloaded in step 1
    5) Repackage the ROM. Simply zip all the files in the folder where you unzipped Piccolo to into a new zip file.
    6) Copy to SDCARD
    7) Reboot device into CWM
    8) Install the ROM
    9) Reboot recovery
    10) Install old baseband zip
    11) Reboot device
    12) ENJOY!!!
    AdictoDigital and istos like this.
    07-27-2012 05:42 PM
  2. korrectmethod's Avatar
    Why was it necessary to do all of these extra steps? I wiped the phone then flashed piccolo like normal and had 0 issues using the thrive. Maybe you should switch recoveries? I'm using CWM Recovery v5.0.2.0.
    07-28-2012 11:10 AM
  3. bill.weckel's Avatar
    Why was it necessary to do all of these extra steps? I wiped the phone then flashed piccolo like normal and had 0 issues using the thrive. Maybe you should switch recoveries? I'm using CWM Recovery v5.0.2.0.
    Quite simply because I don't have all the answers. This worked for my situation. Plus I'm liking the touch recovery especially since the keys have been remapped and I have issues with my power button.

    Sent from my LG-P506
    07-28-2012 11:22 AM
  4. korrectmethod's Avatar
    Quite simply because I don't have all the answers. This worked for my situation. Plus I'm liking the touch recovery especially since the keys have been remapped and I have issues with my power button.

    Sent from my LG-P506
    Ah I see. maybe you should point out that those steps are only necessary with your recovery, just so people with normal cwm know its not required.

    do you think modifying the script will be necessary for all releases?
    Sent from my LG-p505 using Android Central Forums
    07-29-2012 09:55 AM
  5. bill.weckel's Avatar
    Ah I see. maybe you should point out that those steps are only necessary with your recovery, just so people with normal cwm know its not required.

    do you think modifying the script will be necessary for all releases?
    Sent from my LG-p505 using Android Central Forums
    I actually had stated that it was a work-around not a fix. I edited my post and made it obvious that this was not a fix.
    From what I've read and been told, we shouldn't be having this issue , no matter what CWM we run. I believe my problem is the fact that the CWM I'm using was for the P500. Someone else patched the CWM to fix the color issue.

    Sent from my LG-P506
    07-29-2012 10:30 AM
  6. korrectmethod's Avatar
    I actually had stated that it was a work-around not a fix. I edited my post and made it obvious that this was not a fix.
    From what I've read and been told, we shouldn't be having this issue , no matter what CWM we run. I believe my problem is the fact that the CWM I'm using was for the P500. Someone else patched the CWM to fix the color issue.

    Sent from my LG-P506
    I'm using cwm 5.0.2.0 with color issues and haven't had problems. if that helps

    Sent from my LG-p506 using Android Central Forums
    07-29-2012 10:37 AM
  7. LifesGoodPhoenix's Avatar
    Has there been an update to this? Or is there No need.
    08-28-2012 09:01 PM
  8. rbross3030's Avatar
    Arjen I just wanna thank you for this release, this is exactly what I've been looking for. Installed this with CWM 502 after doing a full system/dalvik/cache wipe then did old bb fix (thrive) and this beauty is FAST & CLEAN! I'll run this as long as it works well and get back if I find any bugs! Thanks again!

    edit: can anyone tell me whats the appropriate version of google apps to install on here? I've been using the 08-21-2011 version(?) but that was on CM7... also - is there an "official" site to get g.apps zips? I thought I remember going to a google project repository somewhere but I can't find it now...
    08-31-2012 05:34 PM
  9. donavan's Avatar
    Arjen I just wanna thank you for this release, this is exactly what I've been looking for. Installed this with CWM 502 after doing a full system/dalvik/cache wipe then did old bb fix (thrive) and this beauty is FAST & CLEAN! I'll run this as long as it works well and get back if I find any bugs! Thanks again!

    edit: can anyone tell me whats the appropriate version of google apps to install on here? I've been using the 08-21-2011 version(?) but that was on CM7... also - is there an "official" site to get g.apps zips? I thought I remember going to a google project repository somewhere but I can't find it now...
    If you have any version installed just let google update you to the newest version. This will happen automatically when you go to the playstore/market.
    rbross3030 likes this.
    09-01-2012 07:48 AM
  10. rbross3030's Avatar
    If you have any version installed just let google update you to the newest version. This will happen automatically when you go to the playstore/market.
    Gotcha, thanks donovan! I just installed the ICS version posted on CM's google apps wiki:

    Latest Version/Google Apps - CyanogenMod Wiki

    and all is working great.

    Worth noting: battery charges very fast with this release and seems to last a long time. Scrolling through homescreens even with live wallpapers is surprisingly smooth as well! I feel like I have a new phone!

    Thanks again!
    09-01-2012 11:35 AM
  11. rbross3030's Avatar
    OK so after a few days of using this ROM on my thrive I am reporting back with results:

    Rom is still very stable, has not crashed or randomly restarted other than during the problem below.

    Battery life is still awesome.

    WiFi & Bluetooth work - I can control my iTunes over Wifi using Remote for iTunes, can connect my Plantronics headset without fuss.

    USB Mass Storage works - music in my car via USB

    ICS is generally a hell of a lot nicer to use than GB

    So tethering is working, sort of. It's running and stable right now, but it seems to be touchy. Sometimes the phone will restart when I toggle on hotspot tethering, especially if it's right after I modify the hotspot settings (eg name, password). I also have not been able to get FoxFi working via wifi, which is a bummer because I'd prefer to be able to use it's proxy abilities. Anyone else having issues with tether?

    All in all still the most stable and functional build I've ran and will likely continue using it. I am running a Galaxy Core live wallpaper along with Minimalistic Text and it is smooth, responsive & gorgeous and has little effect on battery life.

    I've attached a few screenshots - I've never run ICS on this phone before so I don't know how much this differs from stock - but you get the idea either way Same as stock ICS
    09-04-2012 01:03 PM
  12. kushkingz's Avatar
    This rom was very nice but in the end was a bit to buggy for me. Like music would skip every now and then, Instagram and Facebook would up, etc. But I still enjoyed using ICS for the last 2 weeks.

    Sent from my LG-P505 using Tapatalk
    09-15-2012 10:44 PM
  13. sicario666's Avatar
    I don't have this device but the name caught my eye. My last name is Piccolo.

    Sent from my SCH-I535 using Xparent Green Tapatalk 2
    09-15-2012 10:46 PM
  14. OneForth's Avatar
    Great rom! Cant wait for a new version, I did find this one a bit buggy.

    ~OneForth
    09-16-2012 10:40 PM
  15. rbross3030's Avatar
    This rom was very nice but in the end was a bit to buggy for me. Like music would skip every now and then, Instagram and Facebook would up, etc. But I still enjoyed using ICS for the last 2 weeks.

    Sent from my LG-P505 using Tapatalk
    It seems as if this ROM is trying to keep too much in RAM, could be nothing in particular to this vs. any other ICS release--thrive is kinda a gimp compared to modern devices running ICS. I went into Developer Options and enable "Kill app back button." I think that lot of that stuff that pops up is running in the background and just needs to be killed. If my homescreen isn't scrolling smoothly I'll hold down the back button to kill the launcher. It will automatically relaunch after a couple seconds BUT if there are other processes running in the background they will be brought forward one at a time and I can selectively kill them one by one until I'm back at the launcher again and things will run far faster at that point. I understand that force killing apps is a topic of debate but I find it hard to argue against it in a case like this where killing everything makes the phone perform exceptionally smoother. One could also play with the Background process limit in developer options but I don't mess with it because I don't know what the default selected "standard limit" actually means and many background processes are normal & necessary anyways.

    Great rom! Cant wait for a new version, I did find this one a bit buggy.

    ~OneForth
    So far tethering is the only major problem I've noticed. Native tethering crashes the phone after using it once and third party tethering apps don't seem to work at all, pretty bummed about that actually because AT&T throttles the hell out of my tethered connection if I don't use a proxy, an option only available with FoxFi addon.

    I've also noticed that sometimes apps running unknowingly in the background can hog priority of the volume control--so that even when you are at the home screen the volume rockers will change the media volume instead of the ringer volume...

    What bugs did you find OneForth?

    EDIT: I've flashed AOKP for p500 followed by flashing joban's kernel followed by flashing arjen's 6/19 ICS kernel and am still encountering the same exact tethering bug in a different rom which leads me to believe that it is more like the kernel causing the problem... see here.
    09-18-2012 11:18 AM
  16. amir2418's Avatar
    Arjen owesome rom i 've using this for about a week i feel like really i have new phone just want to thank you arjen for this great work you have been doing here...
    Rom is very stable everything seem to working perfectly but some reason i can,t get to work all animation ? i don,t know if this release has working animation
    10-31-2012 10:10 AM
  17. Lucio Balbuena's Avatar
    I'm stuck with the battery screen... after I flashed the rom it booted correctly
    Once I turn it off to put the sim in, whenever I try to turn it on a huge battery icon will be display on a black background
    Could anyone help me get the phone working again?

    Thanks
    06-27-2013 04:56 PM
42 12
LINK TO POST COPIED TO CLIPBOARD