Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread Author  Thread Author    #1  

    Default Odin gets stuck, Can't flash any firmware on my S3.

    Hello friends,

    I'm having issues with my T-Mobile SGH-T999 Galaxy S3. The phone had stock firmware and it stopped working out of nowhere. So I started diggin' a bit... Seems it has the infamous "SDS syndrome". Now, it won't enter the recovery mode but I can enter the download mode. So I tried to flash it using Odin and stock firmware that I got from SamMobile. Odin says the phone has been added but the process stops at "Initializing" or "Setup Connection". I've turned off Kies, uninstalled my antivirus program, turned off firewall, tried all ports and different cable and also ran Odin as admin, tried different PC and it's the same... Initializing or Setup Connection. ONCE it managed to get to the point "NAND Write Start" but it stopped there... Also I keep the battery full while I'm running it. Any ideas or suggestions on what else I could try?

    Thanks

Similar Threads

  1. Can't install anything but cyanogen mod 11 on M8
    By RicardoM68 in forum Ask a Question
    Replies: 2
    Last Post: 07-15-2014, 09:06 AM
  2. speeding the audio up on audio recordings!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-14-2014, 12:20 AM
  3. S3 not backing up with Kies
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-14-2014, 12:12 AM
  4. Replies: 1
    Last Post: 07-13-2014, 11:54 PM
  5. can i flash cwm on apls z10(blackberry clone)
    By muviebyc in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 07-13-2014, 08:28 PM

Posting Permissions