1. anteck7's Avatar
    New to T-Mobile and Galaxy, so far love the phone (not all jacked like the verizon version).

    I keep loosing 4g data, ill have three bars, then 2 then 1, then none. then it will swap to edge, and ill get a solid 3 or 4 bars edge.

    It will stay that way until I make a phone call, or restart the phone. After making a call or restarting the phone, ill have 3 bars of 4g, for 2 to 3 minutes before the cycle repeats and im back on edge data.

    This is happening at multiple locations, anyone have any ideas?
    07-14-2012 07:57 AM
  2. feelinfroggy23's Avatar
    Its because T-Mobile is one of the worst companies out their. Boost mobile and metro pcs is better than T-Mobile in my area. They are good if you are in one of the 10 city's that they actually cover decently. I would go to att or Verizon. They Rock pretty much everywhere.

    Sent from my Nexus 7 using Tapatalk 2
    07-14-2012 08:01 AM
  3. Mac33's Avatar
    Change it to where it doesn't switch to edge. *#*#4636#*#*. Device information. Change it to wcdma only.
    07-14-2012 09:33 PM
  4. peppermintman's Avatar
    Yup mine doing the same thing. I heard the S3 International worked on all 3G and 4G networks. The Edge or Echo as the T-Mo calls it is slower than 2G. This a lot of phone to be using that kind of network speed. I'm hoping too that there's a solution other than changing carriers, then's what the point in having this phone??? I got the International model because I don't want the Cell Carriers to own me. I'm going to give the phone a chance and see just what's so good about the Android based cell phones. But I need help on getting this cell online with the 3G and 4G networks.
    07-15-2012 01:28 PM
  5. peppermintman's Avatar
    I don't think switching carriers is the solution to this problem.
    07-15-2012 01:30 PM
  6. LazrRocketArm's Avatar
    I don't think switching carriers is the solution to this problem.
    Wait, are you in USA.? Isn't supposed to work in US Tmo on 3g. Not the international version anyway


    http://forum.xda-developers.com/show...8#post25730798

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    07-15-2012 03:29 PM
  7. LazrRocketArm's Avatar
    I don't think switching carriers is the solution to this problem.
    If you are so sold on Tmo, you should just send the phone back and get the branded version at a discount.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    07-15-2012 03:31 PM
  8. jaymzb0nd's Avatar
    Change it to where it doesn't switch to edge. *#*#4636#*#*. Device information. Change it to wcdma only.
    What does this do exactly? Keep it off EDGE?
    07-15-2012 08:01 PM
  9. peppermintman's Avatar
    Got to let all know that I got an email from Samsung UK. They are the ones that are the tech reps for Samsung. They want to hear from everyone haveing the same problem with T-Mobile Vs 3G & 4G problems so you all need to send them an email with the information they ask for. I was a lot but I did it drinking a few beers so it wasn't so bad.

    Send em an email sounds like they don't know about it yet.
    Ats Villemson likes this.
    07-15-2012 08:58 PM
  10. eagle63's Avatar
    Got to let all know that I got an email from Samsung UK. They are the ones that are the tech reps for Samsung. They want to hear from everyone haveing the same problem with T-Mobile Vs 3G & 4G problems so you all need to send them an email with the information they ask for. I was a lot but I did it drinking a few beers so it wasn't so bad.

    Send em an email sounds like they don't know about it yet.
    WTF??

    As was previously stated, if you're using the international device then that's the problem. It's not a pentaband phone.
    07-15-2012 09:05 PM
  11. Mac33's Avatar
    What does this do exactly? Keep it off EDGE?
    Yes. It keeps it on 3G/4G. It won't switch to edge at all.
    07-16-2012 11:51 AM
  12. anteck7's Avatar
    Update with video (not the best quality)

    [YT]http://www.youtube.com/watch?v=oq-b43GhYsg&feature=g-upl[/YT]

    Looks like its based on how you hold the phone.
    07-16-2012 02:22 PM
  13. MOTH477's Avatar
    Update with video (not the best quality)


    Looks like its based on how you hold the phone.
    Thanks for the video. This is exactly what's happening to mine. I called T-Mobile and the tech told me a few people had called about the issue. The question is,why is T-Mobile different from other carriers? Low signal strength is killing my battery. At times I have seen my phone has been without signal for 45% of the time since last full-charge.
    07-17-2012 10:44 AM
  14. glocky79's Avatar
    Ok, this is crazy but mine does the same thing in my left hand. I know that defies common logic but its true. If anyone finds out more about this issue, please share with us.
    08-19-2012 02:25 AM
  15. bipoler#AC's Avatar
    You're only effected if you are left handed..... thankfully for my style lus

    Sent from my Nexus 7 using Tapatalk 2
    08-20-2012 03:42 AM
  16. Ian C Anderson's Avatar
    Mine will not switch to that (wcdma).. It only stays on auto?
    Edit: I had to turn off wifi now that option works.

    Sent from my SGH-T999 using Android Central Forums
    09-21-2012 08:24 PM
  17. erjennin's Avatar
    Ok, this is crazy but mine does the same thing in my left hand. I know that defies common logic but its true. If anyone finds out more about this issue, please share with us.
    Check YouTube for this issue... there seems to be a antennae located on the bottom portion of the left side of the phone... if you cover it up, you can watch the signal drop. It's like the iPhone4 antennae-gate issue all over again. This is my second GS3 and it does it just like my first one.
    09-25-2012 10:14 AM
  18. Tony Whiteside's Avatar
    will this code work on an unlockedS3 phone from at&t with a t mobile sim card to recieve 3 or 4 g? edge sucks.
    11-24-2012 12:06 PM
  19. Uterm's Avatar
    After I punch in the numbers & I select "wcdma only" how do I save it so it won't automatically go back to edge?
    07-03-2013 01:07 AM
  20. dominicag2000's Avatar
    With the SGH-T999 In touchwiz I just switch it from Settings > More settings > Mobile networks > Network mode > WCDMA only. I've never seen it go to EDGE that way. It stays on HSPA when it would otherwise go back and forth from EDGE to HSPA in low reception areas.
    07-03-2013 05:55 PM
  21. Carla McDougall's Avatar
    H guys im having identical problem s3 from nz on holiday in usa. Bought prepaid data for 4 week cant really use it as i cant do anything on edge. In denver i got a small amount of g3 that dropped within minutes to edge, but in small towns edge or nothing. Did the numbers entered actually work for anyone and how do i enter them please. Also if i enter them will the ph still be ok in nz when i go back. We dont use any 2g eedge there, al 3g. Went to see tmobile but they could not help other than suggest it will be better tomorrow in salt lake city and later in east coast.

    - - - Updated - - -

    H guys im having identical problem s3 from nz on holiday in usa. Bought prepaid data for 4 week cant really use it as i cant do anything on edge. In denver i got a small amount of g3 that dropped within minutes to edge, but in small towns edge or nothing. Did the numbers entered actually work for anyone and how do i enter them please. Also if i enter them will the ph still be ok in nz when i go back. We dont use any 2g eedge there, al 3g. Went to see tmobile but they could not help other than suggest it will be better tomorrow in salt lake city and later in east coast.
    08-26-2013 11:46 PM
LINK TO POST COPIED TO CLIPBOARD