I got a new S3 just a week ago from Dubai and it worked fine. It was on 4.1.1 firmware and my first smartphone. Then overnight a few days ago it updated to 4.1.2 JB and when I woke, it said my home wifi password was incorrect. I would reenter while "show character" was clicked so I was certain password was correct and it would attempt to connect, fail and temporarily "incorrect password" would come at the bottom of screen in small font and disappear.

All other devices, laptops and other phones, had no issues with Wifi.

If I stood in front of router, THEN it would connect. Everywhere else it gave "incorrect password" message.

After scouring android forums, I realised it was maybe caused by JB 4.1.2 OTA update.

So I researched and then downloaded ODIN and after a lot of effort found a tar file for 4.1.1 which I thought might be compatible with my device. I flashed it following instructions on a tutorial.
It said pass. But the boot screen was frozen on samsung logo!!! Then I researched some more. Downloaded the CWM via ODIN onto phone. Went into recovery mode and did factory reset. Then it booted into 4.1.1 JB. Being an amateur I was so pleased.

BUT!!!!!!!!!!!

NOW the damned thing won't connect. It is constantly scanning and will NOT connect. It connects if I am DIRECTLY in front of modem. Move ten feet away and it will just say "connecting" and never connect. It won't give that annoying incorrect password message, but it isn't connecting. Plus it is downgraded to 4.1.1 JB for no reason it seems.

What do I do now? Please help me.