Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  
    b799's Avatar

    Posts
    5 Posts

    Default Galaxy S3: No service but data works

    I have a T-mobile S3 which I'm using with wind mobile in Canada... I've had it for over a year with no issues,until a few hours ago when it decided to not give me service anymore... I can still use data, but I have no signal and it says no service (this makes no sense, how can I have data, but not make/receive any calls?). This happened at the gym basement where I temporarily lost signal due to being underground... when I came upstairs, no signal. I tried restarting the phone a bunch of times, I checked the IMEI and it's still there, no error message, I put my sim into another wind phone and I had data and could make calls... Is it safe to say something is fried with my phone? Can I do something to fix it before I have to do a factory reset? (will that even save it?)

    Cheers
  2. Thread Author  Thread Author    #2  
    b799's Avatar

    Posts
    5 Posts

    Default Re: Galaxy S3: No service but data works

    So apparently my phone has been blacklisted... I don't know why as I have had it for over 1.5 years... anyway to whitelist it again?
  3. #3  

    Default Re: Galaxy S3: No service but data works

    Why was it Blacklisted? Was it new or used when you bought it?

Similar Threads

  1. Android Device Manage only works on WiFi
    By richlaustx in forum AT&T Samsung Galaxy Note 3
    Replies: 6
    Last Post: 04-22-2014, 02:36 PM
  2. Replies: 1
    Last Post: 03-24-2014, 12:29 PM
  3. Replies: 9
    Last Post: 03-23-2014, 01:51 PM
  4. Frozen at Boot Screen, No Power Button. Please help!
    By jpkmiec in forum Samsung Galaxy S II
    Replies: 1
    Last Post: 03-22-2014, 06:55 PM
  5. Replies: 0
    Last Post: 03-22-2014, 07:31 AM

Posting Permissions