1. jamesbecker79's Avatar
    I am having a terrible time the last couple of days. I cannot get any 2 , 3, or 4G data connections. I live in a very strong 4G area. My phone shows the 4G logo. The upload arrow below the icon is constantly highlighted. There is no error message when i attempt to use the internet on 4G, the browser and apps just continuously show the little busy spinning circle thing. When I switch to 2G only, my data apps say that there is no data connection available. I have been on the phone with 4 different T Mobile tech people (they are atrocious, but that's another post). I positively love this phone and would hate to give it up, but i am absolutely at my witt's end with t-mobile.

    I have tried all of the troubleshooting things, there's no network issue in my area. I wanna cray. has anyone had a similar issue? An ideas what may be the cause?

    Thanks!
    06-22-2011 01:11 PM
  2. MattMJB0188's Avatar
    Is Your HTC Sensation 4G Suffering Data Connectivity Issues? The Fix Is Easy.

    That should fix it but T-Mobile and HTC are still working on an update so hang tight.
    06-22-2011 01:12 PM
  3. jamesbecker79's Avatar
    Is Your HTC Sensation 4G Suffering Data Connectivity Issues? The Fix Is Easy.

    That should fix it but T-Mobile and HTC are still working on an update so hang tight.
    Did that. No dice :-(
    06-22-2011 01:17 PM
  4. danperde's Avatar
    I am having a terrible time the last couple of days. I cannot get any 2 , 3, or 4G data connections. I live in a very strong 4G area. My phone shows the 4G logo. The upload arrow below the icon is constantly highlighted. There is no error message when i attempt to use the internet on 4G, the browser and apps just continuously show the little busy spinning circle thing.
    Did you checked if you have any app using your bandwidth? Did you restart your phone?
    06-22-2011 03:14 PM
  5. jab86's Avatar
    Did you recently switch from another platform such as blackberry? If that's the case, you'd have to have customer support change your data plan from Blackberry data plan to Android data plan. What you're describing sounds like that would be the issue.
    06-22-2011 03:34 PM
  6. jamesbecker79's Avatar
    Did you checked if you have any app using your bandwidth? Did you restart your phone?
    Battery pulled, sim card pulled, factory data reset, the works.

    I did try to see if it was an app, it's not.
    06-22-2011 04:48 PM
  7. jamesbecker79's Avatar
    Did you recently switch from another platform such as blackberry? If that's the case, you'd have to have customer support change your data plan from Blackberry data plan to Android data plan. What you're describing sounds like that would be the issue.
    I didn't, I'm a new T Mo customer. Brand new SIM, new plan, etc.

    I finally found someone semi-competent at T Mo. They're sending me a new one. I dunno if other people are having this prob or not. It seems anyone else having issues had the type that could be fixed with *#*# thing.

    Thank you guys for all of your help/ suggestions. I appreciate you taking the time!
    06-22-2011 04:50 PM
  8. danperde's Avatar
    Battery pulled, sim card pulled, factory data reset, the works.

    I did try to see if it was an app, it's not.
    Yeap, seems like you have a bad unit. I'm curious if you are experiencing the same issue with WiFi.
    06-22-2011 05:56 PM
  9. jamesbecker79's Avatar
    Yeap, seems like you have a bad unit. I'm curious if you are experiencing the same issue with WiFi.
    Nope. WiFi works just fine and dandy
    06-22-2011 06:21 PM
  10. Droid800's Avatar
    Nope. WiFi works just fine and dandy
    Go to my tmobile on tmobile.com and double check that the right device is on your account, and that you have the right data plan selected.

    Sent from my HTC Sensation 4G using Tapatalk
    06-22-2011 10:17 PM
  11. jamesbecker79's Avatar
    Go to my tmobile on tmobile.com and double check that the right device is on your account, and that you have the right data plan selected.

    Sent from my HTC Sensation 4G using Tapatalk
    I'm don't feel like waiting for the new one to arrive, so today I made them remove and then reprovision the data plan. Hopefully that will work. We'll see in about an hour. This is more trouble then it's worth. Lol. If i didn't love this phone I'd tell T Mo to shove it.
    06-23-2011 09:45 AM
LINK TO POST COPIED TO CLIPBOARD