1. MrBigFeathers's Avatar
    My wife just upgraded from the MyTouch Slide 3G to the Slide 4G. The 4G is constantly dropping to 2G so obviously the data speeds are terrible. Her Slide 3G usually always stayed in 3G in the same areas the 4G is now dropping. Anyone else experiencing this?
    07-28-2011 11:29 AM
  2. MrBigFeathers's Avatar
    Guess no one else got this phone
    07-29-2011 05:57 PM
  3. Denisej's Avatar
    My wife just upgraded from the MyTouch Slide 3G to the Slide 4G. The 4G is constantly dropping to 2G so obviously the data speeds are terrible. Her Slide 3G usually always stayed in 3G in the same areas the 4G is now dropping. Anyone else experiencing this?
    I have seen mine drop to 2g but not a lot. Ive had very good reception so far. Ive been using it since the day after it lauched on the web.
    07-30-2011 11:19 PM
  4. Dmarco79's Avatar
    Yea, I noticed mine dropping to 2G also in certain areas. I do hope they work to fix this problem, because I LOVE this phone
    08-30-2011 02:43 PM
  5. rmontrose's Avatar
    I have the same problem and when it's in 2G coverage it is very spotty and EXTREMELY slow. My wife has a T-Mobile Samsung Galaxy S and in a non-4G area she will have fast 3G coverage and the MyTouch4g shows just 2G (I have never seen it show 3G) and crawls along, if it can get any data at all. I can open a browser and it seems like it cannot get a data connection even though I have 3-4 bars of 2G. But if I move into a GPRS (the G icon) then I get a much faster connection! I think there is something really wrong with the phone for EDGE (2G) support.
    09-26-2011 10:24 PM
  6. jmart981's Avatar
    I have this phone love it, when I first activated it was doing that , but as I've had it for almost a week its been much better,.but I do have th issue when it falls to 2G here and there, so you are not alone my friend
    11-08-2011 02:05 PM
  7. CadillacMatt#AC's Avatar
    I noticed the same thing when I was having lunch with my sister. I had my Mytouch 4G on the table clicking away at 4G while she spent the entire time down in the 2G zone. Unfortunately I didn't get a chance to find out why as we were just meeting for a quick meal, but I'd love to hear if anyone has a fix for this.
    01-30-2012 12:56 PM
  8. bsmith1051's Avatar
    I have this problem when I'm at home, but then I know I have very weak signal there. From the sound of these other comments it may be a design flaw?
    02-06-2012 05:45 PM
  9. cavskc's Avatar
    Go to wireless & networks then go to mobile network and click wcdma only to stay on 4g
    02-12-2012 10:41 AM
  10. shishirrrrr's Avatar
    set the network preferences back to wcdma and gsm both be proffered, under network settings. you would have your 4g network back..
    12-04-2012 12:19 PM
  11. fablis's Avatar
    When I use the WCDMA only option i periodically lose network connection which results in me seeing the warning sign at top left of my notification bar.

    What then happens if I am on a call when using the GSM/WCDMA auto mode? does this mean my call will disconnect when it loses the 3g signal during a call? or does it automatically switch without interupting the call?

    Also would this be the reason why often on a call I will lose audio and not hear the callers audio?
    06-06-2014 05:42 AM
LINK TO POST COPIED TO CLIPBOARD