Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
Like Tree2Likes
  • 2 Post By Jerry Hildenbrand
  1. Thread Author  Thread Author    #1  

    Default Get Fastboot working on Win7 x64

    Seems like a lot of people are having issues with the amd64 driver from the 2.3 SDK. Here's a workaround:

    • Go to the PdaNet homepage and download the Windows 7 x64 version of the PC software Download PdaNet
    • Make sure your phone is not connected to the computer. Install the app from PdaNet. Ignore the warning about HTC sync if you get it, that doesn't matter for what we're doing.
    • At the end of the PdaNet install, you'll be prompted to connect your phone. Make sure USB debugging is on, and connect to a high speed (as in not through a hub) USB port.
    • Follow the prompts and accept the unverified driver warning. Let it finish, then reboot your phone into fastboot mode -- power off, then hold volume UP and power.
    • Open the device manager in Windows (right click My Computer, properties, choose Device Manager from the list on the left.
    • Find the Android 1.0 entry, with the yellow exclamation mark beside it. Right click and choose to update the driver.
    • Select to search your computer for the driver manually, and point it at C:\Program Files (x86)\PdaNet for Android\. You will see a warning about an unknown/unsigned driver for sure this time, accept it.

    When it finishes, at the command prompt (in the sdk\tools\ directory) type
    Code:
    fastboot devices
    you should now see your Nexus S listed.
    ಠ_ಠ
    제리
    Thanked by 3:
  2. #2  
    Wishbon7's Avatar

    Posts
    25 Posts
    Global Posts
    26 Global Posts

    Default

    ok Jerry HELPPPPPPPP. i didnt have any problem when i did this for the N1. but i can not get the boot unlocked on NS. i have downloaded sdk i have download fastboot, and i get wont load cause it cant find adbwinapi.dll. so i went to ur metheod above. im still not having luck.. i feel so stupid right now. what im i doing wrong.
    <Nexus S & Nexus One>
  3. Thread Author  Thread Author    #3  

    Default

    Make sure you're in the \platform-tools folder when you try running fastboot. They switched things a bit
    ಠ_ಠ
    제리
  4. #4  
    Dragon546's Avatar

    Posts
    7 Posts
    Global Posts
    23 Global Posts

    Default

    Quote Originally Posted by gbhil View Post
    Make sure you're in the \platform-tools folder when you try running fastboot. They switched things a bit
    I ended copying fastboot.exe from tools to the platform-tools folder to get my fastboot to work.

    Android SDK 8 moved adb modules to a separate folder. Why I dunno
  5. #5  

    Default Re: Get Fastboot working on Win7 x64

    Thanks Thanks Thanks So Much
  6. #6  

    Default Re: Get Fastboot working on Win7 x64

    Thanks thanks thanks * 1000000000000000000000000 so much.
  7. #7  

    Default Re: Get Fastboot working on Win7 x64

    hello, i followed all the step but when i update my driver it says "windows encountered a problem installing the driver software for your device"
    and it also said "the system cannot find the file specified". any help is appreciated plz.
  8. #8  

    Default Re: Get Fastboot working on Win7 x64

    thank you jerry...with this steps mine work perfect...thank you so much

Posting Permissions