Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By markkell2233
  1. Thread Author  Thread Author    #1  

    Default my broken Exhibit II

    Hi everyone, It's obvious that there are members on this forum who are very knowledgeable on these devices. I hope that some of you can shed light on what's happening with my SGH-T679 Exhibit II 4G. A brief history: At the start of all this, the phone worked fine. I was carrying it in my pocket. I am an automotive diagnostic technician and spend my days neck stretching under the hoods and dashes of one car after another. The next thing I knew, my touch screen was a lovely mosaic of shattered glass. At this point, it still worked fine, never mind the glass splinters. I bought a replacement digitizer screen and replaced it. After the repair, the touch screen did not work. I f'd with it for a bit, opened it back up to recheck things, pulled the battery and restarted it several times. Then, suddenly, it started ringing and didn't stop until I pulled the battery again. When I restarted it, the screen worked fine. That entire day, I had my android back. That night, upon shutting the device down, my dream ended. Since that time, I have been unable to use the touch screen. This of course means no function at all since the screen doesn't respond to touch. Start up seems normal. I get the android intro and then my screen saver comes up, and that's it. One thing I've noticed is that the device seems to go to sleep real quick after start up. Each time I wake the device up, by pressing the power button, my screen saver comes up and then the screen goes dark after just a few seconds. The phone is going into power saving mode, even though the battery is fully charged.

    I have ordered another digitizer and a new LCD. I had some trouble with the receptacle at the rear of the LCD where the digitizer's ribbon cable connects. The black lock is now missing from that connector. I have thought that this might be my problem. The weird thing though is how the phone seemed to wake up that one day and worked all day without a glitch. It seems like if the trouble were a poor connection, that the phone would have been glitchy, just like any electronic control system with a poor connection. I've really been wondering if this could just be firmware. I've tried to find a firmware flash for the unit or software that might allow me to check the phone's firmware for errors. This forum has obviously gotten me closer to an answer than anywhere else, but I still don't have a definite answer. I have seen references to firmware updates but no links to the actual updates. I have also read about rooting and ADB, but I don't know if either of these are what I might need. I am a phone dummy trying to educate myself and any help would be great.
  2. Thread Author  Thread Author    #2  

    Default Re: my broken Exhibit II

    It's fixed! I replaced the LCD on which the the receptacle for the ribbon cable from the digitizer was questionable. I also went ahead and replaced the digitizer again since it's cheap and I wanted a fresh start. The phone powered up and worked fine immediately. One weird thing is that my text message voice notifications are coming up weird. Instead of speaking the name of the sender from my contact list, it's spouting off some random number. I'm looking through settings now to see if I can correct this.

    One comment I have to make, and I don't mean to smear this vendor. In fact I really appreciate their speedy delivery and the way they package their parts. But the LCD I got from Gadget Fix wasn't really 100%. The ribbon cable, which is glued to the back of the piece was misplaced so that it didn't align quite right with the receptacle on the PCB where it connects. This caused a little issue assembling the phone. In my field I deal with things like this now and then so I was able to gently ease things together. Still, for a brand new, supposedly OE part, I thought this was a little uncool. I will let these guys know whenever I can find their web address(I can't find their website anywhere) and let them know so that they can perhaps watch a little closer in the future. Otherwise, I'm very happy!
    Thanked by:
    tube517 likes this.
  3. #3  

    Default Re: my broken Exhibit II

    Glad you got it fixed, I have this phone and if the screen ever breaks I would like to be able to replace it.

    Sent from my Nexus 7 using Android Central Forums

Similar Threads

  1. Rooting the Samsung Exhibit II 4G?
    By dennis96411 in forum T-Mobile
    Replies: 10
    Last Post: 04-04-2012, 10:52 PM
  2. Help with email app on my exhibit II 4G
    By franquis in forum Introductions
    Replies: 1
    Last Post: 12-08-2011, 12:40 PM
  3. Replies: 2
    Last Post: 11-23-2011, 12:10 AM
  4. I'm bummed with my Galaxy S II
    By pawdrix in forum General Help and How To
    Replies: 4
    Last Post: 10-31-2011, 11:14 PM
  5. My Seidio Innocase II Surface Review (Video)
    By ecaggiani in forum EVO Accessories
    Replies: 24
    Last Post: 06-09-2010, 05:23 PM

Posting Permissions