Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By troidx
  1. Thread Author  Thread Author    #1  

    Question Anyone in Phoenix, Arizona?

    Do any of you know what the LTE service is like in Phoenix (specifically the West Valley)?
  2. #2  
    jollyball's Avatar

    Posts
    9 Posts
    Global Posts
    10 Global Posts

    Default Re: Anyone in Phoenix, Arizona?

    I spend most of my time in the east valley, but I was near 51st Ave and Baseline and LTE was fine there. In fact, I get LTE everywhere except for at my house in Gilbert.

    Posted via Android Central App
    Thanked by:
  3. Thread Author  Thread Author    #3  

    Default Re: Anyone in Phoenix, Arizona?

    So they have pretty solid LTE coverage in many areas? I've heard a lot that the East Valley doesn't have too many good areas for signal.
  4. #4  
    jollyball's Avatar

    Posts
    9 Posts
    Global Posts
    10 Global Posts

    Default Re: Anyone in Phoenix, Arizona?

    So far, the southeast valley is the only place I have issues with LTE, still get HSPA though.

    Posted via Android Central App
    Thanked by:
  5. Thread Author  Thread Author    #5  

    Default Re: Anyone in Phoenix, Arizona?

    Okay, awesome. Do you anyone who lives in the West Valley who could add their opinion as well?
  6. #6  
    jollyball's Avatar

    Posts
    9 Posts
    Global Posts
    10 Global Posts

    Default Re: Anyone in Phoenix, Arizona?

    The only person I know that lives in the west valley with a T-Mobile phone doesn't have an LTE phone.

    Posted via Android Central App
  7. #7  

    Default Re: Anyone in Phoenix, Arizona?

    Im in the 91st ave & Union Hills area - LTE is great!

    I take the 101 south from there - LTE is great!

    Central PHX - LTE is great!

    Mesa / Tempe / Gilbert - LTE is great!
    Thanked by:
    James Frary likes this.

Similar Threads

  1. S4 Battery drain in idle mode
    By allawialhakim in forum Samsung Galaxy S4
    Replies: 17
    Last Post: 03-06-2014, 10:33 AM
  2. Phone getting into dock mode without plugged in
    By KTTB in forum AT&T Galaxy Note 2
    Replies: 1
    Last Post: 09-13-2013, 03:58 AM
  3. Contacts display problem in Android
    By Najam Khan2 in forum The Android Central Lounge
    Replies: 2
    Last Post: 07-22-2013, 09:15 AM
  4. Cannot open dropbox photos in applications
    By jtheavy in forum Samsung Galaxy Note 10.1
    Replies: 1
    Last Post: 07-14-2013, 05:31 PM

Posting Permissions