Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread Author  Thread Author    #1  
    hdgamergts's Avatar
    Junior Member

    Posts
    1 Posts

    Default Tmobile Galaxy s4 M919 - Play Store Won't Connect

    So hopefully this thread is in the right section.. Anyway..

    So I have a T Mobile Galaxy S4 M919 that I have tried rooting and which was successful but then came a problem.
    At first Google play store was perfectly fine and such, after rooting my phone it was still working fine. I downloaded Freedom.apk and after that few minutes later my app store just doesn't connect anymore. I removed Freedom.apk to see if that would work. No it didn't so I tried change the password of my gmail account and re-logging again I can't connect. So I did some research on google and found a couple threads on this forum about the issue which lead to many solutions. I tried them all even clearing cache, data, force stop, enable/disable, re-flashing, uninstalling play store updates. I tried everything..
    Not to mention that I also tried downloading total commander? To edit the Hosts file anyway, I got it to edit the file but I could not save it. It would constantly crash every time I clicked save. Last resort I did was factory reset, no worries I backed up all my contacts, messages and such...
    That also did not work so being that it was a clean fresh start I decided to re-flash again. At first I was using the cf auto root then I tried another one after.

    There is nothing wrong with my internet nor the service provider that I am with (t mobile).

    I literally tried everything and now i'm about to give up. I tried asking xda for help but it seems like no one wants to help me on there. If anyone could help me out without suggesting the same steps that I have done I would really appreciate it.

    Thanks for taking time to read this!

    (Update)

    I was able to sign into my gmail account but everything is an error still. I can't connect to google play store at all.

Similar Threads

  1. GS4 keeps opening a link to a play store app?
    By Anthony Marques in forum General Help and How To
    Replies: 6
    Last Post: 07-07-2014, 05:55 PM
  2. Samsung Galaxy S4 Default Apps-Kitkat
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-06-2014, 01:37 AM
  3. Galaxy S4 Default App Question
    By Andrew Ossi in forum Android 4.4 KitKat
    Replies: 1
    Last Post: 07-06-2014, 12:04 AM
  4. Gear 2 randomly stopped connecting to Note 3
    By pj737 in forum Samsung Gear 2 & Gear 2 Neo
    Replies: 0
    Last Post: 07-05-2014, 11:46 PM
  5. Play Store has no connection retry on Galaxy S5.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-05-2014, 11:17 PM

Posting Permissions