Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Default Signal Issues with AT&T

    So I have the Vibrant. Unlocked it and Put a AT&T Simcard in it and it worked great with 3G but sometimes it'll drop to Edge out of nowhere and It'll stay there and not go back to 3G unless I reboot the phone or in the settings say only search for WCDMA
    Now I wasn't sure if I need to update the drivers on the phone? or a Modem? I'm running Trigger Rom

    Thanks for any input or advice
  2. #2  

    Default

    T-Mobile and AT&T use different frequencies for 3G, and the Vibrant radio was built to pick up T-Mobile's bands. They share at least one though, so it is possible to get 3G in certain areas, but you will usually be on EDGE.
  3. Thread Author  Thread Author    #3  

    Default

    Well I was just confused being in my home with 4Bars-5Bars on 3G and then just drop down to edge like a couple hours later
  4. Thread Author  Thread Author    #4  

    Default

    Got this response from XDA thanks to oka1 When I travel I do this to get 3G in Hawaii since Only Oahu Island has TMO 3G.

    Here is the way you can do it:

    Also by locking into 3g speeds, if you ever go into a non 3g area, or if your 3g signal is poor in your area, then your phone calls will drop and data will stop, unless you go back and set the phone to its default automatic gsm/cdma settings.
    Dial: *#*#197328640#*#*
    Click [1] debug screen
    Click [8] phone control
    Click [7] network control
    Click [2] band selection
    This is where you make a change, default setting is [1] automatic, which means it chooses automatically between gsm/cdma (Edge vs 3g). So we are going to change this and set it to wcdma band which is 3g.
    Click [2] wcdma band
    Click [1] wcdma all []
    Now it should display “select wcdma all bands[*]"
    Now on the bottom of your phone, click the menu key, it’s the one next to the home key, now click back, menu again one more time, back one more time, this is just to confirm it set to number 2 wcdma band.
    Now click menu key one last time, click end.. and you are done. Now to double verify that the phone is locked into 3g, dial in: *#*#4636#*#*
    Then click phone information Then scroll down to “set preferred network type” It should now have listed “wcdma only.” PS, if you tried to do a shortcut, and just set wcdma this way first without doing the lock above, it would just go back to gsm/cdma auto once you exit the screen.
    Your phone should now be locked into 3g.

Posting Permissions