1. ashakouri1's Avatar
    Hi,

    I have a Google Nexus 5 unlocked and I am having trouble with my phone/service at my house and at my work. I run the speed tests on LTE and I get anywhere from 54 KB/sec to 300 KB/sec. The issue is that my gmail doesn't refresh it keeps says "retry no connection," my instagram doesn't load all the pictures and I constantly have to refresh, my gmail send folder doesn't send the emails.

    I have to constantly restart my phone to have my prior emails sync and send out. I tweeted and emailed t-mobile and they say they are having "Excellent Coverage" at zip code 90067 (work) and 90069 (home). They told me that it could be my t-mobile nexus 5.

    Is there anyway to confirm if it is the service or the phone? I don't want to get a replacement Nexus 5, just to find out it is the service.

    It is getting frustrating that images don't sync, email does sync, I can't download my MMS, etc. I took out my sim card and I reset the network defaults, I even switch between LTE and 3G(HSPA+) and nothing works and no one can give me a straight answer.
    06-27-2014 06:04 PM
  2. raino's Avatar
    You could do the one week iPhone test drive. Just return the phone, and don't damage it, and you won't be on the hook for anything and the pending charge on your card will go away.
    06-27-2014 07:28 PM
  3. zorak950's Avatar
    There could be something wrong with your radio, but the first thing I'd do is check your APN settings. I've heard plenty of connectivity horror stories from people with messed up APNs.
    06-27-2014 07:31 PM
  4. ashakouri1's Avatar
    There could be something wrong with your radio, but the first thing I'd do is check your APN settings. I've heard plenty of connectivity horror stories from people with messed up APNs.
    What should I do with the APN settings?
    06-27-2014 07:39 PM
  5. wolfman7828's Avatar
    Try clearing cache, if that doesn't work try hard reset. If still having same problem then probably the phone. Does it do the same thing while connected to wifi?

    Posted via Android Central App
    06-27-2014 07:43 PM
  6. zorak950's Avatar
    What should I do with the APN settings?
    Make sure they match the correct 4G settings for T-Mobile. I don't have a link handy for you, but Google "T-Mobile APN settings" and you'll find them immediately.
    06-27-2014 09:12 PM
  7. dpham00's Avatar
    Make sure they match the correct 4G settings for T-Mobile. I don't have a link handy for you, but Google "T-Mobile APN settings" and you'll find them immediately.



    dpham00, Android Central Moderator
    Sent from my T-Mobile iPhone 5S
    06-28-2014 05:41 AM
  8. flyer8493's Avatar
    I'm doing the 7 day challenge from tmobile. According to tmobile's coverage map I should have a very strong signal with 4g and excellent voice. But I'm lucky to have edge and half the time have no service. I call BS.
    07-01-2014 04:30 AM
  9. zorak950's Avatar
    Isn't the whole point of the free test drive so you can find out things like that?
    07-01-2014 10:35 AM
  10. Almeuit's Avatar
    I'm doing the 7 day challenge from tmobile. According to tmobile's coverage map I should have a very strong signal with 4g and excellent voice. But I'm lucky to have edge and half the time have no service. I call BS.
    Isn't the whole point of the free test drive so you can find out things like that?
    This. Be happy flyer that it's free. I tried Verizon out for a few days... Didn't like it so went back to T-Mobile... I had to pay Verizon 140 $ .

    Sent from my T-Mobile Note 3 using AC Forums.
    dpham00 likes this.
    07-01-2014 10:57 AM
  11. dpham00's Avatar
    I'm doing the 7 day challenge from tmobile. According to tmobile's coverage map I should have a very strong signal with 4g and excellent voice. But I'm lucky to have edge and half the time have no service. I call BS.
    Sorry it didn't work out. Didn't work out good for me either. But I have to applaud t-mobile for letting us try it completely free

    dpham00, Android Central Moderator
    Sent from my Verizon Samsung Galaxy Note 3
    07-01-2014 11:48 AM

Similar Threads

  1. Can't root my phone
    By xabg17 in forum T-Mobile Galaxy S III
    Replies: 4
    Last Post: 10-24-2016, 04:33 AM
  2. Fingerprint Sensor -- I Was Wrong, I Admit It
    By PsychDoc in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 06-29-2014, 12:52 AM
  3. Problems phoning out
    By Rosalind Talbot in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 06-28-2014, 02:57 AM
  4. pictures from phone sd card won't show on pc
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-28-2014, 02:52 AM
  5. Google voice search opens with media playing
    By Brian Ekerman in forum General Help and How To
    Replies: 0
    Last Post: 06-27-2014, 04:43 PM
LINK TO POST COPIED TO CLIPBOARD