1. Ryan Harrison's Avatar
    I've been searching online trying to find a solution but have come up empty handed. Hopefully someone here knows what I can do. I bought a galaxy note 3 from AT&T in December and it has been kept in a zerolemon full body case with a screen protector. This phone has been babied 24/7. Since I got it my boss always complains that when she calls she gets feedback or an echo and can't hear me. recently clients have started to complain too, so on Thursday I took it to AT&T to get it looked at. They recreated the problem in store and tried everything to fix it, then had me call the warranty department to send me a replacement. Well today I got the replacement and the first thing I did out of the box was make a phone call. The replacement unit has the same problem but now it's even worse! no one can hear me at all in the call. Switching to speakerphone fixes the problem and the problem does not happen on skype or other VOIP. I went back to the AT&T store again tonight and they blamed the screen protector (the same one they sold me with my original phone) and after a bit of aruging told me to call warranty department tomorrow.. I'm going to call but what do I do if I get a 3rd defective unit? The AT&T rep in the store told me that they probably won't even replace this note 3 they'll just give me a similar phone like the Optimus G Pro. I'm so mad! I didn't pay $700 for an optimus G pro!.. has anyone heard of a problem like this? I was also unable to update to 4.4 on my old phone and on this replacement. It tells me i'm up to date with 4.3...

    the replacement phone i'm stuck with now is running android 4.3. it's a N900A just like my first one, and the build number is JSS15J.N900AAUCUBMJ5
    04-08-2014 11:28 PM
  2. Evilguppy's Avatar
    I'm with Verizon, but I had several phones with AT&T and every single time I had the same issue: all calls sounded as if they were taking place in an underwater tunnel.
    And now, when I talk to anyone who's with AT&T it's the same thing, they sound like they're under water. So my guess is the problem is with AT&T, not with your device. My Verizon Note 3 sounds crystal clear.
    04-08-2014 11:55 PM
  3. o4liberty's Avatar
    I just left Verizon after 15 years and picked up a note 3 on AT&T and call quality has been nothing but seller! In fact it's way better than Verizon was it's much clearer. I just think you have another bad device IMO.. Do all you calls happen in the same area or everywhere?
    04-09-2014 05:17 AM
  4. Ryan Harrison's Avatar
    unfortunately I have the issue everywhere. My business cell phone and my bosses phone are both AT&T iPhone 5S's and neither of those have this issue. Just got off the phone with AT&T and they're sending me another replacement phone. I'll keep you all updated with that one, it gets here tomorrow.. lol. I live in downtown Tucson so I can't imagine that it's just the network. I think that it's just a bad batch of Note 3's
    04-09-2014 01:43 PM
  5. Spencerdl's Avatar
    I have a Verizon Note3 and 5s, both are crystal clear on both ends. When I had Sprint, now that was a different story all together...thats why I switched to Verizon.
    04-09-2014 01:50 PM
  6. jneusch's Avatar
    I went through 3 replacement Note 3's for another problem. They tried giving me an LG G pro. I looked on the web site while on the phone and realized that it was not an even swap since I already paid of my Next plan. They them sent me a G2 which was better than the Gpro, but not nearly as good as the Note. I called again and the 4th replacement was perfect.

    Posted via Android Central App
    04-11-2014 02:21 PM
  7. H3aTeRzz's Avatar
    Having the same issues here lately with AT&T. I have the zerolemom case and now am wondering if that's the problem. I have another note 3 without it and am going to be switching it to my primary to see how it does without the case on it.
    04-11-2014 02:26 PM
  8. H3aTeRzz's Avatar
    Just got off the phone with AT&T. They said there was a tower out, but also noted that there was an error showing up on her end regarding my phone being forwarded. I at first thought it might have been an issue with KK, but initially ruled it out because my other note 3 was going it; however, at the last time I noticed the issue, I had my personal phone forwarded to my note 3 running 4.3, so "it could" still have something to do with 4.4. She did some kunfoo stuff on my personal phone, and had me restart it. So once again, I'm in testing mode; at present, I hear no echo's at all. My issue started at about the time KK came out, but then again, and for the most part, I keep the KK enabled phone forwarded to my 4.3 work phone.

    I have un-forwarded them and will run them separately for a while to see if the problem continues. ,....Have a great weekend, I'll report on this after a couple of days of testing.
    04-11-2014 03:37 PM
  9. Neil Inabnitt's Avatar
    I am experiencing a similar issue. It's random with mine though. About 10% of my calls are doing what you guys described. I have the note 3 with AT&T using an otter box case and kitkat 4.4.2 no root. I'll keep updates of what I find as well.
    04-28-2014 05:40 PM
  10. Flyin2low's Avatar
    One of the microphones is probably being covered up by the case
    04-29-2014 08:34 PM
  11. Madonna Warwick's Avatar
    My Note 3 just started echoing in last few days. Got new Zerolemon extended battery and case. Wondering if case since others with case are reporting this happening too.

    Posted via Android Central App
    04-30-2014 08:36 PM
  12. wendy5001's Avatar
    This just started for me, random occurrence and my SN3 is naked minus a screen protector. I'm on AT&T. Any ideas or updates from the carriers?

    Sent from my SAMSUNG-SM-N900A using Tapatalk
    05-03-2014 06:14 AM
  13. H3aTeRzz's Avatar
    My Note 3 just started echoing in last few days. Got new Zerolemon extended battery and case. Wondering if case since others with case are reporting this happening too.

    Posted via Android Central App
    Sadly, it appears that the zerolemon is the culprit on the echoing so far. I took the case off earlier today and made a few calls since then, and no echo!!! This SUCKS!!! I really like my 10000 MAH battery!!!!
    05-03-2014 08:17 PM
  14. H3aTeRzz's Avatar
    Sadly, it appears that the zerolemon is the culprit on the echoing so far. I took the case off earlier today and made a few calls since then, and no echo!!! This SUCKS!!! I really like my 10000 MAH battery!!!!
    Doesn't look like the case was the problem at all now!! I did start it again...no matter what case I had on it. or off.I have rebooted into Safestrap and went back to my stock rom, from the Skynote Rom, and SO FAR, no echo, my issue might have been the rom. Will report on it again in a day or two to be sure.
    05-07-2014 01:20 PM

Similar Threads

  1. Galaxy S5 Prime?!?
    By atg284 in forum Rumored Devices Lounge
    Replies: 12
    Last Post: 04-20-2014, 05:21 AM
  2. Replies: 5
    Last Post: 04-19-2014, 09:35 AM
  3. Man smashes Galaxy S5 with hammer, Galaxy S5 takes revenge
    By smooth4lyfe in forum Samsung Galaxy S5
    Replies: 35
    Last Post: 04-11-2014, 09:44 PM
  4. The Design Issue
    By Adranalyne in forum Samsung Galaxy S5
    Replies: 10
    Last Post: 04-09-2014, 11:58 AM
  5. Replies: 2
    Last Post: 04-09-2014, 10:15 AM
LINK TO POST COPIED TO CLIPBOARD