1. charlee08's Avatar
    I work inside a brick building and my Note 3 struggles to find any reception in the office at all. My previous phones, like the Moto X, HTC One M7, iPhone 5, and Nexus 4 never had near this many problems finding service. This phone also is slower than my other phones at connecting to HSPA+, which is what I have in my area.

    I'm hoping this is a sim card problem and not the phone, because I love the phone.

    Anyone else had similar problem with their Note 3?

    Posted via my Note 3
    05-05-2014 09:12 PM
  2. charlee08's Avatar
    Well, I stuck my sim card in an old S3 and it's holding onto reception like my other phones did. Must be the phone.

    Posted via my Note 3
    05-06-2014 12:21 AM
  3. Zacharyw70's Avatar
    First off make sure your Wifi settings aren't causing the issue. I've heard of a lot of people that have had issues and fixing those options did it. Myself in particular I've been having issues with my connection and after changing my options it's all better now.

    Go into Wifi>Hit button left of the menu button>Advanced options and then uncheck everything there.

    If you've done that already it could possibly be a defective Wifi chip, but hopefully it doesn't come to anything like that.
    05-06-2014 10:59 PM
  4. charlee08's Avatar
    Thanks for the reply... I did already have everything unchecked.

    Posted via my Note 3
    05-07-2014 07:38 AM
  5. pappyfire's Avatar
    First off make sure your Wifi settings aren't causing the issue. I've heard of a lot of people that have had issues and fixing those options did it. Myself in particular I've been having issues with my connection and after changing my options it's all better now.

    Go into Wifi>Hit button left of the menu button>Advanced options and then uncheck everything there.

    If you've done that already it could possibly be a defective Wifi chip, but hopefully it doesn't come to anything like that.
    Thanks! I never would have thought WiFi settings would affect cellular signal strength. I unchecked all the boxes and my signal strength instantly went up. Just to prove I wasn't imagining it, I rechecked them and my signal strength dropped, unchecked and it went back up.
    05-07-2014 08:37 PM
  6. Morpheus's Avatar
    What things specifically are you unchecking? What software update are you on?

    Posted via Android Central App
    05-09-2014 01:06 PM

Similar Threads

  1. weak reception/no service switches off automatically
    By sahqib in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 05-04-2014, 06:46 AM
  2. Getting horrible reception!
    By Redx in forum Verizon Galaxy S III
    Replies: 3
    Last Post: 05-02-2014, 12:44 AM
  3. T-Mobile: Poor LTE Speeds, Southwest of Atlanta
    By ThackerSS in forum T-Mobile
    Replies: 8
    Last Post: 04-29-2014, 12:23 PM
  4. Samsung video player to bluetooth poor sound quality?
    By asworldandroid in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 04-29-2014, 08:57 AM
  5. Poor GS4 Performance since Factory Restore and Several Errors
    By Drakus127 in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 04-28-2014, 05:05 PM
LINK TO POST COPIED TO CLIPBOARD