Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 12 of 12
  1. Thread Author  Thread Author    #1  

    Default Galaxy S4 Slow WiFi Issues when using AES

    Just got a new S4 and it works fine except for WiFi. I noticed a limit of a 4Mbps download speed (upload is fine) when using WPA2-PSK (AES) or (TKIP/AES) security modes on my router. All other 802.11n phones and computers in the house are hitting around 25-30+ Mbps download on this setting.

    However, when I set the security mode to the older WPA2-PSK(TKIP), I get speeds at about 20 Mbps dowload on my S4. This is an improvement, but now using TKIP I've limited all other devices in my house to 802.11g speeds instead of the faster 802.11n speed that AES uses.

    I exchanged the phone for a new S4 and I get the same issue with the new one.

    Does anyone else using WPA2-PSK (AES or TKIP/AES) security on there router have this issue? I've tried messing with every networking setting on the S4 and on my router to get this to work properly. I'm thinking my router is ok because I'm hitting 36 Mbps on my other WiFi devices. Thanks.
  2. #2  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    Interesting it looks like I might be seeing the same thing. I'll have to test some more. I have a 30/5mbps connection at home and running a speed test on my phone got me about 3 meg down and 5 meg up
  3. #3  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    There is definitely something wrong.

    This is a test from a S3 on my wifi




    And here is the results from my S4

  4. Thread Author  Thread Author    #4  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    Quote Originally Posted by gabbott View Post
    Interesting it looks like I might be seeing the same thing. I'll have to test some more. I have a 30/5mbps connection at home and running a speed test on my phone got me about 3 meg down and 5 meg up
    It's strange, isn't it? Does changing your security mode on your router affect your results at all?
  5. #5  
    seinx's Avatar

    Posts
    71 Posts
    Global Posts
    72 Global Posts

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    Changing my setting to TKIP only hasn't affected anything aside from the fact that I can use WiFi on my phone with zero problems now! Are you on channel 11 or auto?
  6. #6  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    I had forgotten to get back to this thread to post my updates to what I was seeing. For me, a reboot of my phone seemed to clear up the speed issues I was seeing on my S4.

    So for me, not having an issue on my wifi using AES.
  7. #7  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    Experiencing exactly the same.... did you find a solution/fix? Thanks.
  8. #8  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    I just got my new SG4 and my wifi the same day, and I noticed the lack of speed in my S4 device, but in my other devices everything worked fine. Thanks to you, now it's fixed! That worked for me pretty well. Thank You!
  9. #9  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    What router do you have? I just upgraded the firmware on two DLink DIR-655's for S4 compatibility issues.
  10. #10  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    If you have a router with IPv6 disabling it will fix the issue. Note 3 and 2 S4 Galaxys in the house and an IPhone5. The IPhone 5 connected to wifi and ran normal speeds. all Galaxys would just crawl if connected at all. after disabling IPv6 option in my router all galaxys are faster then the IPhone 5 now.
    OLOW_Sean likes this.
  11. #11  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    Disabling the IPv6 worked for me
  12. #12  

    Default Re: Galaxy S4 Slow WiFi Issues when using AES

    I have a Galaxy S4 with the newest firmware from samsung I9505XXUGNF1 (Kitkat 4.4.2). My router is a Asus RT-AC66U to which My S4 connects to with max speed of 433 Mbps. My internet connection is 120 Mbps.

    When I do a speedtest on the S4 I get results of over 110 Mbps, but when I'm downloading a file over LAN from the disk connected directly to the router I get download speed only of ~20Mbps (2.4 MB/s) which is very sucky!

    My Laptop have only a N network card, and connects to the router with max 300 Mbps and when I download the same file I get over 7.5 MB/s!! (~65 Mbps).
    Speedtest also shows results of over 110 Mbps...

    I remember when the phone was new, and it had Android 4.3, I had LAN download speed of over 9-10 MB/s...

    I tried with different file managers like X-Plore and others, but it looks like it is not the app problem.

    I have disabled IPv6.. what can be the problem?

Similar Threads

  1. gps slow to lock when using navigation
    By jaekim717 in forum Samsung Galaxy S3
    Replies: 8
    Last Post: 04-29-2013, 01:14 AM
  2. Do we lose access to AT&T wifi hotspots when using Custom Roms?
    By andy_d in forum AT&T Galaxy S3 Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 03-16-2013, 05:02 PM
  3. galaxy s3 international WiFi issues?
    By vanvar07 in forum Samsung Galaxy S3
    Replies: 0
    Last Post: 08-16-2012, 12:48 AM
  4. galaxy s3 international WiFi issues?
    By vanvar07 in forum Samsung Galaxy S3 I9300
    Replies: 0
    Last Post: 08-16-2012, 12:48 AM
  5. No wifi data when using bluetooth
    By dahkillah in forum Samsung Galaxy S II Skyrocket
    Replies: 0
    Last Post: 01-11-2012, 09:09 PM

Posting Permissions