1. DanDanMC95's Avatar
    I have tried rooting my hero s with supertool v3. It says It's rooted. But when I use root checker it says it hasn't rooted?. Any suggestions?
    04-20-2012 02:50 PM
  2. darkprince004's Avatar
    I'm getting the same thing on my wife's Hero S. I rooted mine with the supertool (in fact I'm unlocked as well), but it doesn't want to take on hers. What are we doing wrong?
    04-26-2012 09:27 PM
  3. DanDanMC95's Avatar
    Can you tell me step by step what you did to root your hero? When the people who posted the original instructions most of the links were broken? I am at a complete loss. This is my very first android phone. And i wanna root it correctly, and not screw up my phone..
    05-02-2012 09:03 PM
  4. grad061980's Avatar
    Use this root tool (one click root). If the links in that thread doesn't work, then click at the top of the page on downloads, then hero s, then root/s-off, to find the files needed to complete the instructions in the thread. If you follow the instructions to the t, then you should be root. If your phone is too high of a software # to accept the root method (find it under menu, system settings, about phone, software), then you can unlock via htcdev.com, install a custom recovery, & flash a su.zip to get root (clockworkmod recovery & all other instructions at that site too). http://2fastroms.com/showthread.php?p=7810 hope that helps. There are good folks at that site & will be willing to help.
    DanDanMC95 likes this.
    05-02-2012 11:46 PM
  5. DanDanMC95's Avatar
    It worked!!! Thank you so much!!!
    grad061980 likes this.
    05-03-2012 10:09 AM
LINK TO POST COPIED TO CLIPBOARD