1. poi09's Avatar
    6 months with the phone, generally happy with it. Yes, poor battery life (keep a second charged battery around). Had occasional data drops: no 1x, 3g, or 4g. Self corrected after a few minutes. Usually happened when in a poor signal or non-4g area. Did not happen often enough to complain.

    1 week ago had no data, no data signal in the notification bar. Happened while away from home in a non-4g area. Corrected with verizon on the phone. They had me pull the battery and the sim card. They "did something on their end" and then it worked fine until last night while away from home in non-4g zone.

    Again, no data. Called Verizon: general 4g outage and wait until today.

    Today, no data and no phone service. No signal strength bars. Just a circle with a line through it. Did a battery pull: still no phone or data but now the gps is in constant search for signal mode and there is a new notification icon in the bar that I have not seen before without any text in the notification pull down screen. The icon looks like a sim card with an exclamation mark along the right border.

    So on the phone with VerizonWireless again, "Still an outage."

    Personally, I think it is the sim card as reported here by others. Will head to the store tonight to wait on line and see if they can replace the card.

    None of the three agents ever asked me to do a hard reset.

    I'll let you know how it works out.
    12-07-2011 03:56 PM
  2. mozicodo's Avatar
    I have the same problem. Did you ever get this resolved?
    12-14-2011 02:57 PM
  3. poi09's Avatar
    The notification symbol that looks like a sim card with an exclamation mark along the right edge simply means that there is no sim card inserted. The tech pulled the card, wiped it and the contacts, reinserted, and service was restored.

    I still get the data drops (at the most inoppurtune times). The gps is taking longer to lock on. Sometimes it is instant. Other times, outdoors with clear view of sky, 20 minutes. Makes it unreliable.
    12-15-2011 12:18 PM
  4. Daniel Hagyard's Avatar
    pro smart same problem
    02-11-2013 01:04 AM
LINK TO POST COPIED TO CLIPBOARD