1. egborko's Avatar
    If you take off the back cover of the phone, is it quite obvious that the usb port is loose? Meaning if you just tap the back of the phone (near the port) with your finger you can hear it rattle (when the back cover is off). When the cover is on, I can wiggle the port. Is this just how the phone is made or should I take it back? It will be 14 days tomorrow.

    Thanks!
    05-12-2011 09:46 PM
  2. egborko's Avatar
    let me add - that when the cover is off, it is VERY easy to move the usb around with your finger.
    Thanks for the help!
    05-12-2011 09:55 PM
  3. Kevin217's Avatar
    I just noticed today that the plastic surrounding the usb port is lose on mine as well. I haven't touched it with the cover off, but with it on i can wiggle it back and forth a little bit.
    Not sure if its a defect or what, but I bet it has something to do with the cable fitting SO damn tight.
    05-12-2011 11:44 PM
  4. mclaughh#AC's Avatar
    mine wiggles as well, I'm pretty sure they are all made that way.
    05-13-2011 10:40 AM
  5. egborko's Avatar
    Thanks! good to know. Might go to the bigV and make sure though.
    05-13-2011 09:01 PM
  6. LowFire's Avatar
    It is just the insert, and a lot have noticed it

    It is NOT the actual port, no need for alarm
    05-14-2011 08:29 AM
  7. egborko's Avatar
    what do you mean by "just the insert"?...so it's not the usb that wiggles? is there a link to another thread about this? THANKS!
    05-15-2011 03:33 PM
  8. Kevin217's Avatar
    what do you mean by "just the insert"?...so it's not the usb that wiggles? is there a link to another thread about this? THANKS!
    He means that it is just the jet black surround to the port that's loose, not the actual usb port. So it's just a cosmetic thing.
    05-15-2011 08:03 PM
  9. mhzimmer's Avatar
    A related issue that made me have to swap my DINC2 out at Verizon last week...

    After 1 week, my phone stopped charging. I figured out the problem was the USB port on the phone. If I pulled upward on the cable, it started charging again; but once you released pressure it would think it was disconnected again. I tried this with 3 different cables and got the same result each time (so it wasn't a defective cable).

    Verizon replaced the phone right away with no hassle, so I'm back working again. I'm just hoping that my particular phone had a rare defect... and that this doesn't turn out to be some kind of design flaw!
    05-15-2011 10:30 PM
LINK TO POST COPIED TO CLIPBOARD