Results 1 to 12 of 12
  1. Thread Author  Thread Author    #1  

    Default Inbound calls without area code

    I am getting calls from contacts that are in my contact list, but are not matching because the incoming call is not using the area code because we are in the same area code.

    So... If I am in area code 222 and the caller is also from 222, the number showing on the caller id is 123-1234 without the area code.

    This means the system doesn't match the number even though the full number 222-123-1234 is in my contact list.

    Seems like there should be a setting somewhere that sets the area code for the phone.

    I've been searching for where that might be but can't find anything.
    Active Phone: T-MOBILE - Samsung Galaxy Note 3 - Rooted/Stock
    Tablet: Nexus 7 16gb Stock Rooted - 4.2.1 - TWRP Recovery
    Active Phone: VZW - HTC ReZound - Rooted/JuopunutBear S-Off - Stock GB 2.01.605.11 ROM
  2. Thread Author  Thread Author    #2  

    Default

    This is becoming a problem.

    Anytime someone calls me from my office, the number that shows up is with an area code. This appears to be true for all calls that originate from the same area code as my phone.

    All my contacts have area codes in them, so these inbound numbers don't match what is in my contact lists.

    In most phones, you can set the area cod you are in, and it will know that.

    I can't find anything like that however in the DI.

    How are others dealing with this. This can't be the only area which has several area codes in the same region.
    Active Phone: T-MOBILE - Samsung Galaxy Note 3 - Rooted/Stock
    Tablet: Nexus 7 16gb Stock Rooted - 4.2.1 - TWRP Recovery
    Active Phone: VZW - HTC ReZound - Rooted/JuopunutBear S-Off - Stock GB 2.01.605.11 ROM
  3. #3  

    Default

    Wait, you said:

    Anytime someone calls me from my office, the number that shows up is with an area code. This appears to be true for all calls that originate from the same area code as my phone.

    and

    All my contacts have area codes in them, ...

    So... if all the calls show an area code and all of your contacts have area codes in them, then maybe the area code isn't the issue? What are we missing?
  4. #4  

    Default

    i didnt know this was still an issue in any part of the USA. everywhere i go you must dial the area code even if you are calling your friend next door.
  5. Thread Author  Thread Author    #5  

    Default

    The office is located in the same area code as the phone is.

    When someone calls from the office (area code 602) to the phone (also areacode 602), the number that is displayed on the phone is without the area code.

    The contacts are from my Exchange contact list, which is used both here and other places so the area codes need to be there or I can't use the number.

    I could remove the 602 area code from all the contacts, but then when used by something else and I was not using a 602 device, I wouldn't be able to dial them.

    Also, note, this is not a dialing issue.... they are calling me. it is the phone that is only displaying the number without the area code. That has nothing to do with how they dialed me.
    Active Phone: T-MOBILE - Samsung Galaxy Note 3 - Rooted/Stock
    Tablet: Nexus 7 16gb Stock Rooted - 4.2.1 - TWRP Recovery
    Active Phone: VZW - HTC ReZound - Rooted/JuopunutBear S-Off - Stock GB 2.01.605.11 ROM
  6. #6  

    Default

    Hello, who is this?
  7. #7  

    Default

    Have you tried Settings > Call > Assisted Dialing and putting your area code in the "Area Code" field and checking "Enable Assisted Dialing" at the very top? I don't know if this will help, but I am not experiencing the problem and I have done these things. I hope it helps.
  8. Thread Author  Thread Author    #8  

    Default

    Actually, I did look at that... and I thought I had set it to 602... but I look at it now and it is back to 0.

    Just changed it. Will have someone from work give me a call again.
    Active Phone: T-MOBILE - Samsung Galaxy Note 3 - Rooted/Stock
    Tablet: Nexus 7 16gb Stock Rooted - 4.2.1 - TWRP Recovery
    Active Phone: VZW - HTC ReZound - Rooted/JuopunutBear S-Off - Stock GB 2.01.605.11 ROM
  9. #9  
    JF
    JF is offline
    JF's Avatar

    Posts
    99 Posts

    Default

    I don't get what the problem is.

    Are you saying that the caller id as a result doesn't correspond to your contact list?
  10. #10  

    Default

    I have the same issue. (I also have a HTC Incredible)
    Inbound calls originating from my area code do not contain the area code in the inbound number.
    My numbers are all stored with area codes in my contacts.
    So inbound calls do not match my contacts and it will not display the contacts name.
    Example:
    Contact: Joe Jones 208-123-1234
    Inbound call: 123-1234
    Inbound caller display: 123-1234
    SHOULD BE:
    Inbound caller display: Joe Jones.
  11. #11  

    Default

    I have the same problem. I use outlook contacts and if someone calls me from my same area code with a 7 digit number it doesnt register the contact...just an unknown caller. Any fixes for this?
  12. #12  

    Default Re: Inbound calls without area code

    I have received call from my no to my second no but actually i was not called to my other no. second thing is that no not containing area code and after end of call it not saved in my call logs file i dont know what happens with my no

Posting Permissions

B