02-01-2016 03:31 PM
45 12
tools
  1. Adrynalyne's Avatar
    Its not terribly common, but there have been some cases where upon installing froyo and updating the camera, the firmware flash has messed up and broken the camera. Make no mistake, this is not a software issue. Its a camera firmware issue and the only way to fix it is to reflash the firmware.

    Now, the camera software offers once. After that, if it fails, it isn't going to prompt again.

    To get around this:

    1. Download Launcher Pro from the market. Any cut and ADW will likely work too.
    2. make a new shortcut, to an activity.
    3. Scroll to Camera Firmware, and choose the second option (user)
    4. Click ok. There is now a shortcut on your homescreen. Choose the third option, Phone to CAM FW Write. Put your phone down and do not touch it until it is done.


    Hope this helps.
    02-12-2011 10:31 AM
  2. gunnermike53's Avatar
    my camera worked and prompted me to dl the frim ware and all is well, but you are a machine. i hope you get enough cash from us folks to buy your wife that Nook. i almost have my wife convinced to send some money your way, but she doesnt get this geek stuff. im workin on it though.
    02-12-2011 10:45 AM
  3. Adrynalyne's Avatar
    Yeah, they covered me for the Nook. My wife now loves me again
    02-12-2011 02:11 PM
  4. tw105188's Avatar
    Whew...close call adryn lol. Hope she likes it. Thanks for devoting so much time! Goes for all the rest of ya geeks as well!

    Sent from my SCH-I500 using Tapatalk
    02-12-2011 11:56 PM
  5. tw105188's Avatar
    Btw, adrny, down loaded your 2.2...still nothing from my battery icon..its weird..had to put on a theme to get battery notification.

    Sent from my SCH-I500 using Tapatalk
    02-12-2011 11:57 PM
  6. Adrynalyne's Avatar
    That is so bizarre. I am totally at a loss as to what would cause that.
    02-13-2011 11:26 AM
  7. gunnermike53's Avatar
    That is so bizarre. I am totally at a loss as to what would cause that.
    same happened for me. i flash themes anyway so no biggie.
    02-13-2011 02:22 PM
  8. tw105188's Avatar
    Eh i did too and Im very happy with it..just dont like that i 'had' to. Feel like i goofed somewhere....which i probably did lol

    Sent from my SCH-I500 using Tapatalk
    02-13-2011 02:31 PM
  9. chubbrock's Avatar
    tried this on two fascinates and didn't fix the camera
    04-25-2011 09:05 PM
  10. Adrynalyne's Avatar
    Then there is likely something else wrong with the camera.

    What was the error?
    04-25-2011 09:15 PM
  11. UltiMatDan's Avatar
    Tried this on my fascinate as well and it didn't fix the "please wait" message and crashing of the camera. Is there another option to try?
    04-26-2011 08:13 PM
  12. Kjax016's Avatar
    Tried this and I'm still getting a "please wait..." message. Very frustrating! I'm happy with everything else in the update but this sucks!
    04-28-2011 09:30 PM
  13. yaeyaeman's Avatar
    I am unable to get this to work either. Is there a need to grant the update app superuser permission or to make the system writable?

    Also, I notice that the firmware update progresses steadily up to about 88% and then claims to complete successfully. Is it supposed to skip the last 12%, or could that be why it still doesn't work?

    Either way, thanks for the advice on how to try fixing the camera.

    Addition: Also, I'm wondering if there might be a corruption in the camera app. Even though it was stated not to be software in the original post, it probably wouldn't hurt to get a working copy of the system camera app posted just for troubleshooting (root access is assumed, of course). That is, if there is such a thing. I'm not too familiar with the actual OS.
    05-03-2011 12:41 PM
  14. nobledean's Avatar
    Hey, so i have this same problem.. and when i try to make a shortcut, there isn't anything that says "camera firmware", like i'm supposed to click on. please help! thanks(:
    11-04-2011 08:53 PM
  15. Lttlwing16's Avatar
    Hey, so i have this same problem.. and when i try to make a shortcut, there isn't anything that says "camera firmware", like i'm supposed to click on. please help! thanks(:
    assuming your using Launcher Pro correct?
    11-05-2011 10:38 AM
  16. nobledean's Avatar
    Yes, i'm using Launcher Pro.
    11-05-2011 12:11 PM
  17. nobledean's Avatar
    okay, so i got it to the point where it starts to load. but when my phone gets to 99% (250/253) it stops. i don't know what to do. please help, i'm going on vacation soon, and i would like to use my phone. it would mean a lot if i could get your help to fix it. thanks!
    11-14-2011 06:27 PM
  18. smashnlc82's Avatar
    I am also running launcher pro plus. I do not come across an option to reload the camera firmware. I am running pool party 1.6 with no theme and CWM4. Please help!!! I know if I'm patient you guys will figure it out ......you always do!!!
    11-15-2011 10:31 AM
  19. tmags2's Avatar
    This happened to me. It was so frustrating. I eventually downloaded gingerbread 2.3.4 and now no problems. When In camera mode, Attempt to shut off phone and you see a lock icon pop up in the upper right corner. Here you can't get out of camera mode unless you hit power again to unlock.
    11-18-2011 02:39 PM
  20. nobledean's Avatar
    This happened to me. It was so frustrating. I eventually downloaded gingerbread 2.3.4 and now no problems. When In camera mode, Attempt to shut off phone and you see a lock icon pop up in the upper right corner. Here you can't get out of camera mode unless you hit power again to unlock.
    How did you download gingerbread 2.3.4?
    11-25-2011 05:22 PM
  21. zrgandrei's Avatar
    Hey! I am using laucher pro but i do not see the option "camera firmware" when I try to make the shortcut to the activity. I have only the option "camera" can somebody please help me because I am starting to lose my mind fixing this camera.
    11-19-2012 07:41 PM
  22. levare's Avatar
    can you guide me through the steps to fix my camera i am stuck after downloading the launcher pro
    01-04-2013 08:22 AM
  23. Real Media Shop's Avatar
    Hi
    I just bought the Galaxy Note II DUOS GT-N7102. I rooted it in order to install Googles service since the chinese Version doesnt have this.

    Now, my camera does not work again, I keep getting the error message: Camera fail.

    I cleared the cache. and even reinstall stock rom, still no solution.

    The camera itself is OK, because if I use video call with skype it is ok, but starting the camera app to make call will not work.

    Do anyone have a solution??
    02-09-2013 12:37 PM
  24. roenma2001's Avatar
    After trying so much things to get my captivate`s camera to work, frustration gave me a simple answer and it works all the time. Just go to your camera app, when the screen is black, tap your phone against the palm of your hand about three times with moderate force, and the camera will start working. It has worked every time for me. I have a samsung galaxy s captivate I897. Sometimes the screen of the camera look fuzzy, just take a picture and all the next pictures will como perfectly clear.
    03-18-2013 09:19 AM
  25. sam007's Avatar
    i am using the device have android 2.3.5 here is a problem in camera when i start click the icon of camera its shows me " Cannot connect the camera " pls help me out of this problem
    07-01-2013 02:09 AM
45 12
LINK TO POST COPIED TO CLIPBOARD