Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By heloguy
  1. Thread Author  Thread Author    #1  

    Default **FIX** cannot connect sd card to pc

    I have been searching the internet for 2 full days trying to figure out why my new pc wont recognize my sd card when i plug it in.

    finally, I stumbled across a fix posted for a similar problem with another USB thumb drive, and it worked perfectly!
    I hope this helps anyone like me that was ready to rip their hair out.


    For the USB thumb drive, try the following:

    "Run "regedit" and select the "HKEY_LOCAL_MACHINE/SYSTEM/MountedDevices" folder. See all the "Dos Devices" listed? You'll have one entry for each physically mounted drive (HDD or Disc) plus you'll have one show up for each USB drive you attempt to insert. Double click each device listed and see if you see text saying something like "U.S.B.S.T.O.R...". Once you find that device, right click it and select "Rename". Now change the drive letter to something unused... like Q: or something. Close regedit, disconnect the USB device and reconnect again.

    If all went well, you should be able to see your new drive when you plug it in. I recently had a conflict with my Sandisk 5-in-1 reader and my PNY thumb drive. I forced my PNY to be the N: drive and the Sandisk to be the M: drive, that solved the problem. Unfortunately, I can't get this darn USB-IDE to resolve it's conflict."

    Good luck!
    Thanked by 5:
    zaidyft likes this.
  2. #2  
    sup3rchi3f's Avatar

    Posts
    109 Posts
    ROM
    Suprclean 2.9.2ec10 voodo

    Default

    I have a similar problem ..when I connect my phone to my computer via usb I no longer get the mount sd notification option, unless I turn debugging mode on but it wasn't always like that. Is debugging mode something I should leave turned off or does it matter?
  3. #3  
    gunnermike53's Avatar

    Posts
    3,199 Posts
    ROM
    Gummy, AOKP

    Default

    i havent heard of anyone experianceing this problem since dl09. but if it sill exists (obviously it does) this whould be a more visible thread. maybe included in the faq stickie.

    good work heloguy.
  4. #4  
    Sta11i0n's Avatar

    Posts
    960 Posts
    Global Posts
    961 Global Posts
    ROM
    CM10/Devil

    Default

    Quote Originally Posted by sup3rchi3f View Post
    I have a similar problem ..when I connect my phone to my computer via usb I no longer get the mount sd notification option, unless I turn debugging mode on but it wasn't always like that. Is debugging mode something I should leave turned off or does it matter?
    That's up to you. Myself, along with many others tend to leave it on for easier access to the phones internal memory for ADB/recovery usage. I've seen a few kernels that give the issue of not showing USB connected. Either leave debugging on or try a different kernel.
  5. Thread Author  Thread Author    #5  

    Default

    Quote Originally Posted by gunnermike53 View Post
    i havent heard of anyone experianceing this problem since dl09. but if it sill exists (obviously it does) this whould be a more visible thread. maybe included in the faq stickie.

    good work heloguy.
    Thanks Mike.
  6. #6  
    papa54's Avatar

    Posts
    590 Posts
    Global Posts
    592 Global Posts
    ROM
    Eclipse 2.0

    Default

    [QUOTE= Originally Posted by sup3rchi3f
    I have a similar problem ..when I connect my phone to my computer via usb I no longer get the mount sd notification option, unless I turn debugging mode on but it wasn't always like that. Is debugging mode something I should leave turned off or does it matter?[/QUOTE]

    ok since you all have the same problem i might be able to help..

    dont click on USB in settings ..
    go to settings/applications/development/ and check the USB debugging box..

    then attach the USB cable to the PC/ then: wait untill you see the USB Icon in upper left of status bar..
    then you willl open status bar and click on the box that reads similar to this.. click on to copy files etc..

    then wait and a green droid will pop up when he does the words under him will say "connect to USB" click it and then you will see a orange droid show up on screen with wording "connected to usb".. then just open explorer on your pc and look for the new drive and from there you can copy delete or move etc all or any files from and to pc/ph..

    i have a fascinate and hope this helps you..
  7. #7  

    Default

    I have an issue with my Fascinate. I can get it into download mode but the computer won't recognize it. I also notice that when I have it in usb mass storage mode, the computer does not read up on it. I have the drivers installed and tried it on four different computers. I have tried usb debugging mode and nothing. Anyone else having issues with ODIN not seeing their Fasciante?
  8. #8  

    Default

    I have. I also have issues with the phone charging sometimes with the factory cable. My phone randomly shows usb connected, even when it is not, but only when debugging is on. Someone on irc told me I may have shorted the usb port somehow and to get a replacement. Haven't been able to afford it yet. Did get back to full stock and then ota'd to latest vzw bloat rom. I'm clean and good to go once I have a spare $90 for the insurance. Otherwise phone is acceptable minus occaisional bad battert life (false full charges).

    Also, some people have found that it is just a dirty usb port. Some have found success taking a small paintbrush and some rubbing alcohol and cleaning the port. Others have used a linux live cd and ubuntu to use its odin brother heimdall. Same functions and is what odin is vased off of. Others have bought an aftermarket cable and tried that. And an extreme measure of disconnecting all usb devices, uninstall them, reconnect phone, install drivers and open odin to try connecting there, has been successful in some instances.

    Hope this helps some.

    Sent from my SCH-I500 using Tapatalk
  9. #9  

    Default Re: **FIX** cannot connect sd card to pc

    On Samsung Galaxy Grand on Jelly Beans this worked -
    Scroll down the notification after you connect the USB cable to PC, and choose media - See this blog post explained with screenshots -
    Day 2 Day Experiences: Samsung Galaxy Grand | Android | Unable to see my SD CARD on computer via USB
  10. #10  
    zaidyft's Avatar

    Posts
    1 Posts
    Global Posts
    3 Global Posts

    Default Re: **FIX** cannot connect sd card to pc

    Yo da man man. Cant thank you enough. You have taught me something new . Dont worry if i help others ill credit you

Posting Permissions