1. piizzadude's Avatar
    Figured I would throw this out here since I am still programmed to look for the Fascinate on any list lol. Looks like tonight Netflix updated things and the Fascinated made the supported device list.

    Here is the article: [Updated] Netflix Quietly Adds Support For 16 New Devices, Including The Thunderbolt, EVO 3D, Droid 2, 3, X2, Charge, Atrix 4G, Bionic (!), And... One Honeycomb Tablet

    Have fun with it!

    This is with 2.2 Froyo as well, no GB needed
    eibbed0001 likes this.
    07-20-2011 02:43 AM
  2. PreceptorJR's Avatar
    I just downloaded it! THANKS!
    07-20-2011 06:56 AM
  3. elroyo's Avatar
    app just force closes on me after trying to login...running comrom 2.1
    07-20-2011 07:09 AM
  4. rjack22's Avatar
    Same with me, force closes.
    07-20-2011 07:42 AM
  5. rjack22's Avatar
    Update: I just called Netflix. The app for the Fascinate is brand new as of this morning. The person I spoke to said that I should wait one day and see if it starts working. He said that it was so new to the Fascinate that they didn't have the "tools" in place yet to help me. He seemed to indicate that they weren't set up yet for the Fascinate even though the app has appeared on the Market this morning. So I will wait a day and then if it still doesn't work I will be calling them again. Just wanted to share what I found out.
    07-20-2011 08:03 AM
  6. cfox10's Avatar
    app just force closes on me after trying to login...running comrom 2.1
    Same here.
    07-20-2011 08:08 AM
  7. fascinatej's Avatar
    same thing on mine , what a let down
    07-20-2011 08:11 AM
  8. piizzadude's Avatar
    yeah check your version. I think I read somewhere that it should be 1.3 for the new devices to be supported but sometimes the market was still putting out 1.22 or something like that
    07-20-2011 08:26 AM
  9. piizzadude's Avatar
    but hey at least you know it will be supported more sooner than later
    07-20-2011 08:28 AM
  10. codeman0624's Avatar
    Wow, even if it doesn't work quite yet, I'm still happy to see the fascinate not be last to get something for once!
    07-20-2011 08:57 AM
  11. wjanowski's Avatar
    yeah check your version. I think I read somewhere that it should be 1.3 for the new devices to be supported but sometimes the market was still putting out 1.22 or something like that
    Yeah, I just downloaded and checked, and I got ver. 1.22.
    07-20-2011 09:50 AM
  12. rjack22's Avatar
    Yeah, I just downloaded and checked, and I got ver. 1.22.
    I hope they get this corrected soon. We have been waiting so long. I too have the earlier 1.22 version as that is the version on the Market.
    07-20-2011 10:47 AM
  13. elroyo's Avatar
    updated finally apperared, signed in fine and now working
    07-20-2011 12:51 PM
  14. rltripp's Avatar
    updated finally apperared, signed in fine and now working
    Same here. I just downloaded the update and it is working fine now.
    07-20-2011 01:17 PM
  15. Downwind's Avatar
    Me too. Works great after the update.
    07-20-2011 01:24 PM
  16. eibbed0001's Avatar
    Works with Cyanogen 7, too.
    07-20-2011 02:31 PM
  17. Ytaay's Avatar
    Works with Cyanogen 7, too.
    Did a quick test on the rooted FASN8 (UKB2.1) and it worked. Starting playing a 21min episode of Archer, pulling over 3G at work no less. Did the FC boogie, though, when I tried to stop the playback.

    Baby steps...
    07-20-2011 03:21 PM
  18. jjcasillas15's Avatar
    Just downloaded it. Running MIUI 1.7.15 and its working great!
    07-21-2011 03:00 AM
  19. STLRampage1's Avatar
    Effective today netflix works for the fascinate!
    07-21-2011 11:05 AM
  20. rjack22's Avatar
    Effective today netflix works for the fascinate!
    It was effective yesterday for me.
    07-21-2011 03:21 PM
LINK TO POST COPIED TO CLIPBOARD