1. geosnipe's Avatar
    Ok, so I heard of people having issues with the data on class2 SD cards being wiped...I actually had it happen to me but was able to fix it WITHOUT reformatting and/or losing data. The phone saw nothing on the SD card, my WIN7 64bit PC didn't either. I simply right clicked the corresponding drive in MY COMPUTER, clicked PROPERTIES, and the clicked the TOOLS TAB. In tools I clicked ERROR CHECKING and selected both CHECK DISK options. The process ran successfully, when it finished I popped the SD card back in the phone and BAM there it was! Fully recognizable and data intact! The next step is optional: remove the SD card and put it back in your computer and do a DISK DEFRAGMNENT on it, when complete put it back in the phone. After this you should notice faster loading and media scanning of the the card and its contents. I hope this helps!
    Brennb#AC likes this.
    08-03-2011 09:24 AM
  2. Ejames42783's Avatar
    I can't wait to try this on my samsung 16gb SD card. I spent the money to get a 8GB card but couldn't swing the money for another 16GB. I'm back to ComRom 2.0 because until the gingerbread leak is fixed I don't want the hassell.
    08-03-2011 04:01 PM
  3. geosnipe's Avatar
    I can't wait to try this on my samsung 16gb SD card. I spent the money to get a 8GB card but couldn't swing the money for another 16GB. I'm back to ComRom 2.0 because until the gingerbread leak is fixed I don't want the hassell.
    How did you fair? Any luck?
    08-04-2011 03:32 PM
  4. sushiguy732's Avatar
    How did you fair? Any luck?
    Didn't work for me... my card is TOAST!
    08-04-2011 06:57 PM
  5. geosnipe's Avatar
    Didn't work for me... my card is TOAST!
    ouch...sorry, it was worth a try. Wonder why it worked for me? Try this if you don't mind; link below:

    https://www.sdcard.org/consumers/formatter_3/
    08-05-2011 08:05 AM
LINK TO POST COPIED TO CLIPBOARD