Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Default /system partition read only now?

    hi,

    guys i am having trouble with my phone all of a sudden.
    I flashed back to stock ED05 and now my /system rfs partition is READ ONLY.
    I found out its only read only, because i couldn't root anymore. I need root for titanium backup so i can restore my apps.

    How do i change it to Readwrite?
    Im trying to remount, but i am having problems




    i went into cmd > adb shell > window opened up i typed mount -o rw,remount -t rfs /dev/block/stl9 (the stl9 is my /system i think from the look of the screenshot if i am wrong plz post)
    and then i tried chmod 777 /system
    it says UNABLE TO chmod /system read-only file system


    SCREENSHOT from adb shell
    http://img535.imageshack.us/img535/1202/android2.jpg



    i tried following this guide
    Write on the Android Read-only file system « PocketMagic


    thx for help in advance

    sorry for links it says u need to have 8 posts before u can link away from forums
  2. Thread Author  Thread Author    #2  

    Default Re: /system partition read only now?

    someone plz help im going insane on this. I have tried odin DL09 and ED05 over and over again but /system stays read-only

    -ADB shell doesnt fix it
    -odin doesnt fix it
    -trying to get root but since /system is read-only i cant get root


    plz someone has to know this
  3. #3  

    Smile Re: /system partition read only now?

    solution



    su

    mount -o rw,remount -t rootfs /system
    or
    mount -o rw,remount -t rootfs rootfs /system


    chmod 0777 /system


Posting Permissions