02-23-2011 11:03 PM
80 1234
tools
  1. icebike's Avatar
    Same problem. Not rooted- stock DL09. Launcher pro.

    Apps:
    Beautiful widgets
    Angry Birds
    Facebook
    Gesture Search
    Flashlight
    Gmail
    Google Goggles
    History Eraser
    Power Control
    Retro Camera
    Tango
    Shootme
    Yelp
    Scanlife
    So far you are the only person claiming to be non rooted that can replicate this.

    Could you try going into Menu/Settings/Applications and remove the "Defaults" Setting for Launcher Pro and see if this persists when using the stock launcher?
    01-22-2011 02:24 PM
  2. phommk's Avatar
    So far you are the only person claiming to be non rooted that can replicate this.

    Could you try going into Menu/Settings/Applications and remove the "Defaults" Setting for Launcher Pro and see if this persists when using the stock launcher?
    the op also is not rooted...but i went back to stock launcher and i was able to access the emergency dialer so im guessing it has something to do with a third party launcher?

    EDIT: I just switched back to launcher pro from touchwiz as my default launcher and now the emergency dialer works
    01-22-2011 03:19 PM
  3. DroidXcon's Avatar
    the op also is not rooted...but i went back to stock launcher and it worked fine so im guessing it has something to do with a third party launcher?
    chris kerrigan is using stock launcher and has this problem
    01-22-2011 03:22 PM
  4. icebike's Avatar
    chris kerrigan is using stock launcher and has this problem
    Chris Kerrigan is rooted. So....
    01-22-2011 03:27 PM
  5. icebike's Avatar
    i went back to stock launcher and i was able to access the emergency dialer so im guessing it has something to do with a third party launcher?

    EDIT: I just switched back to launcher pro from touchwiz as my default launcher and now the emergency dialer works
    So if it fails again, maybe try going into Launcher Pro Settings, and select Restart to see if it corrects the problem?

    I often have to restart launcher pro for the contents of desktop folders do not show the correct icons.
    01-22-2011 03:30 PM
  6. phommk's Avatar
    So if it fails again, maybe try going into Launcher Pro Settings, and select Restart to see if it corrects the problem?

    I often have to restart launcher pro for the contents of desktop folders do not show the correct icons.
    yeah, it was probably because ive never restarted launcher pro since ive installed it on my phone and more specifically after the dl09 update
    01-22-2011 03:36 PM
  7. DroidXcon's Avatar
    Root is just root . Is just moved files nothing to do with anything. Root just gives you permissions

    Sent from my SCH-I500 using Tapatalk
    01-22-2011 03:59 PM
  8. curley's Avatar
    OK, I am rooted Stock DL09 kernal no CWM and have the Go Launcher running. I reloaded TW and checked the emergency dialer, it worked. So I removed TW, back to .OLD, restarted and now the Emergency is working.

    I hope this helps.
    01-22-2011 04:10 PM
  9. DroidXcon's Avatar
    OK, I am rooted Stock DL09 kernal no CWM and have the Go Launcher running. I reloaded TW and checked the emergency dialer, it worked. So I removed TW, back to .OLD, restarted and now the Emergency is working.

    I hope this helps.
    did it ever not work for you curley?
    01-22-2011 04:13 PM
  10. Cory Streater's Avatar
    So far you are the only person claiming to be non rooted that can replicate this.

    Could you try going into Menu/Settings/Applications and remove the "Defaults" Setting for Launcher Pro and see if this persists when using the stock launcher?
    Not anymore.

    3 Fascinates, 1 rooted, 2 not. All 3 are fine. TW on the 2 that aren't rooted.
    01-22-2011 04:37 PM
  11. GrainOsand's Avatar
    I am not rooted and niether is my wife and both our phones had this problem. So root nor launcher has anything to do with it! But I reflashed DI01 thru Odin and problem went away, So I downloaded the OTA again and all seems fine now. My wife doesnt trust me to mess with her phone and she will be getting a new one from vzw on monday. According to vzw warranty rep, it wasnt the first fascinate he replaced for this issue. Take it for what its worth.
    01-22-2011 04:43 PM
  12. Chris Kerrigan's Avatar
    Just an update guys:

    Performed a factory reset, kept everything completely stock, and remained UNROOTED. Still able to produce this bug, and zero response from GalaxySsupport or VZW on Twitter...
    01-22-2011 08:44 PM
  13. Chris Kerrigan's Avatar
    3 cups of coffee later, a total of 5 resets, 2 of which were starting over from DI01, it appears we have a fix for those seeing this issue. Wanna know how simple?

    Simply restart your phone after setting your pattern lock. Now excuse me while I go bash my head off my wall. Can someone who has been having this issue verify that this works?
    01-22-2011 09:52 PM
  14. Cory Streater's Avatar
    3 cups of coffee later, a total of 5 resets, 2 of which were starting over from DI01
    Story of my life.

    Simply restart your phone after setting your pattern lock.
    I never had to do that. Glad you figured it out though

    Now excuse me while I go bash my head off my wall.
    01-22-2011 09:55 PM
  15. Lowrance's Avatar
    3 cups of coffee later, a total of 5 resets, 2 of which were starting over from DI01, it appears we have a fix for those seeing this issue. Wanna know how simple?

    Simply restart your phone after setting your pattern lock. Now excuse me while I go bash my head off my wall. Can someone who has been having this issue verify that this works?
    This fixed mine! Thanks
    Chris Kerrigan likes this.
    01-22-2011 10:04 PM
  16. Chris Kerrigan's Avatar
    This fixed mine! Thanks
    Excellent, thanks! Any one else who sees this working please let us know
    01-22-2011 10:07 PM
  17. afbar1114's Avatar
    apprently this is a known issue with our phone after we got the update Samsung Fascinate Emergency Calling Bug Discovered After Update | PhoneNews.com

    so does this mean we are going to be seeing another update this week and have to reroot again...ugh!!!
    01-22-2011 10:16 PM
  18. Chris Kerrigan's Avatar
    apprently this is a known issue with our phone after we got the update Samsung Fascinate Emergency Calling Bug Discovered After Update | PhoneNews.com

    so does this mean we are going to be seeing another update this week and have to reroot again...ugh!!!
    Check the fix. They also cited us, we were the first to report on this
    01-22-2011 10:18 PM
  19. FearTheGhost13's Avatar
    This is the copy pasted version of a post I commented on the video in regards to the emergency call bug... Hope this helps I can gladly add more information if requested.


    I am using a stock fascinate with DL09 not rooted or de-binged.. Using apps such as lookout mobile security, facebook for android some sports apps, weather app etc.. Nothing too major I dont believe.. And yes when I went to test this bug it happened to me! Cannot use emergency dialer when set to use the unlock pattern. So I believe my phone to be proof that it is effecting random phones for a pretty unknown reason? I've been researching stuff for days in regards to other bugs and the infamous 2.2 update...

    Ok, now I tried one thing that did allow it to work properly.. I restarted my phone, reactivated unlock pattern and tried emergency dialer again.. This time it worked as it should! So honestly its quite confusing as to why its working for some and not for others.. Looks like something internal that will take some research on vzw or samsungs part. Like I said before I am not rooted using the phone completely standard, at first emergency dialer did not work then after restarting my phone it did work.. Could it be possible that the others having this issue may have tried the same without restarting? My only idea is that the phone requires a restart after activating the unlock pattern feature for the emergency dialer will work properly. Please give this method a try and post your findings so we can all further investigate this matter.
    Chris Kerrigan likes this.
    01-22-2011 10:36 PM
  20. afbar1114's Avatar
    i dont even have that dialer i am using asops lock fix to get the sliders which is better well at least to me
    01-22-2011 10:40 PM
  21. cordoni's Avatar
    The fix mentioned above worked for me. Turned off patern lock. Then turned it back on. Rebooted phone and it now emergency calling works. Thank you guys for finding a fix.

    Sent from my SCH-I500 using Tapatalk
    Chris Kerrigan likes this.
    01-22-2011 10:40 PM
  22. FearTheGhost13's Avatar
    Haha, looks as if I didn't read into it far enough before I thought I had found a fix for the issue myself lol... Well at least I was able to figure it out on my own before I got this far into the comments/forums LOL!
    01-22-2011 10:44 PM
  23. Chris Kerrigan's Avatar
    YAY! It's still a bug nonetheless, as you shouldn't have to restart for it to work, but a much less severe bug needless to say. Thanks everyone for the feedback!
    01-22-2011 10:45 PM
  24. cordoni's Avatar
    Thank you Chris for finding the fix!

    Sent from my SCH-I500 using Tapatalk
    01-22-2011 10:51 PM
  25. Chris Kerrigan's Avatar
    Thank you Chris for finding the fix!

    Sent from my SCH-I500 using Tapatalk
    I can't take full credit here. We had a tweet come our way, I am just the tester and messenger.
    01-22-2011 10:55 PM
80 1234
LINK TO POST COPIED TO CLIPBOARD