Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Angry Rooted phone won't charge, turn on, etc. Help!

    I am running latest Axiom

    Mine worked fine until I went to bed. Turned it off to charge as normal and stuck on charger(didn't pay attention to see if it lit up). Woke up and it is dead. Tried to hold down volume buttons + power, tried taking out battery & sim card then holding down power for 10 seconds, and tried another battery that's fully charged(I have the extra battery & external charger). Zilch, a completely dead phone.

    I have had zero problems in the 3 weeks I've owned it and been using Axiom. I haven't downloaded a new app in at least a week maybe longer. The computer won't recognize it at all so I can't unroot or do anything to the phone. It doesn't give me the yellow triangle or any option to install drivers. Please help!!
  2. #2  

    Default Re: Rooted phone won't charge, turn on, etc. Help!

    had a similar problem last night. phone just turned off. tried the volume + power, charging it, pulling battery. finally i tried putting in the standard battery(i was using the extended) and it came on fine. Switched back to the extended and that worked also. No idea what happened.
    wkupike2000 likes this.
  3. Thread Author  Thread Author    #3  

    Default Re: Rooted phone won't charge, turn on, etc. Help!

    Yeah not a battery issue, tried 2 different ones I own and one new at Verizon. I finally just took it in and they are shipping a new one overnight. The techs there and the ones they called had no idea. They said it had to be a hardware issue because even if the software got borked, the phone would still charge and attempt to turn on
  4. #4  
    mclarryjr's Avatar
    Retired Moderator

    5,908 Posts
    Global Posts
    6,536 Global Posts
    NOS M7 Sense 5.0

    Default Re: Rooted phone won't charge, turn on, etc. Help!

    It does sound like a hardware issue, hope you have better luck on the replacement
    wkupike2000 likes this.

Posting Permissions