1. booyackasha's Avatar
    When flashing this rom I get two sdcard folders. The usual /sdcard and /storage/sdcard0. I still have everything in the sdcard folder but its home root folder is the storage/sdcard0. Did I do something wrong? Has this happened to anyone else? Sorry for the confusing explanation, I tried explaining it as best as I could. Btw I installed the vicious rom of jelly bean.
    06-30-2012 12:38 PM
  2. 2defmouze's Avatar
    Seen it mentioned....... Before you screw with these ROMs backup everything from your sd you may need, and get an idea of how to fastboot factory images because I have a feeling we're all going to need to at some point or another, lol. For now don't stress that, if its working alright just backup your stuff and be cautious.
    dmmarck likes this.
    06-30-2012 12:51 PM
  3. oxymoron's Avatar
    It doesn't matter. It's technically the same directory. I don't know why JB creates this, but it's inconsequential. Both /sdcard and /storage/sdcard0 are the same. If it bothers you, just set your home directory to /sdcard.




    Jellybeanin' on tapatalk
    dmmarck and booyackasha like this.
    06-30-2012 12:55 PM
  4. booyackasha's Avatar
    Well what's interesting is that the gallery doesn't recognize any of my pictures and when I connect it to my laptop I can see the phone but no folders show up... :/ I know this sdcard0 is causing the problems or at least I think so.. any suggestions or solutions?
    07-01-2012 11:30 PM
  5. dmmarck's Avatar
    Well what's interesting is that the gallery doesn't recognize any of my pictures and when I connect it to my laptop I can see the phone but no folders show up... :/ I know this sdcard0 is causing the problems or at least I think so.. any suggestions or solutions?
    I don't think it's that. It's an exact mirror.

    Is USB debugging checked?

    Are the folders still there?
    07-01-2012 11:41 PM
  6. booyackasha's Avatar
    The files and folders are still there and USB debugging is unchecked. Would having it checked make a difference?
    07-02-2012 06:29 AM
  7. oxymoron's Avatar
    Do you have USB fast charge enabled in your kernel by chance? That would cause it. It won't mount your sdcard if so.

    *clever signature*
    07-02-2012 07:07 AM
  8. booyackasha's Avatar
    I don't have usb fast charge enabled. Do you think this could be a bug they haven't sorted out yet?
    07-02-2012 07:56 AM
  9. dmmarck's Avatar
    I don't have usb fast charge enabled. Do you think this could be a bug they haven't sorted out yet?
    Which port are you on?

    Sent from my Galaxy Nexus using Xparent Cyan Tapatalk 2
    07-02-2012 08:43 AM
  10. booyackasha's Avatar
    Which port are you on?

    Sent from my Galaxy Nexus using Xparent Cyan Tapatalk 2
    As in from? If that's what you meant I flashed vicious the latest version. Then tried the stock and still got the same result
    07-02-2012 09:25 AM
  11. dmmarck's Avatar
    As in from? If that's what you meant I flashed vicious the latest version. Then tried the stock and still got the same result
    I have no idea then, to be honest. I've been on all sorts of ports, and while at first the presence of the sdcard0 was disconcerting, it has not affected my ability to access a thing.

    Hmmm....try Jelly Belly?
    07-02-2012 09:27 AM
  12. booyackasha's Avatar
    That is what I'm trying and seem to get that problem only when I flash Jelly Bean. I never had any problem flashing any of the AOKP builds before
    07-02-2012 09:36 AM
  13. dmmarck's Avatar
    That is what I'm trying and seem to get that problem only when I flash Jelly Bean. I never had any problem flashing any of the AOKP builds before
    I meant the specific port of Jelly Bean called Jelly Belly.
    07-02-2012 09:42 AM
  14. booyackasha's Avatar
    Hahaha I'm confused at by what your hinting at :P
    07-02-2012 10:12 AM
  15. dmmarck's Avatar
    Hahaha I'm confused at by what your hinting at :P
    lol...go to my guide, scroll down, I believe it's port #3. Go to that thread on RW. Install it.

    It has no peers at the moment.
    booyackasha likes this.
    07-02-2012 10:19 AM
  16. booyackasha's Avatar
    Alright thanks! I'll give it a try and see if I still get the same problem!
    07-02-2012 10:49 AM
  17. oxymoron's Avatar
    Fwiw, I'm on Jelly Belly 1.6 and the mirrored directory is still there.

    I'm able to access all files via Root explorer or USB... so I don't know what's happening with yours?

    *clever signature*
    07-02-2012 11:02 AM
  18. Nedra144's Avatar
    This is normal. Same thing on my totally stock nexus 7.
    11-17-2012 11:47 AM
  19. JkdJedi's Avatar
    Found this in the wild, if we're all talking 4.2 then....

    "To support multi-user capabilities this will be the norm... for each user, there will be a sequentially numbered folder in /data/media (/data/media/0, /data/media/1)...

    And for each user, within Android, this will be symlinked to /sdcard & /storage/sdcard0... for user 1, /sdcard = /storage/sdcard0 = /data/media/0... for user 2, /sdcard = /storage/sdcard0 = /data/media/1...

    These are emulated storage points... /data/media/0 = /storage/emulated/0, /data/media/1 = /storage/emulated/1

    Without root access, each user will just see /sdcard/ and will not be able to access the other emulated storage points...

    In the recovery mode, however, /sdcard is mapped to /data/media which is why you need to navigate to the "0" folder to see your files"!
    11-17-2012 12:14 PM
  20. TheBish0p's Avatar
    I also have an exact mirror of the contents of my internal storage. I got it after installing stock Android 4.2 on my Galaxy Nexus. Everything is appearing twice in the Gallery app, et cetera.

    It's pretty darn annoying. How can I get rid of it and how could Google mess this up so badly?
    11-17-2012 03:41 PM
  21. dmmarck's Avatar
    I also have an exact mirror of the contents of my internal storage. I got it after installing stock Android 4.2 on my Galaxy Nexus. Everything is appearing twice in the Gallery app, et cetera.

    It's pretty darn annoying. How can I get rid of it and how could Google mess this up so badly?
    (1) It shouldn't show up twice, that's very odd.

    (2) It's just how Jelly Bean saves now, I'm sure there's a decent explanation for it somewhere lol
    11-19-2012 05:48 AM
  22. colchambers's Avatar
    I've just had the same problem. I used /mnt/extSdCard instead. The camelcase is important. Frustrating but it's how they're rolling these days.
    12-11-2012 09:27 AM
  23. Canuckfan's Avatar
    It doesn't matter. It's technically the same directory. I don't know why JB creates this, but it's inconsequential. Both /sdcard and /storage/sdcard0 are the same. If it bothers you, just set your home directory to /sdcard.
    So do the mirrored folders actually take up more space? Or does one folder just "link" to another?
    12-11-2012 11:13 PM
  24. diretoree's Avatar
    Hi. I am only "user", but have this problem. When I linked File Manager to /sdcard directory or /mnt and move/copy some files like pictures, than I don't see them in Gallery. If the directories are linked same, should to be seen same data.
    02-01-2013 09:20 AM
LINK TO POST COPIED TO CLIPBOARD