09-09-2014 09:56 AM
910 ... 3233343536 ...
tools
  1. Zcortlandt's Avatar
    OK i was wrong everything works except regular cam with Flash if you don't use flash it works fine... but how do I live with out flash! ALL MY PHOTOS ARE IN THE DARK

    no really there not but i do want flash any fix for that or is this as good as it gets? im happy it works enough I can use my other cam for flash photos BTW so u know what i did to get this far

    I deleted all old lib and system files, then I installed apps then after installed wipe cache dalibk then after that I went ahead reboot and fixed permsions then before tried anything i reboot then I used it

    Everything good but the dam flash
    01-19-2013 01:19 AM
  2. Ikki Wang's Avatar
    God like it!
    01-20-2013 09:36 AM
  3. Windfrenzy's Avatar
    I have a Verizon (Toro) Gnex. I got the gallery has stopped issue when I first flashed the zip, but got it to work by doing the following. Thanks to SpecR for the detailed post and all here.
    1) uninstalled CameraFX (not sure if this contributed, but it seemed prudent)
    2) Set up ES File Explorer for /system access and modification (go to settings, Root settings and check everything)
    3) Used ES File Explorer to change extensions to GalleryGoogle apk and odex to bak and obak (in /system/app)
    4) Used ES File Explorer to change extension to GmsCore odex to bak (/system/app)
    5) Used ES File Explorer to put all the files in the OP in their proper places and change file permissions to rw-r-r
    6) Reboot in TWRP recovery
    7) Wipe cache and dalvik cache
    8) Reboot

    Anyone have a way to add HDR capability to this camera? I'd like to try that, but it sounded like adding that lib didn't work for folks.
    dhworph likes this.
    01-20-2013 09:39 AM
  4. texaslittleangel's Avatar
    One more to the list of error "Unfortunately, Gallery has stopped."

    I've got a Nexus 4 running 4.2.1 rooted only.

    I noticed the problem when I accidentally uninstalled Gallery with TBP whilst uninstalling Google Books and a couple of other crap apps.

    Followed instructions of installing the 4.2Camera zip as well as the toolkit zip via recovery with no avail.
    Deleted the apps, added them. No luck
    Copy pasted the lib (.so) files and changed permissions (replaced existing). No luck
    Rebooted a million times. Did a data, cache and dalvic cleanup and No luck
    Fixed permissions via ROM Manager, No luck

    I had installed instragram and then deleted it. I also installed Quickpic (doubt any of these have anything to do with the problem though).
    01-22-2013 12:03 PM
  5. texaslittleangel's Avatar
    SOLUTION!!!!!!!!!!!!!!!

    Update your gapps!!!!! That will do the trick!!! I Downloaded this version which seems to be the latest and voila! Camera is working
    Wadman82 likes this.
    01-22-2013 12:38 PM
  6. Josef Ferguson's Avatar
    OK, so apparently I got myself in over my head. I'm pretty sure I followed the directions to the letter. Copied GalleryGoogle.apk and GMSCore.apk to the system>apps folder, changed permissions to RW-R-R (did NOT install). Copied libjni_filtershow_filters.so and libjni_mosaic.so and liblightcycle.so to the system>lib folder (is that right? not sure), changed permissions to RW-R-R, rebooted a couple times.
    But whenever I try to open the camera or the gallery, I get the "Unfortunately, Gallery has stopped working" error. What did I miss? (Keep in mind that, like I said earlier, I'm in way over my head here. Explain it to me as if you were explaining it to your grandfather or a particularly stupid cousin.)
    Thanks for any help.
    01-23-2013 09:49 AM
  7. Windfrenzy's Avatar
    Back a page is how I got it to work. Looks like the only things I did different are the steps with the odex files and wipe cache and dalvik before reboot. http://forums.androidcentral.com/sho....php?p=2533545

    Sent from my Galaxy Nexus using Android Central Forums
    01-23-2013 04:51 PM
  8. texaslittleangel's Avatar
    i got my camera to work as posted above BUT when i tried using the photosphere yesterday I get the following message "Sorry, your device is not yet supoorted. Model: unknown (LGE)."

    I went into the build.prop and noticed that the ro.product.model and the ro.product.brand files are missing. I am assuming this could be the issue.


    EDIT: Added the two ro's missing and I now have a fully functional camera!
    01-27-2013 12:25 PM
  9. Twain Russell's Avatar
    can u help me i have a saphire black i9300 and the camera doesnt work
    01-27-2013 10:10 PM
  10. chonpan's Avatar
    Well I am totaly lost in space!!!
    Is there any guide to install 4.2 camera on rotted 4.1.2 odex ROM?
    My device Galaxy SIII Mini
    Thanks in advance
    PC. Flashing zip in first post , fixing permissions gives me a black screen and no respond from phone. I have to take the battery off to restart
    01-29-2013 05:07 AM
  11. Corey Downs's Avatar
    Using Verizon Samsung Galaxy Note II - Photosphere does not work, says device is not supported.

    ~Corey
    01-29-2013 02:15 PM
  12. Zulhelmi Effendi Zulkifli's Avatar
    hello everybody,
    android jelly bean 4.2 camera working awesomely, but somehow the video recording doesn't work.
    it is kind of bug? or did i do something wrong? any solution would be helpful..
    thanks..

    Samsung GSII [GT-i9100]
    Resurrection Remix 3.1.2
    Jelly Bean 4.1.2
    01-29-2013 11:35 PM
  13. pmcd1962's Avatar
    hello everybody,
    android jelly bean 4.2 camera working awesomely, but somehow the video recording doesn't work.
    it is kind of bug? or did i do something wrong? any solution would be helpful..
    thanks..

    Samsung GSII [GT-i9100]
    Resurrection Remix 3.1.2
    Jelly Bean 4.1.2
    Just used mine with no problems. What is yours doing or not doing? Any error message?

    Sent from my Galaxy Nexus using Android Central Forums
    01-30-2013 05:42 AM
  14. Predrag Mishak's Avatar
    Wher u find that 2 missing ro's?
    01-31-2013 12:57 PM
  15. Wim van Oosterhout's Avatar
    Because I place te apk directly into the app-folder, now there isn't even a camera-logo to push....
    02-06-2013 10:00 AM
  16. xoxidine's Avatar
    I tried this with Root Explorer first, but it didn't work. I tried it again with the ES File Explorer and did everything listed http://forums.androidcentral.com/sho....php?p=2533545. I assume
    "change extensions to GalleryGoogle apk and odex to bak and obak" means just rename it to GalleryGoogle.bak. Also, how do I "Wipe cache and dalvik cache"?

    Update: I thought I had CW Recovery installed, but I didn't. Installed it and now I've wiped my cache and dalvik cache, but the camera and gallery don't show up at all in my app list. Now what?
    02-06-2013 03:22 PM
  17. Ray S3's Avatar
    New to android new to the forum.. Regards from Beirut/Lebanon.
    The Dev-Host - 4.2Camera_t04.zip Is perfectly functioning on Samsung Galaxy S3 international version on UK's Jellybean 4.1.2.
    All I did was: Copy the .zip to my phones internal storage.- Flashed in recovery mode. Note: I didn't backup nor wiped cache and dalvik(I guess its called dalvik maybe marvil,mavrick maybe).
    Just flash the .zip. I kept both cameras and both galleries and both are functioning perfectly. Thx to all who made that possible.
    02-13-2013 03:57 PM
  18. 13jpgbass's Avatar
    Anyone else having a problem with the camera image lagging? I have a samsung phone with 4.0.4 and Touchwiz.
    02-14-2013 08:03 PM
  19. dhworph's Avatar
    I got it working by following windfrenzy's instructions.

    However, the photosphere doesn't render the whole panorama. So far I've done two and both have a vertical strip of gray, one larger than the other... so it is not processing all the images. I made sure and was careful to check that I didn't miss any "little blue circles" and that I was shooting the entire panorama. camera and video recording work. Haven't tried regular panorama.
    02-14-2013 08:31 PM
  20. xoxidine's Avatar
    I subscribed to this thread because I was unable to get it to work, and still am. I have since put the AOKP rom on with this camera and it works fine.
    02-14-2013 08:42 PM
  21. Joe113's Avatar
    Ok... so I'm running PACman v19.9 (idk if that matters) but when I copy/pasted the APK to my system/app the camera took 1 pic then froze up on that pic. I probably installed it wrong. Can someone please walk me through the steps? It'd be much appreciated.

    FYI- I only downloaded the GalleryGoogle.apk but yes I did set permissions correct and rebooted. Are there files that I am missing or something?

    Like I said, much appreciated to anyone that can help.

    EDIT: SCRATCH THAT... got it to work!
    02-14-2013 09:13 PM
  22. dhworph's Avatar
    update: ok, photosphere is now working normally it seems. I odexed the apks, and I don't know if that helped or not... but it rendered the complete panorama last go...

    pretty cool!
    02-14-2013 10:40 PM
  23. arczangel's Avatar
    Courtesy of yours truly.

    Move to system/app folder in Root Explorer. Make sure the permissions are set to RW-R-R. Reboot.

    Let me know if anything doesn't work, it works fine for me (see pics below).

    Oh, and don't try to install it. A reboot with the proper permissions set will populate it . If you want, remove the other camera/gallery, which for most is Gallery2.apk.

    Here's a link to the latest flashable zip, courtesy of mariusox! ==> Jelly Bean 4.2 Camera
    Thanks a ton OP, working very well with my ICS 4.04

    One Question guys, It is safe to edit build.prop? I read some encounter bootloops after editing it, wanna know how to avoid such and wanna know if i can edit it in the ES file explorer? Thanks!
    02-15-2013 02:54 AM
  24. Ray S3's Avatar
    I am not sure if my "discovery" is of any relevance, but just in case.
    All amateurs like myself that are having trouble with Tiny Planet- Make sure your photo sphere is a complete 360 degree of the scenery+ sky + ground all in one shot (3 to 4 360 spins to get it done, but its worth it) . If its not a complete (sky,scenery,ground) 360 shot; the tiny planet option will always crash on my Samsung S3 int.
    Regards

    Here's a shot of the tiny planet I came up with- edited a bit due to some minor distortions.
    Attached Thumbnails Jelly Bean 4.2 Camera-1360938190836_0.jpg  
    02-15-2013 07:49 AM
  25. dhworph's Avatar
    I am not sure if my "discovery" is of any relevance, but just in case.
    All amateurs like myself that are having trouble with Tiny Planet- Make sure your photo sphere is a complete 360 degree of the scenery+ sky + ground all in one shot (3 to 4 360 spins to get it done, but its worth it) . If its not a complete (sky,scenery,ground) 360 shot; the tiny planet option will always crash on my Samsung S3 int.
    Regards

    Here's a shot of the tiny planet I came up with- edited a bit due to some minor distortions.
    awesome! How'd you get the black circle in the center to not be there, or add the corners? Did you just edit it yourself, like in gimp or photoshop?

    Edit: nevermind... for some reason it didn't work on my first coupld of pano's, but it is working now. You just click to "add a frame" and that will fill out the corners and center! very cool... cant wait to get some nature shots!

    This camera is killing my work impetus!

    Edit: ok, just had one pano photo not show up in my gfallery, it showed the rendering notification, and I found it in the correct place with a file explorer. weird... app definitely a bit buggy, but works well. I find that you get a good tiny planet if you shoot from lower to the ground,
    02-15-2013 10:23 AM
910 ... 3233343536 ...

Similar Threads

  1. HELP! Not able to open camera album after Jelly Bean update!
    By liana ramlee in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 22
    Last Post: 06-24-2015, 11:09 AM
  2. Verizon Galaxy Nexus camera not working after flashing Jelly Bean
    By egarcia85 in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 14
    Last Post: 09-06-2012, 12:09 AM
  3. Jelly Bean Camera Tricks
    By Sooks in forum Verizon Galaxy Nexus
    Replies: 1
    Last Post: 07-02-2012, 10:57 AM
  4. Next version after Ice Cream Sandwich to be called Jelly Bean!!!
    By skitzer9 in forum General News & Discussion
    Replies: 3
    Last Post: 09-09-2011, 08:00 PM
  5. Version after Ice Scream Sandwich to be called Jelly Bean!!!
    By skitzer9 in forum General News & Discussion
    Replies: 0
    Last Post: 09-09-2011, 06:07 PM
LINK TO POST COPIED TO CLIPBOARD