Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 35 of 37 FirstFirst ... 323334353637 LastLast
Results 851 to 875 of 910
Like Tree219Likes
  1. #851  

    Default Re: Jelly Bean 4.2 Camera

    dhworph, If you take a regular pano using "photo sphere" feature you will always get the black circle in the center of the planet and the corners- on my device (S3) I couldn't apply tiny planet that way the app always crashed the gallery.
    Try taking a whole sphere "pano" .start with the scenery when you finish a whole 360 degree of dots and turns, while still in photo sphere direct your phone to the sky and do a 360 of the sky too. then do the same to the ground then you may press the stop button for a full photo sphere not a pano. that way the app won't crash on tiny planet nor will the black corners or center circle appear.
  2. #852  

    Default Re: Jelly Bean 4.2 Camera

    Ray, I got it working... I made sure I got all the "blue dots" each time, but it was just buggy at first. You can take the black circle out of the tiny planet by applying a "frame" in the edit menu. It took a couple tries for me to get it working, but it works now.

    However, the gallery stores the photos out of order... weird... hope thats fixed when the official release comes out... not a big deal though.
  3. #853  

    Default Re: Jelly Bean 4.2 Camera

    Hi guys,

    I'm having problems getting the photo sphere to work. Running the camera app from a Samsung Note 2 stock rom. Pushed all the files to the appropriate location as per the instructions in the earlier posts.
    Got the camera, video, gallery and panorama to work but the photo sphere still shows that "your device is unsupported"
    Any ideas?
  4. #854  

    Default Re: Jelly Bean 4.2 Camera

    Dhworph,, not sure about the lag or the bugs, but for my device (S3) It was lagging and crashed when I tried the flash in photos, all I did was updated all google related apps on my phone and everything ran smoothly ever since.

    Luminscence69,, check around page 18-23 i guess, there's a fix for that where you change something concerning the phones name in some system file.
  5. #855  
    Joe113's Avatar

    Posts
    853 Posts
    Global Posts
    905 Global Posts
    ROM
    R.D.D.T ND2 v1

    Default Re: Jelly Bean 4.2 Camera

    I can't seem to get this to work. I place the zip on my ext SD card, then I flash it, but when I take a picture the camera freezes on the picture I just took and doesn't work after that one picture... GoogleCamera.apk and the gallery already have permissions set to rw-r-r and are already in system/app. What am I doing wrong? Any help is appreciated!
  6. #856  

    Default Re: Jelly Bean 4.2 Camera

    Joe. for my S3 int. version running 4.1.2 all I did was:
    -Download the t04.zip
    -Although all say its better to clear cache and dalvik in recovery mode, I have no idea why I didn't.
    -Flashed the t04.zip in recovery without even renaming the old camera or gallery.
    -at first everything was lagging (the whole phone). and the new camera used to crash when i used flash in photo's and tiny planet.
    -I updated all google related apps.
    -At this point I thought of renaming the old gallery and old camera (On my S3 the old gallery name is secgallery.apk)
    -everything ran smooth without any crashes since.
    -I renamed the old gallery and camera back to their original names. and have both camera's and galleries now working correctly.
    I think I was a bit lucky on making it work...
  7. #857  

    Default Re: Jelly Bean 4.2 Camera

    Hey, my name is laTrell and I have the T-Mobile LG G2X when I open the camera, I get a blank white screen. It will capture a picture, but nothing shows.
  8. #858  

    Default Re: Jelly Bean 4.2 Camera

    Thanks guys!
    Will try on my GFs SGS3
  9. #859  

    Default Re: Jelly Bean 4.2 Camera

    I just discovered that if you do a photosphere in potrait mode the black cirles end up MUCH tinier, and that makes the tiny planet look way better too.

    1. Camera still buggy for me... sometimes leaving a vertical strip of gray unrendered, about 1 out of every 3 or 4 photospheres do that.
    2. photos in gallery out of order
    3. sometimes editing a tiny planet doesn't let me "change the scale" slider, where it sort of zooms in and out to choose the tiny planet level.

    I am soooo stoked on this camera though... loving the tiny planets...

    all my google apps are up to date (all apps on my phone are), plus I just did a recent factory reset and started from scratch. I also odexed the gmscore and gallerygoogle apk's (but all the issues listed above persisted form before I odexed). Camera is a bit snappier maybe, after odexing.
  10. #860  

    Default Re: Jelly Bean 4.2 Camera

    LOL
  11. #861  
    Joe113's Avatar

    Posts
    853 Posts
    Global Posts
    905 Global Posts
    ROM
    R.D.D.T ND2 v1

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by Ray S3 View Post
    Joe. for my S3 int. version running 4.1.2 all I did was:
    -Download the t04.zip
    -Although all say its better to clear cache and dalvik in recovery mode, I have no idea why I didn't.
    -Flashed the t04.zip in recovery without even renaming the old camera or gallery.
    -at first everything was lagging (the whole phone). and the new camera used to crash when i used flash in photo's and tiny planet.
    -I updated all google related apps.
    -At this point I thought of renaming the old gallery and old camera (On my S3 the old gallery name is secgallery.apk)
    -everything ran smooth without any crashes since.
    -I renamed the old gallery and camera back to their original names. and have both camera's and galleries now working correctly.
    I think I was a bit lucky on making it work...
    That's what I originally did and that doesn't work I get the problems I posted (post #855)
  12. #862  

    Default Re: Jelly Bean 4.2 Camera

    Did you try the lib files a couple of pages back? download them, using root explorer move them to their respective locations and change their permissions as mentioned in the post. hope that helps.
  13. #863  

    Default Re: Jelly Bean 4.2 Camera

    Please Help , newbie here. I flashed the zip file. Everything went well. But when i did the photosphere thing, the blue dot seemed to move slightly downwards, causing the pic produced look like rubbish. Any ideas?
  14. #864  
    Joe113's Avatar

    Posts
    853 Posts
    Global Posts
    905 Global Posts
    ROM
    R.D.D.T ND2 v1

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by Ray S3 View Post
    Did you try the lib files a couple of pages back? download them, using root explorer move them to their respective locations and change their permissions as mentioned in the post. hope that helps.
    Just searched back to page 27 and couldn't find any "LIB files". What am I supposed to do with them?
  15. #865  

    Default Re: Jelly Bean 4.2 Camera

    Joe, try Post #3 first page..
  16. #866  
    Joe113's Avatar

    Posts
    853 Posts
    Global Posts
    905 Global Posts
    ROM
    R.D.D.T ND2 v1

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by Ray S3 View Post
    Joe, try Post #3 first page..
    So I flashed the zip, and then DLed the 3 files in post #3 and moved them to their designated placed. Still force closes and doesn't work. Was I supposed to flash those files or just DL them and move them? Thanks. I really want this to work lol.
  17. #867  

    Default Re: Jelly Bean 4.2 Camera

    I was just playing around with installing leankernel and the camera stopped working. Restoring a Nandroid did not bring it back either... weird. my gallery and camera are no longer recognized as installed. The icons for camera and gallery were still on my homescreen, but absent from the app drawer. I'm stock rooted 4.1.1 otherwise. I also has a program called picsart installed, which seemed to take over the lockscreen camera slide-to-unlock spot, so maybe there was some conflict there - however deleting that app and wiping cache/dalvik didn't fix it.

    Will try to go back to stock camera/gallery and report how it goes.

    Edit: deleted GalleryGoogle.apk, GmsCore.apk (and their odex files --- I odexed the 4.2 camera), and deleted the extra lib files, and the camera and gallery appeared in my drawer unlabel at the top. They opened and seemed to work, so I rebooted and wiped cache and dalvik, then they were gone again... weird... luckily titanium was able to restore them. I am going to try and get the 4.2 cameras back up and running.

    Edit: redid the process for installing the 4.2 camera, and changing the permissions on the apk's and lib files... wiped cache/dalvik and no go. the icons are on my homescreen, but the apps dont appear in the drawer. Fear I may have to do a factory reset or flash factory image... really weird... Anyone have a clue why it wont take now? Why wouldn't a nandroid be able to restore it?!?!?! Why couldn't my stock camera be restored from a nandroid?!!?!? this is most puzzling!
  18. #868  
    Joe113's Avatar

    Posts
    853 Posts
    Global Posts
    905 Global Posts
    ROM
    R.D.D.T ND2 v1

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by dhworph View Post
    I was just playing around with installing leankernel and the camera stopped working. Restoring a Nandroid did not bring it back either... weird. my gallery and camera are no longer recognized as installed. The icons for camera and gallery were still on my homescreen, but absent from the app drawer. I'm stock rooted 4.1.1 otherwise. I also has a program called picsart installed, which seemed to take over the lockscreen camera slide-to-unlock spot, so maybe there was some conflict there - however deleting that app and wiping cache/dalvik didn't fix it.

    Will try to go back to stock camera/gallery and report how it goes.

    Edit: deleted GalleryGoogle.apk, GmsCore.apk (and their odex files --- I odexed the 4.2 camera), and deleted the extra lib files, and the camera and gallery appeared in my drawer unlabel at the top. They opened and seemed to work, so I rebooted and wiped cache and dalvik, then they were gone again... weird... luckily titanium was able to restore them. I am going to try and get the 4.2 cameras back up and running.
    If you get it stable and working pleaseeeee give me step-by-step on what you did lol.
  19. #869  

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by Joe113 View Post
    If you get it stable and working pleaseeeee give me step-by-step on what you did lol.
    I had it stable and working, by following the instructions above: put apps in system/app, and libs in system/lib, wipe cache and dalvik, reboot. photosphere and all was good for about a week. Going to try and flash the 4.2 camera zip now

    Edit: no luck with flashing the zip... it flashed, but still same problem...

    Edit: ok... I did a factory data reset through stock settings menu, let it do its thing, signed back in to google after the phone booted up, and the 4.2 camera was there and working. All my apps are restoring... something was just funky in the user/system data I guess... will update if it breaks again or if it continues to work... gonna make a nandroid now!
  20. #870  
    Joe113's Avatar

    Posts
    853 Posts
    Global Posts
    905 Global Posts
    ROM
    R.D.D.T ND2 v1

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by dhworph View Post
    I had it stable and working, by following the instructions above: put apps in system/app, and libs in system/lib, wipe cache and dalvik, reboot. photosphere and all was good for about a week. Going to try and flash the 4.2 camera zip now

    Edit: no luck with flashing the zip... it flashed, but still same problem...
    I did the same, but it would freeze up after I took a picture UNLESS I pressed the focus button... and it woudn't work until I rebooted.
  21. #871  

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by Joe113 View Post
    I did the same, but it would freeze up after I took a picture UNLESS I pressed the focus button... and it woudn't work until I rebooted.
    It's not the funnest thing to do, but try what I did... backing up all your important stuff from sdcard and apps with titanium, etc... and doing a factory reset through stock settings menu after flashing the 4.2 camera zip. It fixed my problem. A stock factory reset seems to keep root and all your system apps... at least it did for me, and this is my second reset in the past couple of weeks.
  22. #872  
    Joe113's Avatar

    Posts
    853 Posts
    Global Posts
    905 Global Posts
    ROM
    R.D.D.T ND2 v1

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by dhworph View Post
    It's not the funnest thing to do, but try what I did... backing up all your important stuff from sdcard and apps with titanium, etc... and doing a factory reset through stock settings menu after flashing the 4.2 camera zip. It fixed my problem. A stock factory reset seems to keep root and all your system apps... at least it did for me, and this is my second reset in the past couple of weeks.
    Wouldn't a factory reset delete the camera though cause it would go back to factory settings which is the default camera lol...
  23. #873  

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by Joe113 View Post
    Wouldn't a factory reset delete the camera though cause it would go back to factory settings which is the default camera lol...
    Factory reset from the stock android OS settings menu does not seem to delete system apps. At least it doesn't for me. I've done at least 2 factory resets from there and both times it kept all my system apps, nova launcher, root/superuser, and now the 4.2 camera. Although, maybe some expert advice would be inline here.

    Also, I just re-odexed the 4.2 camera apk's and found that the GalleryGoogle.apk was not zipaligned. That might be a source of problems. Or maybe it was an error on my part... but I zipaligned it, and I have the zipaligned, odexed version up and running. I have attached the zipaligned deodexed verison of GalleryGoogle.apk here. Maybe using that will fix some of the problems people are experiencing. I don't know if other people can use my odexed version though... I don't know if that is phone-specific.

    attached: zipaligned GalleryGoogle.apk
    md5sum: AF86E6403CCCF3E97F882AD4122F751E

    Edit: Well, I checked the 4.2Camera_t04.zip file and GalleryGoogle.apk was zipaligned in there, but some other files weren't, including libjni_mosaic.so, so I have included the entire zipalined zip here too... hope that helps someone. *** Flash at your own risk, as I am a noob compared to the people who originally made this zip. Backup, backup, backup, and know how to restore backups!!!

    attached: 4.2Camera_t04-zipaligned.zip
    md5sum: 76AC5CDBAC51D99EE379FAA392BF3F73
    Attached Files Attached Files
  24. #874  
    Joe113's Avatar

    Posts
    853 Posts
    Global Posts
    905 Global Posts
    ROM
    R.D.D.T ND2 v1

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by dhworph View Post
    Factory reset from the stock android OS settings menu does not seem to delete system apps. At least it doesn't for me. I've done at least 2 factory resets from there and both times it kept all my system apps, nova launcher, root/superuser, and now the 4.2 camera. Although, maybe some expert advice would be inline here.

    Also, I just re-odexed the 4.2 camera apk's and found that the GalleryGoogle.apk was not zipaligned. That might be a source of problems. Or maybe it was an error on my part... but I zipaligned it, and I have the zipaligned, odexed version up and running. I have attached the zipaligned deodexed verison of GalleryGoogle.apk here. Maybe using that will fix some of the problems people are experiencing. I don't know if other people can use my odexed version though... I don't know if that is phone-specific.

    attached: zipaligned GalleryGoogle.apk
    md5sum: AF86E6403CCCF3E97F882AD4122F751E

    Edit: Well, I checked the 4.2Camera_t04.zip file and GalleryGoogle.apk was zipaligned in there, but some other files weren't, including libjni_mosaic.so, so I have included the entire zipalined zip here too... hope that helps someone. *** Flash at your own risk, as I am a noob compared to the people who originally made this zip. Backup, backup, backup, and know how to restore backups!!!

    attached: 4.2Camera_t04-zipaligned.zip
    md5sum: 76AC5CDBAC51D99EE379FAA392BF3F73
    Ok so I downloaded both files.... now what should I do? Flash the zip and move GalleryGoogle.apk to system/app and set permissions and then I am done? Or am I missing something? Thnanks!
  25. #875  

    Default Re: Jelly Bean 4.2 Camera

    Quote Originally Posted by Joe113 View Post
    Ok so I downloaded both files.... now what should I do? Flash the zip and move GalleryGoogle.apk to system/app and set permissions and then I am done? Or am I missing something? Thnanks!
    If you flash the zip, then you don't need to do anything, as that will move the apks and libs to the proper place and set their permissions. ALso, it will overwrite your stock camera, so be sure to backup it up and/or do a nandroid. I definitely recommend backing up with a nandroid before flashing the zip or doing anything with system files!
Page 35 of 37 FirstFirst ... 323334353637 LastLast

Similar Threads

  1. HELP! Not able to open camera album after Jelly Bean update!
    By liana ramlee in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 21
    Last Post: 05-14-2013, 01:27 AM
  2. Verizon Galaxy Nexus camera not working after flashing Jelly Bean
    By egarcia85 in forum Verizon Galaxy Nexus Rooting, ROMs, and Hacks
    Replies: 14
    Last Post: 09-06-2012, 01:09 AM
  3. Jelly Bean Camera Tricks
    By Sooks in forum Verizon Galaxy Nexus
    Replies: 1
    Last Post: 07-02-2012, 11:57 AM
  4. Next version after Ice Cream Sandwich to be called Jelly Bean!!!
    By skitzer9 in forum General News & Discussion
    Replies: 3
    Last Post: 09-09-2011, 09:00 PM
  5. Version after Ice Scream Sandwich to be called Jelly Bean!!!
    By skitzer9 in forum General News & Discussion
    Replies: 0
    Last Post: 09-09-2011, 07:07 PM

Posting Permissions