Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  

    Default Proximity Sensor Slow?

    So I was checking my voicemail.. and once I do it prompts me for my password..

    once i put my password in and put the phone to my ear.. i always seem to press the keypad with my cheek. I'm assuming the proximity sensor doesnt catch the phone coming to my ear on time..

    anyone else running into this issue?

    *on a side note.. i do have the SGP Oleophobic Screen Protector on it. I'm not sure if this degrades the sensor quality.

    Please advise!
  2. #2  

    Default Re: Proximity Sensor Slow?

    I have the exact same problem. No screen protector here. It just seems like the proximity sensor is too slow. My original droid had the opposite problem where it would blank the screen as soon as a call was placed and I would have to wave it around or hit the power button to wake it up. Both issues are super annoying.
  3. #3  

    Default Re: Proximity Sensor Slow?

    first off your doing it wrong....google voice = free visual voice mail = doing it right
  4. #4  

    Default Re: Proximity Sensor Slow?

    same issue here, so I make sure to un-press the keypad button, before I put it up to my ear and that usually works...

    the stock ear phones work great also for calls too...
  5. #5  

    Default Re: Proximity Sensor Slow?

    Yes, same issue, annoying. I am mildly hoping some of the savvy devs can get a resolution for this somehow, as I'll bet it's a software issue?
  6. #6  
    naddie's Avatar

    Posts
    23 Posts
    Global Posts
    55 Global Posts

    Default Re: Proximity Sensor Slow?

    I posted this on the XDA forums, too.

    I just found out why this is. The GNexus requires the phone to be upright before the proximity sensor will turn off the display. If it is laying flat, it won't work. Because of the complexity (the requirement to satisfy both conditions), it seems to react slower.

    The hardware itself isn't the problem. It's the stock dialer.

    To demonstrate, I made a video. I used the stock dialer and GrooVe IP (a dialer I use for Google Voice). GrooVe IP turns off the screen right away when I put my hand over the proximity sensor. Also, it does not cause accidental ear dialing.

    I hope Google will fix this in the next update. It's certainly by design (a bad decision), and can be fixed by software.

  7. #7  
    moosc's Avatar
    Grand Master Moosc

    Posts
    3,439 Posts
    Global Posts
    5,512 Global Posts
    ROM
    AKOP M4 old geezer theme

    Default

    Nope youmail is better
    Quote Originally Posted by jafels View Post
    first off your doing it wrong....google voice = free visual voice mail = doing it right


    Sent from my Galaxy Nexus using Xparent Cyan Tapatalk
    Google Nexus Class Devices (Nexus7, Nexus4, Galaxy Nexus lte VZW)...@moosc on twitter ...
  8. #8  
    qnet's Avatar

    Posts
    1,671 Posts
    Global Posts
    1,675 Global Posts
    ROM
    All stock right now

    Default Re: Proximity Sensor Slow?

    Yeah, I have the same issue. It's never happend on a regular call but, happens all the time when I call my credit union and have to key in inputs.
  9. #9  

    Default Re: Proximity Sensor Slow?

    Try putting the top (earpiece) edge of the phone to your ear first, then pivoting along that edge to bring the mic toward your face. Sounds more complicated (and slower) than it is, but allows you to hear the earpiece immediately while also getting the sensor close to your face before your cheek hits the touchscreen. I got used to this approach pretty quickly and haven't done any accidental keypad pressing in a while.

Posting Permissions

B