Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 33
Like Tree3Likes
  1. Thread Author  Thread Author    #1  
    sahmd's Avatar

    Posts
    29 Posts
    Global Posts
    42 Global Posts

    Default Can't connect to camera?

    I've done some reading and haven't seen this one discussed yet -

    I got my GN a couple of days ago and have had some battery issues like everyone else. This seems to be slowly improving as i run the battery through a couple of cycles, so i was just going to live with it.

    However, today my phone went through one spontaneous reboot (which didn't happen with my Droid X until it was about one year old) and, more annoyingly, has now refused to open the camera and given me a "Can't connect to camera error" message three separate times. This happens if I swipe left on the lock screen to directly access the camera AND if I try to open the camera from the app drawer.

    I am running stock OS, no messing with the bootloader or rooting.

    Has anyone else experienced this? Any fixes? I'm thinking that if Best Buy is open tomorrow (12/26), I'm going to head in and exchange it.
  2. #2  
    XLR8NSS's Avatar

    Posts
    3 Posts
    Global Posts
    5 Global Posts

    Default Re: Can't connect to camera?

    Mine has not rebooted on it's own but, I did get the "Can't connect to camera error" today so you aren't alone. I had to reboot in order to use the camera again.

    I am running the stock OS but, unlocked/rooted.

    No clue why it did it and no idea if there is a fix. I'm new to this android stuff! lol
  3. #3  

    Default Re: Can't connect to camera?

    Same here on the can't connect issue. I had to reboot to make it work again. Had it happen 3 times today. Argh.
  4. #4  
    5h4un360's Avatar

    Posts
    208 Posts
    Global Posts
    210 Global Posts
    ROM
    Codenameandroid 1.3

    Default

    Happened to me once, not rooted

    Sent from my Galaxy Nexus using Tapatalk
  5. #5  

    Default

    Me too. Very frustrating. Not rooted.

    Sent from my Galaxy Nexus using Tapatalk
  6. #6  
    tjubb's Avatar

    Posts
    151 Posts
    ROM
    Skyraider Athena

    Default Re: Can't connect to camera?

    Just started happening to me too in the last 24 hours. Annoying!
  7. Thread Author  Thread Author    #7  
    sahmd's Avatar

    Posts
    29 Posts
    Global Posts
    42 Global Posts

    Default Re: Can't connect to camera?

    I took the phone back to Best Buy today - they had not heard any other complaints of the same issue (although clearly it's not an isolated incident). They were very cool about it, though - they took one look at my phone and replaced it with no further questions. So far so good with the new hardware.

    I'll keep you updated.
  8. #8  

    Default Re: Can't connect to camera?

    Seems like a software issue to me. My bet is your hardware swap will make no difference.
  9. #9  
    eth555's Avatar

    Posts
    66 Posts
    Global Posts
    271 Global Posts

    Default Re: Can't connect to camera?

    I had it happen to me, I believe it was after I opened the app launcher and swiped to close the camera app; at least that is my theory. I have not closed the camera app this way since, and have not had this problem, maybe it is just a coincidence.
  10. #10  

    Default Re: Can't connect to camera?

    Happening to me too, not rooted. No pattern noticeable. Has happened at least 6 times. Sucks a lot - by the time the phone is rebooted, moment definitely has passed.
  11. #11  

    Default Re: Can't connect to camera?

    I have been having this problem periodically over the past two months with my Samsung Nexus Galaxy. I must shut off the phone and turn it on again in order to use the camera which is very annoying and time consuming. Has anyone found a solution? Thank You
  12. #12  

    Default Re: Can't connect to camera?

    I've had this problem for about a month. I have an LTE Nexus. I was running stock rom, but unlocked and rooted. At first a battery pull or power cycle would fix it, but It got progressively worse and now I cannot use my camera at all. I have done dozens of hard resets. I've unrooted and re-locked my phone. Nothing fixes it anymore. I either get an error message "cannot connect to camera", the camera app force closes or, usually, the screen just flickers and nothing happens. Very frustrating. Is it possible this is just a software issue that an update will fix?
  13. #13  

    Default Re: Can't connect to camera?

    Quote Originally Posted by NexiiUnite View Post
    I've had this problem for about a month. I have an LTE Nexus. I was running stock rom, but unlocked and rooted. At first a battery pull or power cycle would fix it, but It got progressively worse and now I cannot use my camera at all. I have done dozens of hard resets. I've unrooted and re-locked my phone. Nothing fixes it anymore. I either get an error message "cannot connect to camera", the camera app force closes or, usually, the screen just flickers and nothing happens. Very frustrating. Is it possible this is just a software issue that an update will fix?
    If that was my phone, and a factory reset doesn't fix it, I'd call Verizon for a replacement.
    Semper Fi
    I love my Moto X 2014!
    Take better pictures with your cell phone camera...http://www.bigshotmoms.com/
  14. #14  

    Default Re: Can't connect to camera?

    This happened to me today for the first time. I had the camera app open and ready to shoot some video when my wife asked me to hold the baby. I pressed the power button to turn off the screen without leaving the camera app. When I turned the phone back on, I got the "cannot connect to camera" error. Had to power cycle phone to get my camera back.
  15. #15  
    Jet300's Avatar

    Posts
    311 Posts
    Global Posts
    410 Global Posts

    Default

    Quote Originally Posted by snrsuave View Post
    This happened to me today for the first time. I had the camera app open and ready to shoot some video when my wife asked me to hold the baby. I pressed the power button to turn off the screen without leaving the camera app. When I turned the phone back on, I got the "cannot connect to camera" error. Had to power cycle phone to get my camera back.
    Same issue for me. Was at the Grand Canyon a couple of weeks ago when this started to pop up. Was taking a ton of pics and had to be conscience of not letting the phone lock with the camera app open. Otherwise I had to reboot. Needless to say I was very distracted by the scenery. After the third reboot I just set the auto lock for 5 minutes. Only had to reboot two more times after that after locking the phone on my own. Ugh

    Worst part was my wife kept ribbing me over rebooting while her D3 was rock solid taking blue.tinted photos of the Canyon ... Heh heh
  16. #16  

    Default Re: Can't connect to camera?

    I've had the same issue happen to me 3 times, albeit with a GSM unlocked GNex. I've determined what the problem was for me: I'd swipe left at the lockscreen to boot into camera then hit the home button before the camera has fully loaded. After that, no response from the camera.

    Essentially it seems to be because the app is closed suddenly, I think, and chances are it's a driver issue. I have no solution for it though, except to let the camera do its thing before closing it. :P
    If I've been of assistance help me get some more Dropbox space http://db.tt/AL3XE4e2
  17. #17  
  18. #18  
    JustinTiburon#AC's Avatar

    Posts
    56 Posts
    ROM
    Vicious JB 4.1.1

    Default

    Quote Originally Posted by NexiiUnite View Post
    I've had this problem for about a month. I have an LTE Nexus. I was running stock rom, but unlocked and rooted. At first a battery pull or power cycle would fix it, but It got progressively worse and now I cannot use my camera at all. I have done dozens of hard resets. I've unrooted and re-locked my phone. Nothing fixes it anymore. I either get an error message "cannot connect to camera", the camera app force closes or, usually, the screen just flickers and nothing happens. Very frustrating. Is it possible this is just a software issue that an update will fix?
    I would have relocked and talked to verizon. Never had a problem with mine.

    Sent from my Galaxy Nexus using Tapatalk
  19. #19  
    jakkzen's Avatar

    Posts
    5 Posts
    Global Posts
    6 Global Posts

    Default Re: Can't connect to camera?

    I haven't had reboots at all yet, but my camera did the same thing today. I have stock 4.02 unlocked/root. I rebooted and all is well again.
  20. #20  

    Default Re: Can't connect to camera?

    Quote Originally Posted by jakkzen View Post
    I haven't had reboots at all yet, but my camera did the same thing today. I have stock 4.02 unlocked/root. I rebooted and all is well again.
    Yep same here. Was shooting a video and wanted to gmail it and it flipped out...
    A somewhat colorful guy with a mildly checkered past....
  21. #21  

    Default Re: Can't connect to camera?

    Same here. Rebooting works, but not for long. Stock 4.0.2 not rooted.
  22. #22  

    Default Re: Can't connect to camera?

    Mine is Alcatel 918N which showed "Cannot connect to camera" error about two days ago. It's a 2.3.6 android. I have somewhat solved the problem by connecting my phone to a pc thru a USB cable and scan my phone SD card using IObit malware fighter. I turned off the phone before pulling out the USB cable. I turned on the phone and viola the error was gone. Hope this help you.
  23. #23  

    Question Re: Can't connect to camera?

    How do you do a reboot?
  24. #24  
    dmmarck's Avatar
    Retired Moderator

    Posts
    10,928 Posts
    Global Posts
    10,930 Global Posts
    ROM
    What do you think?

    Default Re: Can't connect to camera?

    Quote Originally Posted by Shlebs12 View Post
    How do you do a reboot?
    Turn the device off completely. Turn it back on.
  25. #25  

    Red face Re: Can't connect to camera?

    Holding down the volume/power/back button worked for me!!!!!! Just make sure you hold them down for longer than 30 seconds.
    (The first time I did not hold down long enough, so it did not work.) Second attempt, I held for longer than 30 seconds and it worked!

    Thanks!
    Thanked by:
Page 1 of 2 12 LastLast

Posting Permissions