1. Stamponephoto's Avatar
    So I was very surprised the first time I tried to use Google maps on my Verizon Gnex the first time that I cannot zoom in on a map. I work in NYC and when I open the app it comes up with a view that shows a little less than half the island. It's a lot of streets and very few names. I expected to be able to zoom in closer to an area to be able to see street names and even points of interest, but I couldn't. Pinch to zoom did nothing and the "+" was grayed out. I looked around the settings and I could not find anything that would fix this. This is ridiculous, this inability to zoom basically breaks the app for me. This is supposed to be a "Google experience" phone and yet I don't have the same functionality in Google maps that I did on my little Palm Pre+.
    Please help, I am a freelance worker and I am in a different part of the city every day. I depend on Google maps to help me get around areas I am not as familiar with.
    02-05-2012 12:54 PM
  2. RIMMAN's Avatar
    Just went into google maps and pinch to zoom worked as did the double tap to zoom in. Running 100% stock nit rooted GNex.
    02-05-2012 12:58 PM
  3. Stamponephoto's Avatar
    Maybe I didn't explain myself properly... My problem is not that pinch to zoom does not work, it is that I can not zoom into the map as much as I should be able to. Google maps is limiting me to a very "pulled back" map. I am attaching a screen shot to illustrate my point. This is a shot of central park in NYC. I am zoomed in as much as the app will let me (notice the + is grayed out) yet most of the steets don't even have names on them because I am so far away. I know that you can get closer on other phones, and I don't know why I can't get closer on my Gnex
    02-06-2012 12:31 PM
  4. Danv1369's Avatar
    What version of Maps are you using. I did a search for Central Park in NY NY and I can zoom in very close using pinch to zoom or the buttons. Your map looks a little different then mine does. My streets are yellow but yours are grey?
    02-06-2012 02:35 PM
  5. BSG75's Avatar
    Maybe I didn't explain myself properly... My problem is not that pinch to zoom does not work, it is that I can not zoom into the map as much as I should be able to. Google maps is limiting me to a very "pulled back" map. I am attaching a screen shot to illustrate my point. This is a shot of central park in NYC. I am zoomed in as much as the app will let me (notice the + is grayed out) yet most of the steets don't even have names on them because I am so far away. I know that you can get closer on other phones, and I don't know why I can't get closer on my Gnex

    You're on the Terrain layer. That doesn't zoom as far. Click Layers (the thing that looks like stacked cards) and uncheck Terrain.
    Stamponephoto and Nickerz like this.
    02-06-2012 02:46 PM
  6. greydarrah's Avatar
    Mine zooms very tight, even on Central Park. Have you tried going to the Market and selecting Google Maps to see if an update is available? Also, what happens if you go into layers and select satellite? Can zoom closer in that mode?
    02-06-2012 02:46 PM
  7. TabGuy's Avatar
    I just went into maps and zoomed in on Manhattan and was able to zoom down to about 1/4 of a block using pinch to zoom. Only one street was visible at a time.

    Something's amiss with your maps.
    02-06-2012 02:49 PM
  8. jafels's Avatar
    You're on the Terrain layer. That doesn't zoom as far. Click Layers (the thing that looks like stacked cards) and uncheck Terrain.
    This
    02-06-2012 03:23 PM
  9. Stamponephoto's Avatar
    You're on the Terrain layer. That doesn't zoom as far. Click Layers (the thing that looks like stacked cards) and uncheck Terrain.
    Oh my god, THANK YOU!!!!!!
    That totally did the trick. This was driving me nuts. Much appriciated!
    Lorenzo Toluca likes this.
    02-06-2012 04:10 PM
  10. BSG75's Avatar
    Oh my god, THANK YOU!!!!!!
    That totally did the trick. This was driving me nuts. Much appriciated!
    You are welcome
    Lorenzo Toluca likes this.
    02-06-2012 07:26 PM
  11. Tony Walt's Avatar
    Just a note for others. I had to disable the terrain layer, then fully close out of google maps by removing it from the recent app list or 'ending' it in the task manager. Upon relaunch of google maps the zoom worked properly.
    02-26-2013 10:35 AM
  12. bob banson's Avatar
    I had a similar problem using HTC amaze 4g. Maps would not zoom in as close as I wanted. I
    Resolved the issue by going to settings/location/ and unchecking 2 boxes related to google
    Location info, and google search help. Not sure why turning those off helped me zoom
    But it did. Thought I.would share the info.
    03-23-2013 04:25 AM
  13. Lorenzo Toluca's Avatar
    Thank you very very very much.
    02-14-2015 01:14 AM
LINK TO POST COPIED TO CLIPBOARD