Page 1 of 2 12 LastLast
Results 1 to 25 of 26
Like Tree1Likes
  1. Thread Author  Thread Author    #1  

    Default WiFi Problem after 4.0.4 update

    Just updated my phone to the 4.0.4 update (via OTA) And everything seems to work just fine.

    But my new problem is that everytime i am on wifi, google play store would not download / update apps instantly. I usually have to wait at least 2 minutes before the blue "downloading......" bar starts to move. It stays on the blue / white line dashing across for about 2 min.

    I tested 4g, and it seems to work just fine. update and installing new apps downloads right after i click download or update.

    Weird thing is that before (with OS 402) both wifi and 4g would work just fine.

    I have tried doing a factory reset with clearing cache via bootloader and the problem still persists.


    Anybody else having this lag / delay with the app store with wifi? or is it time to try and see if i can get my phone switched?


    **UPDATE**

    Now even the Facebook app isnt loading pictures when i click on them.....it does the loading circle on the black screen for about 1 to 2 minutes then it finally loads......

    but switched to 4g, then most pictures i click would load right away.

    Tried to download an app with my sisters Nexus S on the same wifi network, (4.0.4 stock) and she was able to download instantly. Also with my moms Galaxy Note (stock) on the same wifi network.....again same thing...instantly. Its just my GNEX.

    Also did a speed test with the wifi on (to make sure that my wifi speed isnt at a dogs pace)
    Ping:58ms
    Download: 9.2mbps
    Upload: 1.3.mbps

    Thanks.
    Last edited by h2opoloplyr_11; 06-07-2012 at 12:10 AM.
    8525 / LG Vu / 3gs /Nexus one (ATT) / Captivate / Iphone 4 (ATT) / Droid X / Thunderbolt / Evo 3d / Droid Bionic / Galaxy Nexus / HTC One X
  2. #2  

    Default Re: WiFi Problem after 4.0.4 update

    I am noticing some of this, though quite intermittently.

    I still am not sure if I do see it, but the 2 times I noticed, I switched to 4G and things moved right along - as you mentioned. I'll keep monitoring mine to see it this continues ..
  3. #3  

    Default Re: WiFi Problem after 4.0.4 update

    I'm having an issue similar to this, although not with the Play store. When receiving a text with a picture, the picture will not download while on WiFi. The other problem I'm having is that new gmail messages don't seem to be coming through as they should. I've had to pull to receive messages a bunch of times.
  4. #4  

    Default Re: WiFi Problem after 4.0.4 update

    I'm suffering from this problem as well. Never had the problem with the leaked update.
  5. #5  
    _JKK_'s Avatar

    Posts
    616 Posts
    Global Posts
    617 Global Posts
    ROM
    Redemption ROM

    Default Re: WiFi Problem after 4.0.4 update

    Try forgetting the network by long-holding on its name in the settings.

    Also, I may be wrong, but I think that Verizon only downloads photos over their network as that's the only one they can assure security over. I remember reading about that.
  6. #6  
    tayswg20's Avatar

    Posts
    130 Posts
    Global Posts
    223 Global Posts
    ROM
    Imo lk

    Default Re: WiFi Problem after 4.0.4 update

    I also have been having this issue Wifi issues with D-link router But it just happens with my d link router at home and not any where else. I'm also rooted and i've tried a few different ROMS with no change
  7. #7  
    ScandaLeX's Avatar

    Posts
    485 Posts
    Global Posts
    11,176 Global Posts
    ROM
    Stock

    Default

    It may not be a problem specific to your network or phone. My SG2 (Sprint) ICS 4.0.4 does the same thing. Connected to wifi 99% of the time and downloads of any kind don't start right away.

    Even using apps like tapatalk don't pull in replies to subscribed threads unless I open the app first.
    Same with gmail. Have to open it to receive mail. None of this was a problem before ICS.

    Tappin' from my SGP 5.0
  8. #8  
    tayswg20's Avatar

    Posts
    130 Posts
    Global Posts
    223 Global Posts
    ROM
    Imo lk

    Default Re: WiFi Problem after 4.0.4 update

    Quote Originally Posted by h2opoloplyr_11 View Post
    Just updated my phone to the 4.0.4 update (via OTA) And everything seems to work just fine.

    But my new problem is that everytime i am on wifi, google play store would not download / update apps instantly. I usually have to wait at least 2 minutes before the blue "downloading......" bar starts to move. It stays on the blue / white line dashing across for about 2 min.

    I tested 4g, and it seems to work just fine. update and installing new apps downloads right after i click download or update.

    Weird thing is that before (with OS 402) both wifi and 4g would work just fine.

    I have tried doing a factory reset with clearing cache via bootloader and the problem still persists.


    Anybody else having this lag / delay with the app store with wifi? or is it time to try and see if i can get my phone switched?


    **UPDATE**

    Now even the Facebook app isnt loading pictures when i click on them.....it does the loading circle on the black screen for about 1 to 2 minutes then it finally loads......

    but switched to 4g, then most pictures i click would load right away.

    Tried to download an app with my sisters Nexus S on the same wifi network, (4.0.4 stock) and she was able to download instantly. Also with my moms Galaxy Note (stock) on the same wifi network.....again same thing...instantly. Its just my GNEX.

    Also did a speed test with the wifi on (to make sure that my wifi speed isnt at a dogs pace)
    Ping:58ms
    Download: 9.2mbps
    Upload: 1.3.mbps

    Thanks.
    I found a solution. At least it worked for me. Maybe it'll work for you as well. Wifi issues with D-link router
  9. #9  

    Default Re: WiFi Problem after 4.0.4 update

    That's strange. I'd suggest setting a static IP if you try connecting directly to the router again. I haven't seen this issue with my Asus router at all.

    Is the problem the same on 2.4 ghz and 5 ghz if you have a dual band router? It could be any of a number of things that just aren't playing well.

    Edit: I have seen an old issue crop up when trying to update apps, the one where it shows an update is available but all you get is the option to open it. It's happened for me on wifi and mobile data, but it may be something with the market itself on 4.0.4.
  10. #10  
    tayswg20's Avatar

    Posts
    130 Posts
    Global Posts
    223 Global Posts
    ROM
    Imo lk

    Default Re: WiFi Problem after 4.0.4 update

    Quote Originally Posted by Small_law View Post
    That's strange. I'd suggest setting a static IP if you try connecting directly to the router again. I haven't seen this issue with my Asus router at all.

    Is the problem the same on 2.4 ghz and 5 ghz if you have a dual band router? It could be any of a number of things that just aren't playing well.

    Edit: I have seen an old issue crop up when trying to update apps, the one where it shows an update is available but all you get is the option to open it. It's happened for me on wifi and mobile data, but it may be something with the market itself on 4.0.4.
    I did try using a static IP as well but that didn't work for me either. I also tried setting my phone to only 2.4ghz and not auto which made no difference either. Since my router is only 2.4 ghz i couldn't change it on the router. I even tried changing channels on my router one by one and rebooting the router and my phone after every change lol. But, so far it seems like the connectify me thing is working flawlessly. I keep my laptop on most of the time anyway so its not too big an issue. It saved me having to buy a different router and/or phone.
  11. #11  

    Default Re: WiFi Problem after 4.0.4 update

    If you have it working, best not to fuss with it then.
    tayswg20 likes this.
  12. #12  
    noseph's Avatar

    Posts
    45 Posts
    Global Posts
    772 Global Posts
    ROM
    Liquid JB, CM9 Alpha2

    Default Re: WiFi Problem after 4.0.4 update

    I started having wifi speed issues after 4.0.4 update. My download speed, when connected to either my Netgear 54g 2.4Ghz G or my Asus RT-N56U 2.4Ghz N, have dropped to ~2500kbps. My TouchPad running CM9 registers ~25mbps on the same access points. My Galaxy Nexus when connected to my Asus RT-N56U 5Ghz N registers ~21mbps. Would really like to be connected to 2.4Ghz instead of 5Ghz because of 5Ghz lack of range.
    Quidquid Latine dictum sit, altum sonatur
    CM-REMIX 4.4.2 VZW Galaxy Nexus - CM11 HP TouchPad
  13. #13  

    Default

    Quote Originally Posted by noseph View Post
    I started having wifi speed issues after 4.0.4 update. My download speed, when connected to either my Netgear 54g 2.4Ghz G or my Asus RT-N56U 2.4Ghz N, have dropped to ~2500kbps. My TouchPad running CM9 registers ~25mbps on the same access points. My Galaxy Nexus when connected to my Asus RT-N56U 5Ghz N registers ~21mbps. Would really like to be connected to 2.4Ghz instead of 5Ghz because of 5Ghz lack of range.
    I have an Asus RT-N66U and I do see the connection speed on 2.4 ghz vary all over the place, from the max 65 mbps (GNex maxes out at that on either 2.4 or 5) to as low as 6 mbps. On 5 ghz it's a stable 65 mbps. The N66U's firmware is crap at the moment, but it is interesting to see the same problem on the N56 which is a solid performer.

    It could be from interference on 2.4 ghz.
  14. #14  
    noseph's Avatar

    Posts
    45 Posts
    Global Posts
    772 Global Posts
    ROM
    Liquid JB, CM9 Alpha2

    Default Re: WiFi Problem after 4.0.4 update

    Quote Originally Posted by Small_law View Post
    I have an Asus RT-N66U and I do see the connection speed on 2.4 ghz vary all over the place, from the max 65 mbps (GNex maxes out at that on either 2.4 or 5) to as low as 6 mbps. On 5 ghz it's a stable 65 mbps. The N66U's firmware is crap at the moment, but it is interesting to see the same problem on the N56 which is a solid performer.

    It could be from interference on 2.4 ghz.
    I just find it strange that this started after the 4.0.4 update and my TouchPad (CM9 Alpha 2 0604 Official Nightly also 4.0.4) is a solid performer on 2.4.
    Quidquid Latine dictum sit, altum sonatur
    CM-REMIX 4.4.2 VZW Galaxy Nexus - CM11 HP TouchPad
  15. #15  

    Angry Re: WiFi Problem after 4.0.4 update

    I am having problems with the Verizon Galaxy Nexus even after the 4.0.4 update. My phone only randomly rebooted once, but the battery life is horrible. I have to recharge my phone 5 times per day minimum and thatís with the 2100mAH extended battery. I attribute all of my problems to the radio. The radio signal bounces from 4 bars to 0 bars all day long. The radio also jumps back and forth from 3G to 4G whether if I am using the Internet or not. The data will stall badly. I have the issue with the mic cutting out during phone calls. My friends tell me that during a call I am there one moment and gone the next. I didnít know what the issue was until I read about similar reports with other people. I also have poor Wifi range, the Wifi data stalls, MMS messages do not download and Google play store does not update apps when WIFI is turned on. This is the worst phone I have ever had, but I love the HD screen. Even the store reps witnessed how terrible my phone was with the poor signal and data stalls, and they told me that the 4.0.4 update would fix my problems. That was obviously a lie. I would leave Verizon but I get Unlimited talk/text/10GB of data each month for 100 bucks. I am in the Jackson, MS, market. I am hoping that another update will be released to fix these issues. I might purchase the HTC Rezound off Ebay because I am afraid that my plan will change to these new shared data plans if I sign another contract. I really want the Motorola Droid Razr HD. Plus, I heard that the Rezound has an excellent radio.
  16. #16  
    noseph's Avatar

    Posts
    45 Posts
    Global Posts
    772 Global Posts
    ROM
    Liquid JB, CM9 Alpha2

    Default Re: WiFi Problem after 4.0.4 update

    Quote Originally Posted by Emmanuel McDonald View Post
    I am having problems with the Verizon Galaxy Nexus even after the 4.0.4 update. My phone only randomly rebooted once, but the battery life is horrible. I have to recharge my phone 5 times per day minimum and thatís with the 2100mAH extended battery. I attribute all of my problems to the radio. The radio signal bounces from 4 bars to 0 bars all day long. The radio also jumps back and forth from 3G to 4G whether if I am using the Internet or not. The data will stall badly. I have the issue with the mic cutting out during phone calls. My friends tell me that during a call I am there one moment and gone the next. I didnít know what the issue was until I read about similar reports with other people. I also have poor Wifi range, the Wifi data stalls, MMS messages do not download and Google play store does not update apps when WIFI is turned on. This is the worst phone I have ever had, but I love the HD screen. Even the store reps witnessed how terrible my phone was with the poor signal and data stalls, and they told me that the 4.0.4 update would fix my problems. That was obviously a lie. I would leave Verizon but I get Unlimited talk/text/10GB of data each month for 100 bucks. I am in the Jackson, MS, market. I am hoping that another update will be released to fix these issues. I might purchase the HTC Rezound off Ebay because I am afraid that my plan will change to these new shared data plans if I sign another contract. I really want the Motorola Droid Razr HD. Plus, I heard that the Rezound has an excellent radio.
    Before you use Ebay you should check out and specifically . I have had excellent results there.
    Quidquid Latine dictum sit, altum sonatur
    CM-REMIX 4.4.2 VZW Galaxy Nexus - CM11 HP TouchPad
  17. Thread Author  Thread Author    #17  

    Default Re: WiFi Problem after 4.0.4 update

    Sorry I have been out for awhile. Busy with work and what not.

    But anyways. Yes I was using the same d link router before the 404 update and it worked fine. But after the update it went wonky!

    Thank you for all the suggestions and sorry that a few people are having problems as well!

    I finally fixed the problem. I went into the router settings and found out that my firmware on the router was last updated back in 09. It was a long shot, but it wouldn't hurt to update the firmware. Now running with current firmware and the app store is running back, to normal again.

    I suggest everyone to try and see if there is an update for your router and that might help.

    Thanks again everyone.
  18. #18  

    Default Re: WiFi Problem after 4.0.4 update

    Hi the problem is simple. Just change the channel from automatic to manual in your wifi router settings. playaround from 1to 6 and 12. your phone will start connecting to one of them. Mine was in 6 and now changed to 1 and now my gnx connects.
  19. #19  

    Default Re: WiFi Problem after 4.0.4 update

    Hi the problem is simple. Just change the channel from automatic to manual in your wifi router settings. playaround from 1to 6 and 12. your phone will start connecting to one of them. Mine was in 6 and now changed to 1 and now my gnx connects.
  20. #20  

    Default Re: WiFi Problem after 4.0.4 update

    You could be suffering from a Wi-Fi DHCP bug that appears to be affecting Android versions 2.1 - 4.x on several devices. The bug was reported to Google by Princeton University back in Sept of 2010. You can check out the device list and Android version on the open bug report (Last updated by Princeton on Sept 11, 2012) at

    For the techies you can check out Princeton University report on the bug at
  21. #21  

    Default Re: WiFi Problem after 4.0.4 update

    I just upgraded to ICS on my Atrix 2. I had the same problem. To fix it, I turned on wifi and I went into the advanced settings. I turned off the secure network notifcation. Now everything is fine. It is also called wifi activity check. I hope this helps.
  22. #22  

    Default Re: WiFi Problem after 4.0.4 update

    please help me.. i have this lenovo k860 mobile phone i try to connect at the wifi there is a signal on the phone but still theres no internet connection.
  23. #23  

    Default Re: WiFi Problem after 4.0.4 update

    I had same problem with my HTC Senasation XL, everything worked fine on mobile network, but when i turned off mobile network and turned on WiFi, some apps like facebook or gmail did not work correctly, mostly they did not show pictures or i couldn't access some sites in web browser(with message Web page was not found). My solution for this problem was:
    1. long touch on connected wifi network and press Edit (or something similar)
    2. change DHCP to Static
    3. write some IP address - default IP for my network was 192.168.0.156 so i changed it to 192.168.0.154
    4. i thing this is the most important thing: set DNS servers to free Google DNS servers - 8.8.8.8 for DNS1 and 8.8.4.4 for DNS2

    Since then everything works fine

    EDIT

    My router is D-Link DI-524
    Last edited by pumaikar; 12-17-2012 at 12:12 PM.
  24. #24  

    Default Re: WiFi Problem after 4.0.4 update

    same problem here, an unhacked Evo 4g LTE and the update makes anything that works via wifi useless, have to switch back to 3g or 4g to do anything online. I'm really getting tired of the very poor testing by android prior to releasing updates.....
  25. #25  
    ranblv's Avatar

    Posts
    9 Posts
    ROM
    Leedroid

    Default Re: WiFi Problem after 4.0.4 update

    Had the same problem here, I ended up changing the wifi channel on my router and hello blue bars without a problem.
Page 1 of 2 12 LastLast

Posting Permissions

B