1. biggbrother2's Avatar
    Yesterday at 6:30 PM I was home, connected to WiFi, and I sent two pictures to two different people via MMS.

    The first person is on AT&T (Galaxy SkyRocket). He received one picture immediately, and the second picture he just received it at 10:30 AM today (almost 16 hours later).

    The second person is on Verizon (iPhone) and she also received the first pick immediately and she received the second pic at 10:55 AM today. On my Gnex both messages are time-stamped 10:54 AM today.

    Each picture was a separate MMS, so I had sent 4 MMS total. Actually I sent 2 more to my brother and he's on T-Mobile but I haven't been able to confirm if he received them yet.

    When I sent the second MMS to each, I noticed that it stayed stuck on "Sending" for quite a while. Long enough that I switched to doing something else and forgot about it.

    I'm thinking maybe being on WiFi creats some disruption in sending multiple MMS. Has anyone else experienced a problem like this with their MMS? Any fix?
    06-20-2012 10:27 AM
  2. jamontoast1291's Avatar
    I also have this problem when sending MMS while connected to wifi. They don't send until I leave the area of the wifi network or manually turn off wifi. For some reason it can't automatically send it over 3G or 4G while connected to wifi. I don't know if it's a 4.0.x issue or Galaxy Nexus issue, but it's annoying nonetheless.
    06-20-2012 12:30 PM
  3. macten52's Avatar
    I also have this problem when sending MMS while connected to wifi. They don't send until I leave the area of the wifi network or manually turn off wifi. For some reason it can't automatically send it over 3G or 4G while connected to wifi. I don't know if it's a 4.0.x issue or Galaxy Nexus issue, but it's annoying nonetheless.
    -------------------------------------

    I believe that the Android OS always defaults to using WiFi in lieu of 3/4G. all of my previuos Androids alawys seemed to disable 3/4G whnever wifi was connected.
    06-20-2012 01:31 PM
  4. Revolutionary's Avatar
    -------------------------------------

    I believe that the Android OS always defaults to using WiFi in lieu of 3/4G. all of my previuos Androids alawys seemed to disable 3/4G whnever wifi was connected.
    It doesn't actually disable it -- it just defaults most data through wifi rather than over the mobile network. But for things like MMS, the data connection is still "on" -- otherwise you wouldn't be able to receive those messages.

    This was a known bug with some units before 4.0.4, and I'm pretty sure the release notes for 4.0.4 even mentioned this one as being fixed. I've never experienced it, but it sort of sounds like they didn't actually squash the bug.
    06-20-2012 02:41 PM
  5. pool_shark's Avatar
    I'm connected to wifi most of the time and I never have issues sending mms when connected to wifi.
    06-20-2012 04:55 PM
  6. biggbrother2's Avatar
    Apparently the bug was partially fixed because the first MMS to each individual was sent. It was the two following that apparently stayed in the "sending" status until 10:54 AM the next morning.
    06-22-2012 08:25 AM
  7. jamontoast1291's Avatar
    Apparently the bug was partially fixed because the first MMS to each individual was sent. It was the two following that apparently stayed in the "sending" status until 10:54 AM the next morning.
    Yeah I'm having the same issue
    06-22-2012 03:27 PM
  8. ejaymd11's Avatar
    I've had the issue on all of my Android phones. I think my big problem though comes down to the weak data reception in my apartment. Sometimes turning off wifi helps, other times it doesn't.
    06-23-2012 11:39 AM
  9. shaytoon21's Avatar
    i have had issues sending mms pics to any network, any phone from day one when connected to wifi. even after the recent update, it still has issues.

    for example out of 10 pics i send...maybe 2 of them will go through.

    i have to turn wifi off to send a pic.

    as for receiving, i have better odds of getting the pic but its still a hit and miss to where i have to turn wifi off, some times ill get the pic a minute later after doing this. if i dont get the pic, i have to tell the person to resend it which then i get the pic immediately.

    this is no bueno and google must address this asap and not wait 6 months.

    its these small things that matter greatly in which it makes the fruity phone superior.
    06-23-2012 01:14 PM
  10. biggbrother2's Avatar
    I agree. This is something that should easily be resolved through proper testing. This is especially ironic since Google seemed to go to great lengths to encourage WiFi use whenever possible in ICS.
    06-25-2012 07:58 AM
  11. zedorda's Avatar
    Easier to just use email for pics. I think I remember reading that MMS is going to be phased out soon anyway.
    06-25-2012 10:52 AM
  12. biggbrother2's Avatar
    E-mail is not as effective when you want someone to see a picture right away. The vast majority of people will see an MMS immediately. If you send them an e-mail, they won't see it until they check their e-mail, sometimes days later.

    Not everyone has a Blackberry on their hip and nowadays even that number is dropping... fast. While Gmail is technically "push e-mail", I find that very few people with Android phones respond to e-mail quickly because most don't have aggressive notifications set because it would destroy their battery life.
    06-25-2012 11:14 AM
  13. zedorda's Avatar
    Ahh so importance is not in them getting the pics but that they get them NOW and are interrupted in what they are doing just so they know that you have pics for them and leaving them the option of viewing them at their own leisure or later is just unexceptionable?

    I am one of those people that HATE picture mail because I have abunch of ed friends that think there are TONS of things everybody has to see because they find them so fascinating.
    06-25-2012 12:07 PM
  14. biggbrother2's Avatar
    So don't have to view the picture if you don't want to. It is the same type of notification as any SMS. Simply don't click the image to enlarge it.

    In fact, I believe you can contact Verizon and have them disable MMS entirely on your account.
    06-25-2012 01:18 PM
  15. zedorda's Avatar
    You can on feature phones but not smart phones.
    06-25-2012 04:20 PM
LINK TO POST COPIED TO CLIPBOARD