Results 1 to 15 of 15
  1. Thread Author  Thread Author    #1  

    Default Anyone having trouble activating?

    I keep timing out. Don't know if I should worry yet.
  2. #2  

    Default Re: Anyone having trouble activating?

    Did you follow the instructions EXACTLY? make sure to not turn on the phone AT ALL, until you called and activated the SIM.

    Mine activated perfectly!
  3. #3  
    XeeN's Avatar

    Posts
    12 Posts
    Global Posts
    15 Global Posts

    Default Re: Anyone having trouble activating?

    In the mail you should have received a verizon booklet with lots of cards inside, including the sim card. There are activation instructions. Call the number listed there and follow the prompts to activate your order for your phone number. Then you put in the sim, then you turn on the phone, then you wait. Took about 2-3 minutes for mine to activate, but you know it's working because when you power it on you see the 4GLTE logo appear for a few seconds and go away, then come back, etc. as it activates.
  4. #4  

    Default Re: Anyone having trouble activating?

    Yeah it took me a bit to activate mine. Forgot an account password then I tried to activate it online and had to call support for help. They were very helpful. In my opinion I should have done the activation from the phone and not online and the process might have been smoother.
  5. #5  

    Default Re: Anyone having trouble activating?

    They can't even find my account to activate it...
  6. #6  

    Default Re: Anyone having trouble activating?

    Yeah I spent about an hour on the phone with tech support today. Apparently my 4G SIM number had the last two numbers transposed in their system. Still couldn't get the 4G to work, so they sent me to a store to get a new SIM card. The minute I walked in the door, 4G all of a sudden started working. Horrendous process, but phone is great now.
  7. #7  

    Default Re: Anyone having trouble activating?

    I called the # listed and it said it wouldn't activate so i took it into store( wanted to make sure kept unlimited data anyway) and they had it activated within 10 min. I think it was all a ploy so you would go in store to buy accessories. They suckered me in for some screen protectors lol.
  8. #8  
    T_Virus's Avatar

    Posts
    49 Posts
    Global Posts
    66 Global Posts

    Default Re: Anyone having trouble activating?

    I have 2 s3's (32gb blue for me and 16gb for my wife). I followed the instructions, called the activation number from my old phone to active mine first, put the sim card, put the battery in and then nothing happens...screen is black. I thought it could be a low battery so plug in the charger for 5 seconds just to see if it was a drained battery but it's not drained and it was charging. I pulled out the batter and the sim card and put it back in and nothing still happens. blank screen which is odd. So I went online and notice my phone says pending order. WTH? Now my previous phone is disconnected and my new phone has a blank screen. I then tried to activate my wife's phone online and everything was going well and it even got to the page that shows the phone is activated but same thing, nothing happens after i put the sim card and battery in. What is odd is that Verizon online shows my line is pending and I can't activate it online. I logged out of Verizon and logged back in and now it shows my wife's line as pending...I checked my bank account and it shows that Verizon got paid already for my phone but is pending for my wife's phone. This sucks...Do I have to wait for both phones to be fully paid to Verizon until I can activate both of them?
  9. #9  

    Default Re: Anyone having trouble activating?

    Quote Originally Posted by T_Virus View Post
    I have 2 s3's (32gb blue for me and 16gb for my wife). I followed the instructions, called the activation number from my old phone to active mine first, put the sim card, put the battery in and then nothing happens...screen is black.
    The phone should work regardless of your status with Verizon. At the very least, you'll have a fully functional device with no voice or mobile data connection. Did you hold the power button down to turn the phone on?
  10. #10  

    Default Re: Anyone having trouble activating?

    I was not able to activate the SIM through the VZW website, but a call to their CSR got it going.

    One thing to look for, if the phone says it can't locate your SIM card, you have to press it in pretty hard to get it to click in. If you just press it in a little bit, it will feel like it is seated, but it needs to be pushed in all the way.

    -Suntan
  11. #11  

    Default Re: Anyone having trouble activating?

    My S3 activation was as smooth as silk yesterday. I logged into my Verizon Wireless account online. Clicked "Activate or Switch Device" and followed the simple instructions...no more than few clicks. Put in the SIM card and battery, turn on the phone, waited just a few moments. Done.
  12. #12  
    gafman's Avatar

    Posts
    24 Posts
    ROM
    Stock

    Default Re: Anyone having trouble activating?

    I forgot the password, but called VZW and they helped me out. She even stayed on the phone till my phone was working. To Alewood you needed the password for both phone and online.
  13. #13  

    Default Re: Anyone having trouble activating?

    Mine activated fine yesterday with no problems. Followed the instructions very carefully and did the call in vs. the online activation.

    My wife took hers to a Verizon store before I got home to activate it and they had some problems at the store. Ended up having to talk to tech support to get things going. Took about ten minutes and she was good to go.
  14. #14  

    Default Re: Anyone having trouble activating?

    I started by calling the activation number, and when it asked me to input my account password I forgot I had a different PIN for calling Verizon than I used through the website. So I mis-entered it twice and got put on hold for a CSR for about 10 minutes. When “Taylor” came on the line she helped me figure out I had a different password, and got that cleared up. Then she said she couldn’t activate my new phone if I still had my DX on (which I was talking to her on) and she said to hang up, power off the DX, put the sim card in the SGIII and then turn it on. I knew that wasn’t right, so I just hung up, called the activation number again with the correct password, and it activated flawlessly.

    It’s sad how incompetent Verizon CSR’s are, and how inconsistent they are from one to the next.
  15. #15  
    T_Virus's Avatar

    Posts
    49 Posts
    Global Posts
    66 Global Posts

    Default Re: Anyone having trouble activating?

    Quote Originally Posted by mizzoudrew View Post
    The phone should work regardless of your status with Verizon. At the very least, you'll have a fully functional device with no voice or mobile data connection. Did you hold the power button down to turn the phone on?
    That is what I thought too. Yeah I did hold the power button down but nothing happen. Since my original (previous) phone got disconnected as I activate for the new phone I couldn't call Verzion so I had to drive to my brother's house and use his phone to call Verzion. The first rep couldn't help me but the 2nd tech did and she had to change some things on my profile which was really odd as she asked if I was trying to add a new line/phone number and I told her no. But after that I was able to active both phones and got it done.
    Last edited by T_Virus; 07-10-2012 at 02:07 PM.

Posting Permissions

B