09-26-2016 01:08 AM
111 123 ...
tools
  1. AbundantChoice's Avatar
    So I see lots of threads about WiFi turning on randomly, but my problem is different.

    WiFi doesn't turn itself on, but it resolutely refuses to stay on once I turn it on and connect to a network. It'll work for a few minutes, then randomly disconnect from my network. Sometimes it'll reconnect. Other times it won't, and I need to manually toggle WiFi off then back on to get it to reconnect.

    This is when the phone is literally no more than 5 feet from the router, sitting on the desk next to the router itself.

    My router normally works with everything else flawlessly, and I turned off all the other Wi-Fi connecting objects to see if it was some sort of DHCP issue (it isn't). I also tried both the 2.4Ghz and 5Ghz connections to see if it was one or the other; it happens on both (and my router can run both simultaneously so it's not a 2.4 ghz device connecting and eliminating the 5ghz connection).

    Any advice? Is the WiFi antennae or chip or whatever in my new S3 hosed? Do I call for a replacement? Is there something obvious i'm missing in the phone settings or router settings that might be causing this issue?
    07-11-2012 10:43 PM
  2. AbundantChoice's Avatar
    Some additional info:

    Often, the WiFi icon dissapears and it goes back to 4G or 3G, but the notification pane says i'm still connected. But when I click the wireless network from the notification pane that says i'm connected to the network, the network says "not in range" (even though the phone is very near the router). The only way to reconnect to WiFi is to toggle WiFi off and back on.

    When this "not in range" problem happens, it can't see any networks at all, not just mine. Normally I see about 10 networks when I'm in my condo, when this thing happens everything dissapears, only my saved network shows up (and is marked OOR)

    Sometimes it does this after 5 minutes, sometimes after 15. I'm going to try other WiFi networks tomorrow and see if it's just my network or if it does this everywhere.
    07-11-2012 11:10 PM
  3. kwright817's Avatar
    Have you tried turning off the WiFi sleep function?

    Sent from my SCH-I535 using Android Central Forums
    07-11-2012 11:34 PM
  4. AbundantChoice's Avatar
    Have you tried turning off the WiFi sleep
    Yup, WiFi sleep is off. It also does it while I am using the phone, or tight in the middle of a download.

    I also tried turning wiFi power save off in the service menu, and that had no effect as well.
    07-12-2012 06:37 AM
  5. X10_Unit_1's Avatar
    Reboot both phone and router if you haven't yet.

    In the past, I have had this issue with my old droid x and transformer and it was the router causing the issue even though other devices like laptops connected just fine.
    rupesh setty likes this.
    07-12-2012 09:43 AM
  6. AbundantChoice's Avatar
    Rebooted both phone and router, doesn't seem to solve the problem. Also tried turning off all wireless security on my router, also didn't solve the problem.

    It's a bummer, because I love the rest of the phone.
    07-12-2012 01:15 PM
  7. mrvirginia's Avatar
    i have something similar to this on a ATT version. when i get home and toggle the WiFi on, it won't connect. i have to toggle it back off and then back on again. any ideas?
    07-13-2012 10:54 AM
  8. slopokdave's Avatar
    Same problem here... Not enough to annoy me, yet, though.

    Everything else @ home connects and maintains connection just fine.
    alanmwilliamson likes this.
    07-13-2012 10:59 AM
  9. AbundantChoice's Avatar
    Got the same problem on my work WiFi and on a friend's too. Occasionally if i'm on the WiFi settings page I can actually see the WiFi toggle button turn itself off and back on again, which is... odd.

    So I went into my local Verizon store (I pre-ordered in-store), explained the problem, and they're going to set aside a replacement out of the next shipment they get and call me when it comes in. No refurbs, no needing to FedEx the phone to Verizon Central or anything. They're getting more in next week, but they can't guarantee a Blue 32g will be in the shipment. They should know more Monday.

    Luckily, everything else on the phone works fine so I can wait until the replacement shows up. I can survive without WiFi for a week or two if necessary.
    07-13-2012 10:01 PM
  10. flenn's Avatar
    For kicks, turn off "n" and connect via 802.11g. I had this problem with my Droid X and after trying everything I could think of, turning off n worked. I think I had to run this way for a little while until they updated the router firmware. Worth a try to help troubleshoot...
    Idelgado782 likes this.
    07-13-2012 10:21 PM
  11. Idelgado782's Avatar
    My girlfriend has this problem a lot while at home. It acts as if the network is not in range and when it is connected it will automatically disconnect on its own and give a hard time to reconnect. It's actually annoying because I can tell there is something wrong with the WiFi connectivity. I hope there's a fix for it soon.

    Sent from a sexy a** Galaxy S III
    07-15-2012 08:09 AM
  12. dubge's Avatar
    I also noticed this problem this morning, I get the not in range, problem is 3g/4g is not so great in my house so this could be a major issue for me if it continues. It has happened a couple times before but not enough for me to really notice but this morning it was really bad and I toggled to get it to reconnect then it would say not in range again, I rebooted the phone and it seems to be fine for now
    07-15-2012 09:35 AM
  13. scuba561's Avatar
    Similar issue here. I have two new S3 phones (mine and my wife). At random times I can not get an IP address from my WIFI router. My xoom tablet connects with no problem. Sometimes I toggle wifi off/on (on the phone) and it works, some times it does not help. I have rebooted my phone and it connected then. Only to drop at some random time later.

    Hope we can all find a solution to this issue soon!
    07-15-2012 05:08 PM
  14. mikesmith's Avatar
    You could also try turning off mobile data. I feel like the 3G/4G either tries to take over for the wifi or if the wifi disconnects it switches to that. You won't be able to get MMS messages with it off but that's about it.

    Sent from my SCH-I535 using Android Central Forums
    07-15-2012 06:28 PM
  15. AbundantChoice's Avatar
    I tried disabling N on my router and forcing it into B/G mode and that didn't fix the issue either. I really hope it's a bum chip or antennae or something in my phone and the replacement coming next week will solve the issue, although the issue sounds identical to what Idelgado782 and a few others describe above.
    07-15-2012 07:40 PM
  16. scbower's Avatar
    I have had some wacky wifi things going on with my s3 too. I called verizon tech and she told me to power off, pull the sim card, wait 30 seconds, and insert sim and power back on. So far, so good, but it was just today...

    You might want to try it too. Never had a 4g phone before, so I didn't think about pulling the sim...
    07-15-2012 09:20 PM
  17. dubge's Avatar
    I am really starting to think it is just samsung and their god awful antennas
    07-15-2012 09:35 PM
  18. babracmmm's Avatar
    I called Verizon today and told them about how terrible the phone is at receiving wifi. I'll have full bars standing next to the router and walk 15 feet away and down to one bar. It loses connection all the time. Everything else (computer and Droid Incredible) receive just fine. She said there is an OTA fix coming in October. I told her there are people on the forums that have no problem so it must be hardware. They are sending me a new phone. Thanks Verizon.
    07-15-2012 09:57 PM
  19. scuba561's Avatar
    OK...It has only been 10 hours or so, but this app has seemed to fix my wifi issues:

    https://play.google.com/store/apps/d...ififixer&hl=en

    wifi fixer. I will post again in a day or two after I see if it has really fixed my connection problems.
    07-15-2012 10:52 PM
  20. Whydmer's Avatar
    I called Verizon today and told them about how terrible the phone is at receiving wifi. I'll have full bars standing next to the router and walk 15 feet away and down to one bar. It loses connection all the time. Everything else (computer and Droid Incredible) receive just fine. She said there is an OTA fix coming in October. I told her there are people on the forums that have no problem so it must be hardware. They are sending me a new phone. Thanks Verizon.
    OTA coming in October? They are really planning ahead... Or do things really take that long?
    07-16-2012 12:56 PM
  21. dubge's Avatar
    october!!! ya letting that info out should really help sales

    That wifi fixer app seems to just toggle wifi for you, I see it saying poor reception then it turns it off/on and it reconnects, not sure of the effect it will have on battery life but I will likely just leave wifi off. verizon doesnt want to fix it then I will use their network more

    I would bet this has to do with that stupid wifi crap they changed before the phone launched
    07-16-2012 08:20 PM
  22. judge34411's Avatar
    Suggestion (I am using Canadian phone equivalent to AT&T) but selections should be the same.

    Phone pad type *#0011# then select left hand virtual key. select Wifi bottom of that list click power save mode to off. Then just back out of there. See how that helps it worked for my issues.

    Of note when you turn off phone, and turn it back on you will have to reselect again.

    I noticed above someone did try this without success but here is the method anyway.
    07-17-2012 05:46 AM
  23. allanmclovin's Avatar
    I have noticed this problem as well... Luckily it happens maybe once or twice a week so it hasn't been too bad. Just annoying when I know that my router is working fine but it says out of range. P
    07-17-2012 06:39 AM
  24. Worlds2See's Avatar
    It's happening to me with increasing frequency. I have no idea why because it happens when I stay in the exact same spot. I really hope they come out with a fix soon or one of you awesome people come up with another suggestion!
    07-17-2012 06:54 AM
  25. dubge's Avatar
    well for anyone who just wants to use wifi to save battery life, I am not noticing any difference having wifi shut off and leaving 3g/4g on all the time, I might shut 4g off and see if that helps battery life
    07-17-2012 08:30 AM
111 123 ...
LINK TO POST COPIED TO CLIPBOARD