1. ibcop's Avatar
    Okay, I've noticed this happening pretty darn frequently and I can't seem to find the answer.

    I received an MMS picture via a user with an Iturd - I can see the preview in the messaging thread but when I click the pic to open, I get a black screen with "Load failed!" in red letters.

    I've checked all the settings I know of and now I'm unsure if this has happened with a non-Iturd MMS pic. I've disabled Wi-Fi and tried downloading via the mobile data connection but still no dice. I can email the pic from the messaging app to my gmail account and I can download it without any problems.

    Anyone had this issue??

    TIA!
    08-06-2012 02:35 PM
  2. ThatGuyLurkin's Avatar
    Are you using a different Gallery? And do you have an SD Card?


    ( I don't own this device, but possible answers)

    Sent from my LG-VM670 using Tapatalk 2
    08-06-2012 02:38 PM
  3. ibcop's Avatar
    Are you using a different Gallery? And do you have an SD Card?


    ( I don't own this device, but possible answers)

    Sent from my LG-VM670 using Tapatalk 2
    Hmmmmm.....I am using QuickPic vice the stock Gallery. I do have aSD Card as well. I wonder if the culprit is QuickPic.....sum beaches.
    08-06-2012 02:45 PM
  4. JWLthief's Avatar
    Is your mobile data on? Pull down on your notification bar. The only time this happened to me is when I was on wifi but I had my mobile data off. The text came in fine but the pic fit didn't show up until I turned the mobile data on
    Denise Farris and toadfang like this.
    08-06-2012 03:16 PM
  5. ibcop's Avatar
    Is your mobile data on? Pull down on your notification bar. The only time this happened to me is when I was on wifi but I had my mobile data off. The text came in fine but the pic fit didn't show up until I turned the mobile data on
    Mobile data is on....I sure can't figure it out.
    08-06-2012 03:50 PM
  6. ibcop's Avatar
    Okay, it must be a QuickPic thing as I just re-enabled the Gallery and now I can download the MMS pics.

    So, now that that is settled, anyone know of a setting in QuickPic that will allow MMS pic downloads?
    08-06-2012 03:59 PM
  7. lbkiml's Avatar
    Yes, it's quickpic. I had the same problem as you. I have the default gallery re-enabled just so I can see MMS pictures. I don't know how to set quickpic as the default for MMS.
    08-06-2012 04:07 PM
  8. ibcop's Avatar
    Yes, it's quickpic. I had the same problem as you. I have the default gallery re-enabled just so I can see MMS pictures. I don't know how to set quickpic as the default for MMS.
    Okay, thanks for the confirmation. I have deleted QuickPic and using the Gallery for now.
    08-06-2012 04:14 PM
  9. JWLthief's Avatar
    I use quick pic but I don't have this issue. My wife sends me pic messages from her iPhone all the time too
    08-06-2012 09:08 PM
  10. ibcop's Avatar
    I use quick pic but I don't have this issue. My wife sends me pic messages from her iPhone all the time too
    Well damn....wtf....
    08-07-2012 06:57 AM
  11. lbkiml's Avatar
    How did you make it open with QuickPic instead of Gallery?
    08-07-2012 09:02 AM
  12. Denise Farris's Avatar
    I've had this same problem... Turned ON my Mobile Data... It's works now....Thank you so so so much! I've called At&T, searched all over the web and driven 32 miles round trip 2 times for get help from the At&T store. I was told by the "professionals" Samsung Galaxy S3 and iPhones are not compatible. I kept telling them when I first got the phone I had no problems receiving photo text and now there is a problem... I will always refer to this site for future help. Very grateful and appreciative.
    Is your mobile data on? Pull down on your notification bar. The only time this happened to me is when I was on wifi but I had my mobile data off. The text came in fine but the pic fit didn't show up until I turned the mobile data on
    09-18-2012 09:53 AM
  13. Denise Farris's Avatar
    Worked for me! Thank you so much!!!!
    10-31-2012 10:06 PM
  14. HalizDad's Avatar
    Are you sure your friend isn't being a d!ck and sending you a 2-part pic that reads "Load Failed"? ...I did that to a friend with an iPhone for about 2 weeks...It was funny.
    11-01-2012 09:39 AM
  15. lbkiml's Avatar
    I've had this same problem... Turned ON my Mobile Data... It's works now....Thank you so so so much! I've called At&T, searched all over the web and driven 32 miles round trip 2 times for get help from the At&T store. I was told by the "professionals" Samsung Galaxy S3 and iPhones are not compatible. I kept telling them when I first got the phone I had no problems receiving photo text and now there is a problem... I will always refer to this site for future help. Very grateful and appreciative.
    Were you using QuickPic?
    11-01-2012 02:51 PM
  16. Lauren McKay's Avatar
    Can someone PLEASE help me....I still cant get my phone to download pics. My bf sends me pics all the time but it seems lately some of them wont download. I have my mobile data turned on&Ive tried with the wi-fi both on&off but still no success. And I have not clue what QuickPic is.
    11-07-2012 07:00 PM
  17. Bren Hudson's Avatar
    I need help too, same thing is happening.
    11-21-2012 09:26 PM
  18. XFaega's Avatar
    Are you guys receiving text with media from somone who has a iphone? If so they need to turn off imessaging so the media contents comes in normal instead of
    encrypted. This worked for me. When my friend said that everytime he sent a media file on his iphone it sent as a imessage. I hope this helps somewhat.
    11-25-2012 03:51 PM
  19. Kevin Bott's Avatar
    guys i need help to -- having trouble seeing pics even with mobile data on. have no clue how to "reenable the gallery" or what quick pic is or means
    11-26-2012 08:42 PM
  20. androidatic's Avatar
    Based on my research of this issue it appears that you can't download MMS over wi-fi. I learned this with the Smart Actions app on my old Droid Razr. I had Smart Actions set to turn mobile data off when connected to wi-fi and could never download MMS when connected to wi-fi.

    I downloaded Juice Defender on my GS3 and it did the same thing. It turned off mobile data when I was connected to wi-fi and I was unable to download MMS when connected to wi-fi. I turned off Juice Defender and I'm good to go.

    Maybe something you did is doing the same thing.
    11-27-2012 08:33 PM
  21. Lee Paik's Avatar
    I have Samsung Galaxy S3 with verizon. MMS message not work with WiFi. By turning Mobile Data on, it works. However, when WiFi is available, it is nice to have the carrier provide the option to use WiFi. I believe (at least found postingssome where) that the support the WiFi bysetting the use of packet data support.
    02-11-2013 11:00 AM
  22. wowcole's Avatar
    I don't use quick pic. I've turned off my wifi connection, turned on data download and still getting the message 'download failed'. My network provider is EE. They say its not a network fault. My partner uses the same phone and has 02 has the named provider. Same problem! If it's not a software a service provider problem then surely its and a handset problem. Does anybody have anything that will solve this.

    Tried the suggestions on both phones. Quickpic is not installed on either....Help please.
    03-17-2013 01:34 PM
  23. Philip Laura Kuiper's Avatar
    i turned my wifi off on my phone (tracfone unimax 671C) and turned on my mobile data and i was able to download my message! thanks for the help
    07-07-2015 05:41 PM
  24. Pommyau's Avatar
    I've had this problem lately, I think since changing to Aldi mobile. I tried Mobil data only, and some other suggestions, but in the end, cured it by restarting my phone. SIMPLE. And sorry Aldi.
    12-07-2016 12:32 AM
LINK TO POST COPIED TO CLIPBOARD