1. billf82's Avatar
    I am trying to import a digital certificate into the email app on my recently acquired Galaxy S3. Carrier is Verizon.

    The certificate is in a PKCS#12 (p12) file. I have put copies in the root of both the sdcard and the extsdcard. I have put copies in the Downloads folders on both of the above. The email app consistenly gives me the no certificate error message and tells me to put the certificate where it is.

    The certificate is not protected by an import password.

    Can anyone suggest what I might try?
    08-20-2012 01:30 PM
  2. GSDer's Avatar
    Have you tried importing it from the Security portion of Settings? (Where it says 'Install from device storage')

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    08-21-2012 12:07 AM
  3. billf82's Avatar
    As a matter of fact, I did. I found by experiment that the security settings import will work ONLY if the cert has an import password. Importing it there does not seem to make it available to the email client.

    I have found a solution. I installed Moxier exchange client which did succeed in importing my cert and does sign my email as it should.

    Bill
    08-21-2012 08:04 AM
LINK TO POST COPIED TO CLIPBOARD