1. Chris LeBlanc1's Avatar
    How do i remove the CB# that shows up in some of my text message bubbles? It's weird because it doesn't show up in all of my texts. Just certain contacts.
    01-08-2013 07:14 PM
  2. Vin's Avatar
    How do i remove the CB# that shows up in some of my text message bubbles? It's weird because it doesn't show up in all of my texts. Just certain contacts.
    I very much would like to know as well. Did it only start happening after the Jelly Bean update?
    01-09-2013 11:01 AM
  3. mgloss's Avatar
    You can't. Jelly bean update added that for some God forsaken annoying reason! Lol

    Sent from my SCH-I535 using Android Central Forums
    01-09-2013 11:21 AM
  4. radicalRWer's Avatar
    Yes this also happened to my S3 after the Verizon update to Jelly Bean.

    My wifes # on her Iphone does not show up however. Most all others do. It is annoying.
    01-10-2013 04:17 PM
  5. imhipper's Avatar
    Just like radicalRWer, the only time a callback # isn't added to the end of the text is from a iphone user.
    All other basic and android phones, and yes the person sending the text has callback # unchecked, automatically gets their # inserted at the end of their text after JB update.
    01-10-2013 04:34 PM
  6. leprechaunshawn's Avatar
    At the bottom of the settings in the stock messaging app there should be an option to enable call back number. Make sure that is unchecked and that should eliminate you including a call back number when you text someone.

    I have a GS3 and my wife has a Razr M, both are running stock Jelly Bean and have that option unchecked.
    01-10-2013 04:46 PM
  7. Ninja_T's Avatar
    Just got the G2 and am having the same problem. On both the stock message app and Handcent. I think it has to vary by phone. My old phone, Droid Bionic, was running JB 4.2.2 and it didn't have the callback issue. Only thing different with that phone was it had been rooted. I know people didn't enable the CB feature on their phone overnight so that's not the issue either. Hopefully someone comes up with a fix for this soon.
    01-11-2014 08:41 PM
  8. Davidoo's Avatar
    It all has to do with the settings of the SENDER. There is nothing you can do on your phone to turn it off. It WILL go away if the sender (android) turns it off. I asked everyone I know well and my family members to go into their settings and turn it off as leprechaunshawn said above, and the number is no longer there on texts received from them. This has always been the case, but for some reason, it was turned on by default in the latest update. Someone thought it was a good idea, even if you already see the number or identity of the person sending you the text, that you should see their number again. Got to wonder who they are picking to determine what goes in the updates!!!
    01-12-2014 09:14 AM
  9. LostInBis's Avatar
    Hi.... I have a Samsung Galaxy S3 and figured this out by going into my list of text messages, going down to the bottom and clicking the left-hand "button", clicking on "settings" while you are in "texting mode", and if you scroll down, it will say "Turn on/off callback number", UNCHECK this box and you've got it! Hope this helps.
    Noreen Gamble likes this.
    01-14-2014 11:44 AM
  10. Carolina_C's Avatar
    Unchecking (or turning off) the callback number option in "Settings" DOES NOT eliminate the call back number in text messages in Galaxy 4s.
    01-15-2014 04:31 PM
  11. GSDer's Avatar
    Unchecking (or turning off) the callback number option in "Settings" DOES NOT eliminate the call back number in text messages in Galaxy 4s.
    Re-read post #8

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    01-16-2014 01:33 AM
  12. Noreen Gamble's Avatar
    Thank you soooooo much!
    02-17-2014 02:36 PM
  13. nm9377's Avatar
    i have a verizon enact phone, and the cb# only comes up on one persons, so ask HER to uncheck the cb# on her phone so I dont see it anymore?
    05-01-2014 11:07 PM
  14. GSDer's Avatar
    Welcome to the forums!
    i have a verizon enact phone, and the cb# only comes up on one persons, so ask HER to uncheck the cb# on her phone so I dont see it anymore?
    Yes, that's what it would take.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    05-02-2014 12:37 AM
  15. Spagurl's Avatar
    Thank you so much. Was driving me crazy with my number attached to my text
    09-19-2014 11:30 AM
  16. mjl15's Avatar
    I was able to fix this on my Galaxy S7 Edge by doing the following:
    1. Enter settings.
    2. Select "Applications" under the "Phone" heading in Settings.
    3. Scroll down and select "Messages."
    4. Select "Callback number" and then toggled to "off."

    Thanks.
    12-13-2016 07:31 PM

Similar Threads

  1. Showing Call Back Numbers in Texts??
    By krazykal99 in forum Verizon HTC Rezound
    Replies: 12
    Last Post: 09-18-2012, 09:22 PM
  2. Figured out....phone number in text message sender name
    By corvette72778 in forum HTC EVO 4G LTE
    Replies: 1
    Last Post: 06-23-2012, 02:23 PM
  3. Only phone number displayed in text messages
    By PrinceBug in forum HTC Rhyme
    Replies: 0
    Last Post: 06-21-2012, 01:58 PM
  4. Phone number displayed with name in text messages?
    By MustangDan74 in forum Verizon HTC Rezound
    Replies: 8
    Last Post: 02-28-2012, 08:50 PM
  5. Numbers Next to Contact Name in Text Messaging
    By soccerplayer in forum Droid Bionic
    Replies: 2
    Last Post: 11-30-2011, 05:55 AM
LINK TO POST COPIED TO CLIPBOARD