Results 1 to 16 of 16
  1. Thread Author  Thread Author    #1  

    Default Galaxy S3 not syncing Google Contacts

    I bought my S3 on the 1st day it came out for Verizon and have loved it ever since. I use all of Google's services and sync them back and forth online. In August my phone and google contacts stopped syncing with each other. Attached is a screen shot. All other syncs work.... Does anyone have a way to get it fixed?
    Attached Thumbnails Attached Thumbnails Galaxy S3 not syncing Google Contacts-2013-01-28-09.44.00.png  
  2. #2  

    Default Re: Galaxy S3 not syncing Google Contacts

    I had that problem once before, and I think I fixed it this way:
    (From any Home screen) Menu button -> Manage apps -> All -> Google Contacts Sync -> Clear data.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  3. #3  

    Default Re: Galaxy S3 not syncing Google Contacts

    Quote Originally Posted by GSDer View Post
    I had that problem once before, and I think I fixed it this way:
    (From any Home screen) Menu button -> Manage apps -> All -> Google Contacts Sync -> Clear data.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    I agree to try this first. Also make sure you are not using VZW backup service as this has caused havoc on a few phones I and others I have owned.

    Last choice remove account reboot and add account back. Might and I mean might not using a Factory Reset

    Sent from my VZW Samsung Galaxy S3
  4. #4  
    paulsdv's Avatar

    Posts
    1 Posts
    Global Posts
    125 Global Posts

    Default Re: Galaxy S3 not syncing Google Contacts

    Any joy here I have the same issue...
  5. #5  

    Default Re: Galaxy S3 not syncing Google Contacts

    Paul,
    Your screenshot didn't come through.
    You're having the same problem - back in August your phone stopped syncing contacts with Google?
    You followed the suggestions that were mentioned and nothing happened?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  6. #6  

    Default Re: Galaxy S3 not syncing Google Contacts

    I do not find a an option to clear data via Google Contacts sync at all...my contacts stopped syncing a month ago...are battery pulls important for the S3? i'm an ex-blackberry user, those batteries had to be pulled a few times a month, but it was always helpful. In this case, when I try to sync the contacts, it simply stops syncing.
  7. #7  

    Default Re: Galaxy S3 not syncing Google Contacts

    If you're using the stock TouchWiz launcher, from any Home screen press the Menu button -> Settings -> Application manager -> All, scroll down until you see Google Contacts SyncGalaxy S3 not syncing Google Contacts-uploadfromtaptalk1364623906581.jpgSent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  8. #8  

    Default Re: Galaxy S3 not syncing Google Contacts

    I'm having the same problem. I tried the suggestion of clearing data. Kind of worried to clear account - afraid I'll not get anything back, as I do have most of my contacts now....just want to be able to sync my google contacts with my S3.
  9. #9  

    Default Re: Galaxy S3 not syncing Google Contacts

    I found when I did the upgrade to gingerbread the default for saving new contacts went to phone instead of google.
    Go to Contacts>menu>more>settings. Change "save new contacts to" Google. All sync works now.
    The contacts already saved to my phone will not sync. I sent them via gmail to myself and then saved in my contacts from gmail.
  10. #10  

    Thumbs up Re: Galaxy S3 not syncing Google Contacts

    I had this problem, so I deleted my google account and then reinstalled my account and everything started syncing. Hope this helps
  11. #11  

    Default Re: Galaxy S3 not syncing Google Contacts

    I had this problem as well. I tested it and the sync problem was only my phone ->google. I tried clearing the Contacts and re-syncing but that didn't work. I also looked for the setting in contacts to "save to google" but I did not have that option on my galaxy s3. I figured it out though! When you are adding a conact there's a little drop down menu that says "Phone" but tap it and it gives you the option of "phone" or "google contacts". Aha! I wish this was a default setting though, I don't want to have to remember every time. Edit: After I added one contact with google selected it stayed google for the next add contact. Woohoo.

    Last edited by J0ssi330; 06-22-2013 at 02:54 PM.
  12. #12  

    Default Re: Galaxy S3 not syncing Google Contacts

    If the "clear data" in the sync app idea does not work (it did not for me), it may be the issue where all your contacts are labeled "phone" or "sim" and have not been associated with your Google account. Use the technique in this video:



    Export all your contacts to something, whether it's to "USB" (which actually just saves to your phone's My Files (Apps > My Files > /storage sdcard0 and the file is there) or to an added SD card. Like in the video: Contacts app, menu button, export, etc.

    Then delete all your contacts in the Contacts app. Yeah, I know, you're nervous right now. Rightfully so, I was too. But remember, you just exported them all to a file that's sitting there on your phone, so you haven't, and won't, lost/lose the contacts.

    After your Contacts app is empty, do menu button, import from the same place you exported to, "SAVE CONTACT TO" GOOGLE (is it painfully obvious how important this aspect is?), and go find that file. Then all your contacts should have a little blue g next to them.

    At this point, the sync has likely already started and if you're viewing Google contacts (google.com/contacts) on your laptop you can watch it sync real time. If it's not auto-syncing, you can go to the Contacts app, menu button, Accounts, choose the Google one, and sync now.

    If this doesn't work, sorry I have nothing more. It worked for me and I'm stopping here
    Thanked by:
    GSDer 
  13. #13  

    Default Re: Galaxy S3 not syncing Google Contacts

    Note that in the video the user imported the contacts to the "Phone" rather than to the Google account - that might cause someone problems if they're following the video example rather than your instructions.
    But a very nice job, digging up the video and providing clear instructions - thanks.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 4
  14. #14  

    Default Re: Galaxy S3 not syncing Google Contacts

    You're protected on both the computer and phone end while you're playing with contact syncing. I just went through this, and you can restore your contacts on google/gmail on the computer end if you accidentally delete a few, with a pretty flexible time frame choice. And if you've exported your contacts on your phone, you have a file with all of those. The way that I just dealt with this was:

    1. If your google account syncing is turned on, turn it off on your phone for the duration of doing all the steps below.

    2. Clean up your contacts in google...I had about 300, and ended up with a lot less that I actually use when I was done doing this. This obviously isn't mandatory, it just lightens your load a bit *smile*.

    3. Make sure that the contacts on your phone are also in my google contact list. You can do this by carefully merging that export file that you created on your phone into your google contacts.and avoid dpulicates. This is using the "import" function in google contacts.

    4. Make sure that only the contacts that you want to see on your phone have phone numbers in them in your google contacts.

    4. Once you have your google contacts set up the way that you want them, delete all the contacts on your phone (remember that you have them backed up).

    5. Go to your google account on your phone in "settings" and press "sync contacts".

    6. All your google contacts should now be in your contacts app on your phone.

    7. While in your "contacts" app, use the Menu key to bring up "settings" there, and turn on "show only contacts with phone numbers".

    8. Now the only contacts that you see in your "contacts" app on your phone should be those with phone numbers, and you can now sync contacts when you need to and things should be fine since you have the same contacts on your phone as in google contacts.

    At this point, you can again back up your contacts on your phone if you want (export) and it will not overwrite any previous exports, since the file names created are serialized. Just in case something goes wrong. You can also use the export file on your phone to import into google contacts, should you need to do that. When you do an import into google contacts, it creates a group for that import, rather than immediately merging them into your contacts list, and you can merge them when you're ready, if you want to.

    Pretty flexible interface. The only part that I really object to is having to have all those google contacts on my phone, even though only the ones with phone numbers are displayed. But I'm sure in the scheme of the 16GB. on my phone, that's not a very large piece. And the results are simple, initially identical contact lists on your phone and in google contacts, and you can go from there.
  15. #15  

    Default Re: Galaxy S3 not syncing Google Contacts

    This worked perfectly for me. Thanks for posting this information!
  16. #16  

    Default Re: Galaxy S3 not syncing Google Contacts

    I too, have had this problem for a long while. It seems that it is started by adding a contact or by editing an existing contact from the phone. I found that all the previously mentioned solutions only half worked or temporarily worked. I find that by going into the app manager and resetting TWO apps that it would fix the sync issue. I forced stopped the Contacts app and then deleted it's data. Then I force stopped the Contacts Storage app (right below it on my phone) and also deleted it's data too... like I said, this fixes my sync issue but how do I fix the issue that causes that, the creating or editing of contacts which begins this mess? I temporarily don't do such from my S3 but only do such using a tablet or pc... Anyone?

    Posted via Android Central App
    Samsung Galaxy Note 10.1 2014 Edition (WiFi)
    Samsung Galaxy Tab 2 10.1 (WiFi)
    Samsung Galaxy S3 (AT&T)

Similar Threads

  1. Google Sync Not Syncing my Contacts
    By sydewayzsoundz in forum Sprint Galaxy S3
    Replies: 1
    Last Post: 11-25-2012, 11:02 PM
  2. Galaxy S3 not syncing with google tasks
    By SMM78 in forum Verizon Galaxy S3
    Replies: 0
    Last Post: 08-07-2012, 03:37 PM
  3. HTC EVO Does Not Sync Google Calendar
    By matthewriley in forum HTC EVO 4G
    Replies: 9
    Last Post: 02-24-2012, 04:52 PM
  4. HTC Inspire suddenly not syncing Google Contacts
    By whitenack in forum General Help and How To
    Replies: 0
    Last Post: 04-22-2011, 08:43 AM
  5. Can't sync google contacts
    By Complex Pants in forum HTC EVO 4G
    Replies: 1
    Last Post: 08-12-2010, 04:12 PM

Posting Permissions

B