1. skbk's Avatar
    Hi all,

    I was on Sprint with a GS2 for the last 10 months. GS2 died so I moved onto GS3 with Verizon on Tuesday. There was some kind of software update it did automatically so I'm assuming I'm on Jelly Bean now.

    So far I'm super happy with the S3 experience, except my damn wifi won't connect automatically/ stay connected. The worst thing is that I have to re-enter the password every. single. time. What is the deal?! I use the wifi network at the office as well as at home, and usually I need to check to make sure the wifi is connected when I get to work/home. It doesn't drop once it's connected, but I find it extremely annoying to have to check the network and to re-enter the password each time. Can I AT LEAST get the password to save? I've never had this problem with my S2, or iPad, or laptop, or desktop, so I'm pretty sure it's not my wifi. I'm a little shocked that this wifi thing is such an issue with S3... I've searched different forums but haven't found anything about a settings menu to save passwords. Not able to access the service menu either.

    Any help would be gratefully appreciated. Thank you so much!
    02-07-2013 07:43 PM
  2. PJRed2008's Avatar
    I'm pretty sure there's a setting to keep the password. I connect to two networks, my home and my car, and have no problem with auto connect and both are encrypted. I'd go through the phone setup again. I know that doesn't help a bunch.

    Also, when I got my SIII I received two OTA upgrades, the second was JB so you may not be there yet. Go into settings and manually check for the version you have, or check for upgrades.
    02-08-2013 11:11 AM
  3. anabela 1120's Avatar
    Hi all,

    I was on Sprint with a GS2 for the last 10 months. GS2 died so I moved onto GS3 with Verizon on Tuesday. There was some kind of software update it did automatically so I'm assuming I'm on Jelly Bean now.

    So far I'm super happy with the S3 experience, except my damn wifi won't connect automatically/ stay connected. The worst thing is that I have to re-enter the password every. single. time. What is the deal?! I use the wifi network at the office as well as at home, and usually I need to check to make sure the wifi is connected when I get to work/home. It doesn't drop once it's connected, but I find it extremely annoying to have to check the network and to re-enter the password each time. Can I AT LEAST get the password to save? I've never had this problem with my S2, or iPad, or laptop, or desktop, so I'm pretty sure it's not my wifi. I'm a little shocked that this wifi thing is such an issue with S3... I've searched different forums but haven't found anything about a settings menu to save passwords. Not able to access the service menu either.

    Any help would be gratefully appreciated. Thank you so much!
    11-21-2013 09:32 AM
  4. anabela 1120's Avatar
    I am having the same issue and I have at&t they want to factory reset my phone. I'm upset because if it wasn't always updating maybe I wouldn't be having this issue
    11-21-2013 09:35 AM
  5. AxlMyk's Avatar
    When you enter the password, check the box to logon automatically.
    11-22-2013 08:51 AM

Similar Threads

  1. Qpst PPP Um / AN Login/password *NOT* Saving!
    By Cody Johnson in forum Motorola Droid
    Replies: 1
    Last Post: 12-07-2012, 07:07 PM
  2. [Q] Force a sync for saved wifi passwords from Google?
    By r1fo in forum Google Nexus 7 Tablet (2012)
    Replies: 0
    Last Post: 09-13-2012, 12:50 PM
  3. Am i using wifi or not?
    By Lurch81#AC in forum Motorola Droid
    Replies: 4
    Last Post: 05-09-2010, 09:48 PM
  4. Wifi does not work
    By alphabets in forum Motorola Droid
    Replies: 7
    Last Post: 01-04-2010, 09:50 AM
  5. problem with google sign in: password not valid
    By sonali in forum T-Mobile G1
    Replies: 2
    Last Post: 06-20-2009, 10:39 AM
LINK TO POST COPIED TO CLIPBOARD