Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default Google Maps not working

    Hey everyone,

    My google maps was working perfectly fine about 2 weeks ago, and now won't find my location at all. It will give me the right directions, but no voice navigation, it doesn't follow my location following the route, and the marker for the car jumps around all over the place. I've tried uninstalling the updates, does the exact same thing. Rebooting the phone doesn't help either. I'm not rooted, and I need maps as I travel a lot and being lost is not cool. Anyone else have this problem on the verizon s3 and hopefully have any solutions?
  2. #2  

    Default Re: Google Maps not working

    Download a free app like GPS Essentials or GPS test to check if your GPS is working. You want to see if your GPS is connecting with multiple satellites, low radius, and stays connected. If you have issues it maybe your GPS radio is broken. If your phone is under warranty Verizon will replace it after you try a factory reset.

    Sent from my Nexus 7 using Tapatalk 4
    Thanked by:
  3. Thread Author  Thread Author    #3  

    Default Re: Google Maps not working

    I tried GPS test while sitting in my house. it said GPS was on and was accurate up to 30 feet. I'm going to probably go to the Verizon store, & hopefully they can give me some answers there. This is annoying, I love this phone, besides this issue.
  4. #4  

    Default Re: Google Maps not working

    Verizon will likely have you do a factory reset, meaning it will clear all data and all apps you have installed. Make sure you backup photos or anything else you want to keep.
  5. #5  
    dgcamero's Avatar

    Posts
    80 Posts
    Global Posts
    98 Global Posts

    Default Re: Google Maps not working

    Try tightening the small screws on the back of the phone (with battery cover off). Also, make sure VZW location services are turned off...they tended to do more harm than good.

    Posted via Android Central App

Similar Threads

  1. Why doesn't my Multi Photo Wallpaper work?
    By Bob Thebuilder in forum LG G2
    Replies: 10
    Last Post: 01-31-2014, 07:51 AM
  2. Reset Factory option not found (POWER - VOLUME DOWN buttons)
    By Emersonivo in forum T-Mobile Nexus S
    Replies: 2
    Last Post: 12-16-2013, 09:38 AM
  3. Replies: 1
    Last Post: 12-09-2013, 05:16 PM
  4. new and not able?
    By Daermos in forum General Help and How To
    Replies: 2
    Last Post: 12-08-2013, 11:43 AM

Posting Permissions

B