Results 1 to 4 of 4
Like Tree2Likes
  • 2 Post By wrxg33k
  1. Thread Author  Thread Author    #1  

    Angry Any news on connecting to WPA2 Enterprise on the S3 with 4.1.2?

    Of course the rest of the world is leaps and bounds ahead of Android apparently. We use WPA2 Enterprise at work (as many corporations do) and more and more people are navigating away from Apple and wanting Android due to the ease of use and the open source apps that many professionals use. Why can we still not connect to a WPA Enterprise network????? There is some post out there on how to do this using the PEAP, 801.xEAP and MSCHAPV2 but it does not work. Apparently this may have been fixed in 4.2.1 but I have not confirmed that with anyone, just read it in a post on another site. Does anyone have any solid information about this?
  2. #2  

    Default Re: Any news on connecting to WPA2 Enterprise on the S3 with 4.1.2?

    Dawn,
    Welcome to the forums!

    I can't speak for all Android devices (I don't remember my HTC Thunderbolt having Wi-Fi connection issues) but my Samsung Galaxy S3 is certainly picky about what it will/won't connect to.

    I don't have access to a WPA2 Enterprise connection, and when I worked at a large corporation they didn't allow any non-corporate devices on their network anyway (they had a dedicated Open network connection for guests and contract employees), so I won't be of much help other than to agree that the SGSIII is sub-optimal.

    Perhaps there's something in the Google Play Store that will help?

    Edit:
    SecureW2 JoinNow:
    Secure Access:

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    Last edited by GSDer; 12-19-2013 at 04:32 PM.
  3. #3  
    Golfdriver97's Avatar

    Posts
    13,578 Posts
    Global Posts
    13,853 Global Posts
    ROM
    Stock Moto X

    Default Re: Any news on connecting to WPA2 Enterprise on the S3 with 4.1.2?

    Have you tried changing the advanced settings in WiFi?

    From a Sprint Moto X

    Devices: Current: Nexus 5, Moto X, Galaxy Tab 2 (7.0); Retired: Galaxy S2 (Epic 4G Touch); Traded: Galaxy S3
    When I let go of what I am, I become what I might be - Lao Tzu
    Community Guidelines and also here
  4. #4  

    Default Re: Any news on connecting to WPA2 Enterprise on the S3 with 4.1.2?

    What issue are you seeing exactly? I'm a network engineer and work a lot with enterprise wifi. My galaxy s3 has no issues with connecting to a PEAP/MSCHAPv2 network. The only issue is that the phone does not auto select Phase 2 (outer method) as MSCHAPv2 and you must manually select it sometimes. In fact, I'm connected to a WPA2/AES 802.1X ssid right now with peap/mschapv2.
    Thanked by:
    GSDer 
    GSDer and Golfdriver97 like this.

Similar Threads

  1. Lag turning on screen from deep sleep.
    By gdanonym in forum Samsung Galaxy Note 2
    Replies: 14
    Last Post: 01-19-2014, 04:32 PM
  2. Will the Otterbox for the Note 3 fit my charging cable?
    By maxc50167 in forum Samsung Galaxy Note 3
    Replies: 3
    Last Post: 01-16-2014, 03:27 AM
  3. Replies: 2
    Last Post: 12-27-2013, 02:32 PM
  4. Used HTC One with a bad battery - worth it?
    By Baconwich in forum HTC One
    Replies: 14
    Last Post: 12-23-2013, 11:02 AM
  5. Trouble with Email Notification Settings
    By mbranco978 in forum Sprint Galaxy S3
    Replies: 0
    Last Post: 12-19-2013, 10:01 AM

Posting Permissions

B